1. midmofan's Avatar
    Well the issue I was having with my EVO and the market was similar, but not quite the same as reported on the forums. After working fine at first, I could nol longer update my apps. Would get the "unknown reason" error - 18. The error would not happen while installing and it never "hung up" just would get an install failed message.

    I had moved all the apps that I could move over to the SD card, but moving them back to phone didnt help. Tried all of the tricks here like clearing the caches and data and taking out and remounting card and nothing worked. Even tried deleting the app and reinstalling it, but that didnt work either. I could download NEW apps, but if it was one I had had on the phone at any point, i would not download. I couldnt even download the paid version of Aldiko after deleting the free version.

    So...moved ALL of the apps off the SD card back to the phone and then found could update some but not all of them and, once moved some back (and I need to do that with as many as I have) problem would start again

    So something obviously not playing right with the SD card. As I mentioned in another thread, neither IO or Astro would allow me to delete the .andriod_secure file which others have said is the culperate.

    What I eventually had to do is isolate the apps that seemed to be causing the problem, for me it was Pulse, Aldiko, and ShopSavy that would not update even after everything was supposidly off the card and would not reinstall even after i had deleted them. So, after I deleted the apps, I unmounted the SD card, then downloaded the apps again with the card out of the phone. THIS time the phone accepted the downloads with no problem and, as I have left them on the phone, the other apps, even ones on the SD card seem to be updating ok.

    IT appears then that SOME apps leave some sort of "cookie" (for lack of a better term) on the phone that, once you have put the app on the SD card the downloader looks always to the SD card to do something when you update or try to reinstall -- even if you have put the app back on the phone or deleted it all together. And, if there is some problem with the SD card somewhere, the download/reinstall fails with the error-18. Also looks like a few bad apps can mess up the card for everything.

    I am guessing that if i could have deleted the .android_secure file this would have also solved the problem but that just does not seem possible from the Evo anyway.

    So, IF you can find which apps are the problem, try deleting and reinstalling them with the sd card out of the phone and then dont put them back on the SD card if that works

    In all, quite a pain and hope fixed soon.
    01-28-2011 01:35 PM
  2. midmofan's Avatar
    Hallelujah! Success at last! The solution for the update problem and at least some of the installation problems (like angry birds rio) is as follows:

    First, hook your phone to a computer with a usb cable - need to have your phone in "disk drive" mode. Most likely your phone will at first say "charging only." you will have to click on this to pull up a screen that allows you to change it to "mount as disk drive." Note: this may take several attempts. If your computer does not recognize the phone as being hooked-up at first, unplug it and try again.

    Now, open the new drive that will appear on your computer (which, of course, is actually your phone's sd card).

    Next, locate the file folders named ".android_secure" (it should be near the top of the listings).

    Click on and open up this ". android_secure " folder and look for a file named "smdl2tmp1.asec"

    Delete it! Destroy it! Kick it out of your life! It's what is causing the problems!

    Unplug your phone. Phone will say something like "preparing sd card." It could take a bit but after that you can update all the apps including those on your sd card and angry birds and download Rio hassle free.

    This, IMO, is much better than the suggestions that involve deleting the android_secure file altogether since you DO NOT have to move your apps off of the sd card and then back on again for it to work!

    Credit goes to "the Engineer" who, near as i can tell, was the first to post a version of this fix. As there a a whole bunch of threads on this issue, please pass the fix on.
    03-24-2011 12:17 AM