10-26-2016 09:44 AM
65 123
tools
  1. Coresh's Avatar
    Hi all,

    We've upgraded successfully our two US Moto X Pure Edition devices to Marshmallow yesterday. After upgrade completed, the numbers of calling contact are not being recognized anymore, although these contact exists and saved in android's Contact app, and backed up in Gmail accounts.
    Also, all incoming and outgoing calls in the call log are not recognized, although they were recognized before the upgrade.

    This is very critical for us, since one of the phones is used as a business phone and it's crucial for us to know who's calling.

    Any ideas how to fix this?

    Posted via the Android Central App
    12-10-2015 02:36 AM
  2. Laura Knotek's Avatar
    That's strange. I haven't had that issue. Perhaps you'll need to do a backup and then a factory reset.
    12-10-2015 02:57 AM
  3. Coresh's Avatar
    Found this - wipe partition cache. Didn't try it yet, waiting for less drastic solution.

    https://productforums.google.com/forum/m/#!topic/nexus/uANuzYdsp8E;context-place=topicsearchin/nexus/category$3Acontacts-and-sync%7Csort:relevance%7Cspell:false





    Posted via the Android Central App
    12-10-2015 03:04 AM
  4. Coresh's Avatar
    Workaround solution that we've found : export contact to a csv file form the device. After doing that, you'll get an email with the file attached. Save it to Downloads directory, and re-import it again.
    This will fix the call log and calls recognition, but will also create duplicates, which sucks.

    Posted via the Android Central App
    12-10-2015 05:17 AM
  5. Coresh's Avatar
    Another workaround, that does not create duplicates, but does delete Call history/log:
    Go to Contacts info page, either by dragging it up to the App info or by manage it via Setup - >apps->contacts.
    Then, enter the storage section of the app, and press "clear data" and also "clear cache".
    After doing that, all your contacts will be deleted from your device, and call history will be cleared. Don't worry about that, because they the contact will start synching back to the phone from your Gmail/Google contacts. And that's it, problem fixed. Callers are being identified again in incoming calls and in call log (that unfortunately is now empty).

    Posted via the Android Central App
    12-10-2015 09:31 AM
  6. roee m's Avatar
    Hi all,

    We've upgraded successfully our two US Moto X Pure Edition devices to Marshmallow yesterday. After upgrade completed, the numbers of calling contact are not being recognized anymore, although these contact exists and saved in android's Contact app, and backed up in Gmail accounts.
    Also, all incoming and outgoing calls in the call log are not recognized, although they were recognized before the upgrade.

    This is very critical for us, since one of the phones is used as a business phone and it's crucial for us to know who's calling.

    Any ideas how to fix this?

    Posted via the Android Central App
    I have the same problem. Are you from Isreal?
    Did you find any solution?
    12-12-2015 03:03 PM
  7. Coresh's Avatar
    Yes, I'm from Israel :-)
    I did find a solution, but it's a bit technical.
    I found that the problem is that incoming calls are without a country prefix (in Golan telecom, at least..), while Google is backing up the contacts with County prefix included (i.e. +972). So incoming calls with no prefix are not recognized. The solution is to add an additional number with no prefix to each contact on the phone, and this is how you do it :

    1. Go to your Gmail account via PC/laptop, and export all contact to a. vcf file.
    2. Open the exported file with a file editor such as notepad++
    3. Manually replace the prefix +972 with 0 (zero) for all numbers that has this prefix. So for example a number like
    +972 525347568
    Will look like this after the replacement:
    0525347568
    4. After fixing all numbers with the +972 prefix, save the file.
    5. Copy the file to your phone. I did it by uploading it to Google Drive, and then downloading it to the phone
    6. Go to Contacts app on your phone, open the three dots menu on the upper right corner (or upper left if your on Hebrew), and select "import from vcf file"

    And that's it, you're done. Now every contact with +972 number will also have a number without a prefix. Incoming calls will be recognized, including in the call log/history.

    Let me know if it also fixed the problem for you too.

    Posted via the Android Central App
    Ilan Shchori and Ori Harel like this.
    12-12-2015 06:19 PM
  8. SaintlySins's Avatar
    This is a big problem for me too!
    I've about 1200 contacts, separated by business, friends, family and/or groups and subgroups.
    After this update, I've lost all new entries over last several weeks, there are now duplicate entries and they seem to be the contacts that I've added info to over the last year ... so now "Joe" has a contact with the basic info AND another contact with the additional info added over the last year.
    My contact list is now 3187 large!

    WTF?!?!

    I checked my old phone and this is not a problem.

    What a disaster.

    Reason enough to abandon the phone.
    Coresh likes this.
    12-13-2015 01:30 PM
  9. Ry's Avatar
    Is this a region-specific issue?

    Posted via the Android Central App on the Moto X Pure Edition
    12-13-2015 02:10 PM
  10. Coresh's Avatar
    Yeh, this is a really a huge critical bug. For now my workaround with the import file works, but I also have over 2000 contacts instead of ~1300.

    And another thing - if after the file import I merge the contacts in Gmail after they were synced, the contacts are again not recognized, because the merge removes the contacts numbers without a country prefix, and synch the change back to the phone!
    After this happened, I had to import the file again for the contacts to be recognized,and of course I didn't merge again in Gmail.
    This is really sucks!

    Posted via the Android Central App
    12-13-2015 02:14 PM
  11. Ry's Avatar
    Yeh, this is a really a huge critical bug. For now my workaround with the import file works, but I also have over 2000 contacts instead of ~1300.

    And another thing - if after the file import I merge the contact in Google, after the were synced, the contacts are again not recognized, because the merge removes the contacts without a country prefix!
    After this happened, I had to import the file again for the contacts to be recognized.
    This is really sucks!

    Posted via the Android Central App
    I'm curious if this is a Motorola-specific issue.

    Posted via the Android Central App on the Moto X Pure Edition
    12-13-2015 03:02 PM
  12. Coresh's Avatar
    SaintlySins, where are you from?

    Posted via the Android Central App
    12-13-2015 04:22 PM
  13. Coresh's Avatar
    Just found out about this little app that can do the prefix fix automatically for all phone contacts, instead of editing the export file manually:

    https://play.google.com/store/apps/d...d=angel.twitch

    Posted via the Android Central App
    12-14-2015 05:34 AM
  14. SuperG280's Avatar
    I have the same problem in my two motor 2° generation and I live in spain.it's not a region problem, it's global. I don't understand the solution. I need the international code (here in spain +34) to call in travels. Must I put the code or not?
    12-16-2015 06:02 PM
  15. Coresh's Avatar
    I think that in your case you'll need two numbers for each contact - one with country prefix and one without it.
    I didn't try it my self, but I don't think the application in my previous post adds number, looks like it fixes the existing ones that on the phone, so it might not be good enough for you.
    As I see it, you'll need to use my solution - export Gmail contacts to a vcf file, fix the numbers manually and import the file to your phone. This will create additional number for each contact you've edited.

    Posted via the Android Central App
    12-17-2015 02:47 AM
  16. hbar98's Avatar
    I've had this bug ever since I updated to 6.0, but I did something different that seems to help things. I was over at XDA and found a flashable zip over there that has the Nexus phone dialer and contacts. I flashed those, and after making sure that my contacts were showing up properly, I disabled the phone dialer and contacts app that came with the phone.

    *Note* Don't do this if you aren't comfortable with setting permissions, in case something goes awry. Also, make sure you change your default dialer (settings -> apps -> gear icon -> default apps) to the new dialer or else you'll have issues.
    12-18-2015 11:28 AM
  17. Ntchwaidumela's Avatar
    Found this - wipe partition cache. Didn't try it yet, waiting for less drastic solution.

    https://productforums.google.com/forum/m/#!topic/nexus/uANuzYdsp8E;context-place=topicsearchin/nexus/category$3Acontacts-and-sync%7Csort:relevance%7Cspell:false





    Posted via the Android Central App
    It's not drastic at all. It won't erase any of your info or settings. This really should be done every few months or so, especially if your device starts running slower. Do it!
    Coresh likes this.
    12-18-2015 05:26 PM
  18. Coresh's Avatar
    So I eventually went a head and did it, I wiped the partition cache. Indeed no data was erased, but this wasn't what fixed the contacts problem ☺
    12-19-2015 02:38 AM
  19. Sasha Medv's Avatar
    So I tried to wipe the cache partition, this didn't help. What solved the problem:
    I removed all google accounts (in Google settings), and then added them back. After 15 minutes during which I was sure my contacts were lost forever, everything returned to normal, and I even can see the contacts in past calls in the call log. Yay
    12-19-2015 01:41 PM
  20. Carlos Alba's Avatar
    Another workaround, that does not create duplicates, but does delete Call history/log:
    Go to Contacts info page, either by dragging it up to the App info or by manage it via Setup - >apps->contacts.
    Then, enter the storage section of the app, and press "clear data" and also "clear cache".
    After doing that, all your contacts will be deleted from your device, and call history will be cleared. Don't worry about that, because they the contact will start synching back to the phone from your Gmail/Google contacts. And that's it, problem fixed. Callers are being identified again in incoming calls and in call log (that unfortunately is now empty).

    Posted via the Android Central App
    Thanks very much... I had this same issue. MOTO X 2014 upgraded today to Marshmallow
    12-22-2015 08:33 PM
  21. Ryaan Johnson's Avatar
    Hi all,

    We've upgraded successfully our two US Moto X Pure Edition devices to Marshmallow yesterday. After upgrade completed, the numbers of calling contact are not being recognized anymore, although these contact exists and saved in android's Contact app, and backed up in Gmail accounts.
    Also, all incoming and outgoing calls in the call log are not recognized, although they were recognized before the upgrade.

    This is very critical for us, since one of the phones is used as a business phone and it's crucial for us to know who's calling.

    Any ideas how to fix this?

    Posted via the Android Central App
    What apps are u running.. I found cm security was causing me issues throughout all of mm

    Posted via the Android Central App
    12-22-2015 10:43 PM
  22. Coresh's Avatar
    I don't use Clean Master. It just unnecessary overloads the cpu and ram.

    Posted via the Android Central App
    12-23-2015 01:57 AM
  23. Laura Knotek's Avatar
    I'm curious if this is a Motorola-specific issue.

    Posted via the Android Central App on the Moto X Pure Edition
    I haven't seen this bug. My caller ID works exactly the same in Marshmallow as it did in Lollipop.
    12-23-2015 02:05 AM
  24. alon3232's Avatar
    Hi Sasha !!
    Great solution ! Saved mt day ! all other complicated offered and your solution is the most simple and Elegant - I will spread it and give you credit on every forum possible.
    Thanks again from ISRAEL
    AG
    12-23-2015 11:45 AM
  25. Coresh's Avatar
    Hi Sasha !!
    Great solution ! Saved mt day ! all other complicated sh*t offered and your solution is the most simple and Elegant - I will spread it and give you credit on every forum possible.
    Thanks again from ISRAEL
    AG
    Alon has apologized for using the "sh*t" word for describing other solution that were given here. Hence - I've edited this post of mine and removed my response to him.

    Posted via the Android Central App
    alon3232 likes this.
    12-24-2015 04:21 PM
65 123

Similar Threads

  1. Moto 360 in Good Condition for $70
    By bo_woods in forum Marketplace Archive
    Replies: 5
    Last Post: 12-21-2015, 05:50 PM
  2. Original Charger and cable
    By jimmiekain in forum Nexus 6P Accessories
    Replies: 5
    Last Post: 12-21-2015, 08:18 AM
  3. Pics not saving to sd card
    By riskybzns in forum Sprint Galaxy Note 2
    Replies: 2
    Last Post: 12-19-2015, 01:21 PM
  4. Replies: 1
    Last Post: 12-19-2015, 12:13 AM
  5. Replies: 1
    Last Post: 12-18-2015, 04:07 PM
LINK TO POST COPIED TO CLIPBOARD