1. dthomp99's Avatar
    For the past few months, my phone has been having problems staying connected to my home WiFi (no other hotspot has had any problems). No other device on the same network has the same problem. In attempts to fix this, I have: done a factory reset, wiped cache partition, and just the plain 'ol off-then-on attempt. Nothing I do seems to work! Someone please help. I can't keep using so much data!
    05-30-2016 12:18 AM
  2. anon(9691750)'s Avatar
    For the past few months, my phone has been having problems staying connected to my home WiFi (no other hotspot has had any problems). No other device on the same network has the same problem. In attempts to fix this, I have: done a factory reset, wiped cache partition, and just the plain 'ol off-then-on attempt. Nothing I do seems to work! Someone please help. I can't keep using so much data!
    Is your phone running an early version of lollpop? If it is then that might be the reason. If not, then it might just be a software issue. I'd contact the manufacturer and see if and try to get a replacement device.
    05-30-2016 12:52 AM
  3. dthomp99's Avatar
    I am running Android 4.4.4. I would try and get a replacement, but my warranty ended months ago.
    05-30-2016 12:52 PM
  4. doogald's Avatar
    I am running Android 4.4.4. I would try and get a replacement, but my warranty ended months ago.
    The Maxx 2 comes with a 12 month warranty, and Verizon did not start selling it until last November, and it never had 4.4.4. Do you have the older Droid Maxx rather than the Maxx 2? (This is a forum for the Maxx 2, not the original Droid Maxx.)

    One possibility: on your home network, you may be having channel interference or something similar. Try changing your router to a different channel (most people use channel 1, 6, and 11 on a 2.4 GHz network, because a WiFi channel actually spans about 5 channels. If it is 5.4 GHz, you can use just about anything.)

    If you are using WPA/TKIP for security, try changing to WPA2/AES. (If you are using WEP, DEFINITELY try changing to WPA2).

    Neither of these things will affect your other devices - they will see the change and automatically reconnect. (Also, sometimes restarting the WiFi access point/router will help.)

    If you have Bluetooth turned on, try toggling it off to see if that is interfering.
    Laura Knotek likes this.
    05-30-2016 03:09 PM
  5. dthomp99's Avatar
    I'm not sure what I have, the phone just says Droid Maxx. I will try to change channels when I can. Thank you.
    05-30-2016 04:00 PM
  6. dthomp99's Avatar
    The Maxx 2 comes with a 12 month warranty, and Verizon did not start selling it until last November, and it never had 4.4.4. Do you have the older Droid Maxx rather than the Maxx 2? (This is a forum for the Maxx 2, not the original Droid Maxx.)

    One possibility: on your home network, you may be having channel interference or something similar. Try changing your router to a different channel (most people use channel 1, 6, and 11 on a 2.4 GHz network, because a WiFi channel actually spans about 5 channels. If it is 5.4 GHz, you can use just about anything.)

    If you are using WPA/TKIP for security, try changing to WPA2/AES. (If you are using WEP, DEFINITELY try changing to WPA2).

    Neither of these things will affect your other devices - they will see the change and automatically reconnect. (Also, sometimes restarting the WiFi access point/router will help.)

    If you have Bluetooth turned on, try toggling it off to see if that is interfering.
    I've changed the WPA from "Both" to "WPA-1" and "WPA-2" and neither have worked. I also tried changing the name of my network. Bluetooth is off. Also, I changed the Bandwidth from 40MHz to 20MHz, no change.

    The connection status next to the name shows full bars until I try to connect, then it goes to one and says "Poor Connection."
    05-30-2016 05:15 PM
  7. Mikhail Libin's Avatar
    I had similar issues and searched everywhere on internet and then... I figured if it's Verizon then I have to start from there. Here is what I did and it worked. Log in: VZ Protect, Status, WiFi protection should be OFF. Problem is solved.
    Firstchild likes this.
    05-31-2016 02:10 AM
  8. doogald's Avatar
    I've changed the WPA from "Both" to "WPA-1" and "WPA-2" and neither have worked. I also tried changing the name of my network. Bluetooth is off. Also, I changed the Bandwidth from 40MHz to 20MHz, no change.

    The connection status next to the name shows full bars until I try to connect, then it goes to one and says "Poor Connection."
    What kind of router is it?

    Also, on the phone, what happens if you go into settings / wifi, tap the menu control bottom right and choose "advanced", and turn off "avoid poor connections"? Does that help?
    05-31-2016 10:32 AM
  9. dthomp99's Avatar
    I am not sure what you mean by what kind of router. Its just whatever AT&T U-Verse gave us. And the "avoid poor connections" option is already unchecked.
    akhtar nawaz likes this.
    05-31-2016 01:06 PM
  10. doogald's Avatar
    I'm not sure if this will help or not, but have you tried restarting in safe mode? After you long-press power to bring up the power off dialog, rather than tap the power off control, long-press it until it brings up the restart in safe mode prompt. If the problem goes away in safe mode, there is likely some sort of third party app conflict. Do the normal restart to bring the phone back up in normal, non-safe mode.

    Just note that sometimes home screen widgets get messed up in safe mode and you may need to set them up again. Otherwise, you won't lose any data.

    As for the gateway router, is there some sort of model number on the sticker (and a software version?) I don't have AT&T/UVerse, but I'm guessing that they have some sort of model number on it.
    badcat likes this.
    05-31-2016 02:37 PM
  11. dthomp99's Avatar
    Wow! That really worked! I was able to determine from the Safe Mode that my phone was not broken. Turns out, I had a VPN app I totally forgot about hidden away in my apps! Deleted it and BOOM! WiFi is working like a charm!
    doogald and badcat like this.
    05-31-2016 10:43 PM
  12. dthomp99's Avatar
    Wow. I feel really stupid. I thought it worked, but the problem is still there... I can connect and stay connected for like 30min every time I clear the cache partition.
    06-03-2016 07:29 AM
  13. SonDan's Avatar
    I had similar issues and searched everywhere on internet and then... I figured if it's Verizon then I have to start from there. Here is what I did and it worked. Log in: VZ Protect, Status, WiFi protection should be OFF. Problem is solved.
    When you say log in .. To what please?
    Firstchild likes this.
    06-13-2016 10:04 PM
  14. MI Miah's Avatar
    I'd just like to find out whether anyone with this problem has McAfee Mobile Security installed on their phone, as uninstalling this app seemed to have resolved the issue on my Medion LIFE X5020...
    07-03-2017 03:07 PM
  15. miqrogroove's Avatar
    Had the WiFi Disconnected error on a Verizon device every time. I did this to fix it:

    Settings
    Wifi
    Advanced
    Wi-Fi control history
    Security & Privacy
    Disable

    Confirm disable, then cancel reversiob.

    Solved for me!
    04-24-2018 12:45 PM
  16. freaky4u's Avatar
    When you say log in .. To what please?
    I have a Kyocera Dura Force running Android 7.1.2 that I purchased in early 2017.

    I have this same problem...go to connect to my network, connects and then disconnects immediately. Was intermittent before but it is all the time now. I read this thread and I have easily solved the issue for me.

    The post that says to log in, etc. I have an app next to my "settings" app that I just happened to see while going back to settings several times trying to fix this. It says 'Security & Privacy' and has a little lock icon on it as well as the Verizon 'V' that looks similar to a checkmark. I came to the conclusion that this is what the poster was referring to when they said Log In.

    I opened it and I have 4 rows with titles. The last one is 'Wi-Fi Security'. It says 'ON' and I opened that one. Another list opens and the last one says 'Manage Wi-Fi Networks' and also shows that I have some blocked networks. I opened that one and have two choices again, Blocked Networks and Allowed Networks. I clicked on 'Blocked' and low and behold my network was in that list. I checked the box next to my network and hit the Remove button that was at the bottom of the screen.

    I closed everything and went and connected to my network and I am back in business.

    I am not a techie type so sorry if this is long and drawn out. I do hope that it helps someone else out. Dang that we are so dependent on our devices now.
    07-23-2018 04:06 PM
  17. Murf_1's Avatar
    My phone is a Moto Z2 Play. This will not apply to everyone, but this is what finally fixed the issue for me. I tried the forget network, reset network settings, and messed with router settings to no avail. I had the phone for over a year without issues. Then I did a factory reset (due to bad advice from moto support, they thought it would allow me to get Oreo update - it didn't). Well you have to reinstall everything and try to remember the setup. I was guessing it may have been an app gone crazy so I started uninstalling apps that I wondered about. I have Cricket as my carrier. I was looking in the myCricket app. Settings > Device Settings > Cricket WiFi Manager. It defaults to On. I turned it Off and that fixed my issue. They should have it default to off and give a warning what could happen if you turn it on. Hope that helps out other Cricket users.
    lasagna larry likes this.
    09-13-2018 09:45 PM
  18. lasagna larry's Avatar
    I literally made an account to thank you

    Months of googling and trying all manner of things never fixed it, but this did

    Praise the lord
    10-01-2018 02:57 PM
  19. Firstchild's Avatar
    Thank you! I just went into my VZ Security app and found that my home network was blocked. this infuriates me because I did not block my home network, this is a Verizon app doing this. I can't imagine how much mobile data I have wasted since my home network got blocked by this app. Thank you so much for this advice my phone now stays connected to my home Wi-Fi.
    11-04-2018 05:45 PM
  20. Firstchild's Avatar
    Brilliant, Mikhail Libin! VZ protect had blocked my home network! I removed my home network from the blocked list and now my WiFi stays connected on my phone! Thank you, this has been driving me crazy.
    11-04-2018 05:51 PM

Similar Threads

  1. Where is my clipboard on my Moto e phone
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 12-18-2016, 07:49 PM
  2. Replies: 11
    Last Post: 05-31-2016, 12:10 PM
  3. Any other phones out there with "COM Port" capabilities?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-30-2016, 01:23 PM
  4. Best stock Android, unlocked phone on VZW?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-30-2016, 01:30 AM
  5. Why My phone is often covered with Ads?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-30-2016, 12:23 AM
LINK TO POST COPIED TO CLIPBOARD