1. p08757's Avatar
    The title says it all.

    I've reciently removed the unlimited text option from my family plan as we only send a few hundred text messages a month, and I added the Wi-Fi hotspot feature.

    I just want a way to make sending SMS's easier. Thanks!
    10-12-2010 08:21 AM
  2. p08757's Avatar
    Never mind. I just figured it out. Here is how:

    Step 1 - start composing a text message with Google Voice
    Step 2 - Hit your menu button
    Step 3 - Select Google Voice as your Default SMS client.
    10-12-2010 08:25 AM
  3. judasmachine's Avatar
    You will also want to go to your stock texting app, and turn off notifications in the settings.
    10-12-2010 09:39 AM
  4. Lacarno's Avatar
    are these instructions still accurate? Basically, I want google voice to be the default SMS application so it is used when I use voice command programs, etc.
    10-25-2010 09:08 PM
  5. GenericMessage's Avatar
    are these instructions still accurate? Basically, I want google voice to be the default SMS application so it is used when I use voice command programs, etc.
    That is correct
    10-26-2010 08:14 AM
  6. Callindril's Avatar
    When I hit compose and the cursor is in the address field, the menu button does nothing...

    If I select a contact and then hit menu, I get Call/Text/View Contact as my menu options..

    If I stat entering text, and hit menu, I get the same as above..Call/Text/View Contact

    Where is the option you saw to set your Default SMS client.

    This is on Google Voice app 0.4.2.8

    Thanks
    Cal
    10-26-2010 09:27 AM
  7. FlyingJ's Avatar
    Bump,

    I get the same thing and when trying to reset defaults from withing settings - apps - messages "reset defaults" is greyed out and can't be pressed.

    Anyone else figure this out?
    10-26-2010 12:10 PM
  8. vicw926a4's Avatar
    Borrowing from an exchange in a similar thread in the Google support forum, as suggested by Op ENkODE, I was able to set my DX to use Voice as the default app when generating a Text Message from Contacts, but if the Messaging App is used, it still goes through the Verizon path. That's good enough for me, as I don't really use Messaging as a pathway to generate Texts.

    Here is the method that was presented there, Edited a bit for clarity, with a comment from me in parenthesis:
    --------------------------------------
    Go to Menu > Settings > Applications > Manage Applications > Google Voice > Clear Defaults


    This will reset the default messaging client.

    (Note: My DX still showed No Defaults selected, so I didn't do anything there, except verify status)

    Exit back to the Home Screen

    Select Contacts, and long press on a previous contact, then select "Send Text Message". You should see a popup to select your default app. Just choose Google Voice as your new default.
    --------------------------------------

    This seemed to work properly for me. Now, when I select through Contacts, or Contact Search, texts do go to Voice. The only thing I don't quite understand is that when I go back to the Defaults Option selection, it's still greyed out.

    After a Power Cycle, conditions remain the same for me.
    10-26-2010 04:24 PM
LINK TO POST COPIED TO CLIPBOARD