1. Shindig187's Avatar
    I had my droid X rooted on froyo before the 2.3 firmware came out. After the update went thru, my device was no longer rooted, but superuser was still there. However, when trying to re-root, manually or using z4, it will state that it has re-rooted the phone, reboot and seem fine, but it isn't rooted. I have read this is due to having the old superuser in there, however, I am un-able to re-root to remove it (this is the solution I keep finding when looking for a way to remove the current superuser) I have wiped the system multiple times trying to get it back to stock and remove the superuser, but that has done nothing to help the re-rooting process. I have tried going thru the terminal to mount the file system as r/w, but continually I am denied. I found a forum posting about using RSD lite to flash the phone using a downloaded sbf file, but I'd like to see if there are any other options before I resort to that... any help would be GREATLY appreciated!
    03-31-2011 04:33 PM
  2. wildman's Avatar
    What update did you update to because there hasn't been any recent updates pushed to device? If you updated to 2.2.1 from 2.2 the only root app that worked was z4root and all other methods do not work... Try downloading 1.3 from http://forum.xda-developers.com/showthread.php?t=833953 and rooting with this, the version of superuser app shouldn't cause your issue.
    03-31-2011 08:49 PM
  3. Shindig187's Avatar
    What update did you update to because there hasn't been any recent updates pushed to device? If you updated to 2.2.1 from 2.2 the only root app that worked was z4root and all other methods do not work... Try downloading 1.3 from [APP] z4root - xda-developers and rooting with this, the version of superuser app shouldn't cause your issue.
    I've used the z4root and it continually tells me that it has rooted my phone and restarts it, however, superuser never asks me to give any programs access. Adfree, which needs root access, continues to not work. I opened up the Terminal emulator and still have a $ rather then a #. I had read on a different forum that this issue is caused by the superuser being an older version. Many say to just re-root the phone and remove it, however, mine doesn't seem to be re-rooting. I've even tried going thru root manager, removing superuser, or another program like the annoying madden/amazon bloatware, and it tells me that it is removed and to re-boot. However, when I re-boot, nothing was removed. One thing that's odd, is that under the "App Remover" there are 2 superuser.apk options.
    04-03-2011 08:06 PM
  4. Smitty_82's Avatar
    If your using Z4root 1.3 and that isn't working, you may just have to SBF. Can't think of any other ways to get around that. This is odd cause I know a lot of users have ended up with 2 SU apks and haven't had this issue.
    04-03-2011 08:12 PM
  5. Shindig187's Avatar
    If your using Z4root 1.3 and that isn't working, you may just have to SBF. Can't think of any other ways to get around that. This is odd cause I know a lot of users have ended up with 2 SU apks and haven't had this issue.
    Yea, I'm thinking that might have to happen... I've used Z4Root 1.3 a couple times now to no avail. It says that it gains access and roots it, however, after it re-boots it is clearly still not rooted. Thanks for all the help and suggestions, if there are any others I'd be glad to hear them, however I think I'm going to end up having to SBF it. Any one know of any walk through's? As this is my frist time doing it and I'd like to NOT brick my phone. Again thanks for all the help!
    04-05-2011 02:14 PM
  6. .46caliber's Avatar
    Yea, I'm thinking that might have to happen... I've used Z4Root 1.3 a couple times now to no avail. It says that it gains access and roots it, however, after it re-boots it is clearly still not rooted. Thanks for all the help and suggestions, if there are any others I'd be glad to hear them, however I think I'm going to end up having to SBF it. Any one know of any walk through's? As this is my frist time doing it and I'd like to NOT brick my phone. Again thanks for all the help!
    There's an SBF thread stickied on this forum. Check it out. There are good write-ups on MyDroidWorld as well.
    04-06-2011 08:59 PM
  7. Shindig187's Avatar
    Has anyone had the issue where it seems as if the SBF doesn't load and you can't click start? I can load the phone in, and it's seen, however, when I load up the sbf, the "start" button is still grayed out... I'm using RSD lite v 4.9 on win 7 x64.
    Thanks for any help.
    04-12-2011 10:41 PM
  8. NewAge's Avatar
    Sounds like it isn't recognizing phone. Did you install drivers and reboot into bootloader?
    04-12-2011 11:14 PM
  9. Shindig187's Avatar
    Sounds like it isn't recognizing phone. Did you install drivers and reboot into bootloader?
    Yup, bootloader is up and the most current drivers are in. RDS says it sees the phone and there is a bunch of info under "Device Properties", however after I search and load the file, there is no info under file properties. (I saw under a youtube video tutorial that there should be info under it). Under the "Model" it says "S Flash OMAP3630 MI" and under status it says Connected...
    04-12-2011 11:53 PM
  10. .46caliber's Avatar
    Try a different version of RSDLite.
    04-13-2011 06:55 AM
LINK TO POST COPIED TO CLIPBOARD