1. Sourabh Narayankar's Avatar
    I am using a Nexus 4 that I bought from US. The thing is suddenly from 10 - 15 days my mobile internet has stopped working on my Nexus 4. I dont get 3G as well as 2G data connections. The network state keeps saying Connecting for a long time and then finally says Disconnected. The 3G as well as 2G worked fine previously. I don't remember me making any upgrade or so in that duration too. Wifi works fine.
    I have already tried flashing factory image of jellybean 4.2.2. That dint help too. The problem remains the same even after that. And yes I use Vodafone services in India. I have tried different sim cards in my mobile but with no success. I don't get the data connection on any of the other sim cards too. My sim card works fine in other mobile tho, I tried on Samsung Galaxy S3 of my friend.

    Nexus 4 is of literally no use without the data connection. I hope there is no hardware issue.

    Do any of you guys encountered such a issue. Or what is there left that I can try.
    06-26-2013 06:15 AM
  2. Anirvan Karmakar's Avatar
    I'm facing the exact same issue from last 10-15 days. The phone has become useless and its frustrating. Please let me know if you find any solution.

    Regards,
    Anirvan.
    06-26-2013 04:24 PM
  3. 2defmouze's Avatar
    I'd try contacting your provider and asking for a replacement sim card.. If you haven't changed anything software wise, and even flashed the stock images and radio I don't know what else it could be besides hardware issue.

    Signal has been fine on tmobile, USA, here.

    Sent from my Nexus 4 using Tapatalk 2
    06-26-2013 05:33 PM
  4. fernandezhjr's Avatar
    Check with your provider to find out if possibly there has been an APN change.

    Sent from my Nexus 4 using Tapatalk 4 Beta
    06-27-2013 08:14 AM
  5. Sourabh Narayankar's Avatar
    Thanks for the reply guys...
    I have checked with the operator and checked the APN settings too. Everytihng is fine.
    My sim works in other nexus 4. I checked in a friends mobile. Any other suggestions...
    06-28-2013 08:48 AM

Similar Threads

  1. Data connection not working on Jelly Bean Rom
    By juaxoo in forum HTC EVO 4G LTE
    Replies: 10
    Last Post: 09-18-2013, 02:09 PM
  2. Nexus 7 accelerometer not working! Help please!!!!
    By joe smith8 in forum Google Nexus 7 Tablet (2012)
    Replies: 2
    Last Post: 03-17-2013, 10:02 PM
  3. Replies: 12
    Last Post: 01-24-2013, 08:17 PM
  4. nexus one on gps not working (anymore)
    By mysaturdayself in forum Google / HTC Nexus One
    Replies: 2
    Last Post: 06-08-2010, 01:36 AM
  5. Mobile data connection not working
    By alear in forum Verizon Droid Incredible
    Replies: 1
    Last Post: 04-29-2010, 12:13 PM
LINK TO POST COPIED TO CLIPBOARD