1. Mia Polso's Avatar
    Hi,

    I got my Note 8 yesterday and I love it, except for the part that "Ok Google" doesn't work at all. The settings are all correct, "Ok Google" is turned on, the voice model has been retrained, and the Google app is up-to-date, but it still doesn't work. Bixby works fine.

    Anyone has the same problem? Any solution would be greatly appreciated.
    09-08-2017 07:54 PM
  2. DARK Vader777's Avatar
    Strange, take it back, don't take a chance.
    09-08-2017 11:55 PM
  3. nizmoz's Avatar
    Factory reset phone and set it up again. Works for me.
    09-08-2017 11:59 PM
  4. Strawdawg2013's Avatar
    Mine gave me fits all day yesterday...some times it would work once after I rebooted...I read everything I could and tried the fixes without anything working more than once.

    Today, it worked perfectly every time...got me?
    09-09-2017 12:06 AM
  5. Mia Polso's Avatar
    Factory reset phone and set it up again. Works for me.
    Updated: Check my last comment to see the real problem and my solution. DON'T FACTORY RESET YOUR PHONE YET.

    ---------------

    Original comment: I second this. I suspect using SmartSwitch to switch from my old phone to the N8 did something weird to my phone. Now everything works perfectly as it should. Thank you so much!
    09-09-2017 02:36 AM
  6. cjsmoove's Avatar
    Update Google.
    09-09-2017 02:49 AM
  7. Mia Polso's Avatar
    Update Google.
    Before factory resetting my phone, I did update Google but it still didn't work. After the reset, I got Ok Google to work, but then I adjusted some settings on my phone, and it stopped working again. I figured out that my favorite medium battery saving mode prevented Ok Google from working because it closes all background apps. Now I know that Bixby works regardless of battery modes, and Ok Google only works without battery saving modes on my N8. Nothing was wrong with my phone to begin with, and all is good and right with the world.
    kitmo, recDNA, Amele and 1 others like this.
    09-09-2017 09:59 AM
  8. Roald Van Antwerpen's Avatar
    Okay I think I fixed the issue with the Note 8.
    On the Note 8 you have to go to a different place to remove Google from the optimization process.
    1. Go to Settings
    2. Select Apps
    3. Click on the three dot menu drop down.
    4. Select "Special Access"
    5. Select "Optimize Battery Usage"
    6. Scroll down and deselect Google.
    I also deslected all that start with "Google"
    As well as "OK Google Enrollment"
    It did not seem to work immediately, so I wiped system cache... That didn't seem to have an immediate effect, however, now a few hours later it's working just fine.
    I can go into Bixby, come out and say OK Google and it works every time.
    I have no idea what difference waiting a while did, but everything is working well now.
    09-26-2017 04:49 PM
  9. drquinones's Avatar
    I have the note 8 and i encountered this problem and it was driving me nuts. I searched and applied all the remedies i found online but they all failed. But i did find the solution.

    I used the battery feature the other day to save power. In doing so it turned off a bunch of features such as background network usage. I checked my battery setting and sure enough... i never changed it back. After making the adjustment and watching it turn all the features back on i tested. Immediately it began working again.

    Please do not factory reset. Try this first if you've been using the power saver features.
    10-30-2017 08:13 PM
  10. Cesynsky's Avatar
    There's a very simple way to make it work again. Just turn off the battery saving mode. This mode turns voice command off.
    11-11-2017 09:53 AM
  11. T Brown's Avatar
    Check your "save battery power" under "device maintenance" if it is on, it will disable the voice assistsnt
    11-26-2017 12:06 PM
  12. pianomanss87's Avatar
    I have the Note 8 with Verizon. Found this completely by accident. With the phone locked I say ok Google. Wait for it to beep an than say ok google ok google with no hesitation. This has worked for me for about a week now.
    11-26-2017 07:46 PM
  13. DARK Vader777's Avatar
    Click on google
    You'll see 3 lines at the bottom right click on them
    Then click on settings
    Click voice
    Walla
    11-26-2017 10:21 PM
  14. Baby_Doc's Avatar
    I have the Note 8 with Verizon. Found this completely by accident. With the phone locked I say ok Google. Wait for it to beep an than say ok google ok google with no hesitation. This has worked for me for about a week now.
    I wish it would work for me. If I do hear the beep after saying OK Google, I will wait a few seconds and then repeat OK Google. Sometimes it works, but sometimes it doesn't. I have trusted location turned off which seems to help, but it is still hit or miss. I am on Verizon, if that makes a difference.
    11-26-2017 10:34 PM
  15. AnotherInternetGuy's Avatar
    Before factory resetting my phone, I did update Google but it still didn't work. After the reset, I got Ok Google to work, but then I adjusted some settings on my phone, and it stopped working again. I figured out that my favorite medium battery saving mode prevented Ok Google from working because it closes all background apps. Now I know that Bixby works regardless of battery modes, and Ok Google only works without battery saving modes on my N8. Nothing was wrong with my phone to begin with, and all is good and right with the world.
    Many thanks. I forgot to switch off mid power saving mode recently and I've been outright embarrassed about not being able to find the solution.

    Would it kill Samsung to create a pop-up notification message saying "OK Google Command cant be used in power saving mode"?
    11-30-2017 07:51 PM
  16. flex flex's Avatar
    Ok note 8 customers, here is what I just figure out. You know we.all like to save battery by putting on power save modes, well when you power save mode you stop ok google from working, in order for it to work you need to turn off power save mode. Go to the settings app, select device maintenance, select battery and off, then it should work with no problem. Switch it back and forth with mid battery just to be on the safe side.
    12-09-2017 12:16 AM
  17. Baby_Doc's Avatar
    Ok note 8 customers, here is what I just figure out. You know we.all like to save battery by putting on power save modes, well when you power save mode you stop ok google from working, in order for it to work you need to turn off power save mode. Go to the settings app, select device maintenance, select battery and off, then it should work with no problem. Switch it back and forth with mid battery just to be on the safe side.
    No matter what I do, I can't get OK Goggle to unlock my phone on the first attempt. It usually takes two or three tries. I believe the first attempt (I hear the chime) opens up the Google app. Then I think I am waiting for the mic prompt to appear, before the next OK Google unlocks the phone. This problem occurs with Verizon, especially.
    12-10-2017 10:58 AM
  18. rvhs03's Avatar
    I spent quite some time playing with this, and while I have no idea what was causing it, I know how I fixed it. under your edge lighting settings, you can choose which apps get notifications. turn them all off and then only activate the ones you want. I turned them all off except the apps I use all the time and ok Google now works 100% correctly by unlocking my screen 100% of the time. hope this helps.
    12-13-2017 03:19 PM
  19. HTsurum's Avatar
    I was trying many things to make Ok Google work again..I was so frustrated! And when I finally thought it might have been the power saving mode that could be the cause and disabled it, Ok Google started working. Right after that I found this article. I wish there was some explanation in the oower saving settings..
    12-25-2017 04:53 PM
  20. Willars's Avatar
    Simple fix. Just change your text to speak from Samsung to Google.
    Settings....General management.... text to speak. Restart your phone and hey presto. Well it worked for me. I tried all other things suggested on here but they didn't work.
    aalupatti likes this.
    01-09-2018 06:50 AM
  21. Baby_Doc's Avatar
    Simple fix. Just change your text to speak from Samsung to Google.
    Settings....General management.... text to speak. Restart your phone and hey presto. Well it worked for me. I tried all other things suggested on here but they didn't work.
    I have Verizon. Perhaps, that's the difference that your suggestion didn't work for me. Once the OK Google app is open, the phone is then immediately locked, then the OK Google command works on the first attempt. Otherwise, it takes 2 or 3 attempts for it to unlock my phone and open up the app.
    01-09-2018 01:14 PM
  22. Triacona's Avatar
    None of these things will really work.
    It is a confirmed bug.
    Leave android auto on in the background, after using ok Google first, it will sound now using android auto.
    I think this is something to do with car mode setting not being done correctly in oreo...
    Therefore it's no car mode no prompt sound for you to speak
    07-27-2018 07:56 AM

Similar Threads

  1. Bixby Vision not working!
    By Bijan Hdr in forum Samsung Galaxy S8 & S8+
    Replies: 15
    Last Post: 04-03-2018, 08:28 AM
  2. Google Play Music randomly pausing
    By Face_The_Raven in forum General Help and How To
    Replies: 6
    Last Post: 09-12-2017, 01:37 AM
  3. Replies: 3
    Last Post: 09-11-2017, 04:15 PM
  4. Google Play Music & Music Flow Player
    By Face_The_Raven in forum General Help and How To
    Replies: 1
    Last Post: 09-10-2017, 01:43 PM
  5. Help
    By Neal Smith in forum Samsung Galaxy Note 8
    Replies: 7
    Last Post: 09-09-2017, 03:59 PM
LINK TO POST COPIED TO CLIPBOARD