05-02-2019 03:58 AM
102 12345
tools
  1. Awix301's Avatar
    I keep getting a message pop up on my screen saying "currently unable to download.please try later".
    I haven't got a clue what is trying to download because I physically haven't downloaded anything and nor can I see what is downloading.
    Anybody having or had the same message? Its well annoying.

    Sent from my GT-I9300 using Android Central Forums
    Just restore your message setting
    06-05-2013 09:26 AM
  2. philmiami's Avatar
    Just restore your message setting
    And how would that be?..........HARD reset?
    I have the same problem...doesn't do anything BUT I think it is the Auto Retrieve MMS and also while ROAMING since I am 1200 miles away from my home area, so (MetroPCS) is roaming voice/text/1Xdata on Sprint but when outside get 4G data (T-Mobile), so my model S3 has to switch back and forth between carriers (Sprint & T-Mobile)
    So it is not harming anything just a little annoying, but I will "build a bridge and get the f*** over it"......
    06-26-2013 05:21 PM
  3. okn0tok's Avatar
    Hey I didn't read to the bitter end of this but I can tell you why I get this error. Is your phone rooted? I get it because my phone is looking for updates. The first time it happened was when my phone was rooted and they were pushing the update to jellybean. So I had to un root, dl the update to 4.1.2 and then I never re-rooted, well I just rerooted today and guess what message is back!? I haven't worked on it yet but just wanted to say it could be this issue of your carrier pinging for auto updates.
    09-14-2013 01:21 PM
  4. Attalla's Avatar
    I had the same download error issue and I assumed its one of the apps I recently installed called "shut up button" and since I have uninstalled that app I haven't seen the error message. Hope this helps.
    GSDer likes this.
    10-01-2013 01:11 PM
  5. Kelly Cousins's Avatar
    my samsung galaxy s4 screen wont respond .. get a msg saying currently unable to download try later, i cant get into my phone... it rings and msg come throught, just cant get past home screen help
    11-24-2013 09:36 AM
  6. GSDer's Avatar
    Kelly,
    You could try booting into Safe mode and see if you're able to access the phone. It's possible that some app you recently installed is causing the problem.

    To boot into Safe mode:
    - turn the phone completely off
    - press and hold the Volume Down rocker (and keep holding it)
    - press the Power button until you feel the phone vibrate (usually 2-3 seconds)
    - keep holding the Volume Down rocker until the phone finishes booting
    You'll see 'Safe mode' in the lower left corner

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-24-2013 11:32 AM
  7. nori_nori's Avatar
    Hi, I had this issue. I solved it by deleting all my sms messages/threads. The only time I'd ever received this message, prior to the update, was when I was sent a mms message. Inthat instance the mms was never downloaded, and I deleted the message. I think, somehow during the update, the attempt to download this mms was reignited. Since deleting all sms/mms messages/threads I've not had this warning. I hope this helps. Thanks.
    01-14-2014 12:49 PM
  8. ohayyam's Avatar
    Think i have solved it. I had it, i had a picture message sent to me that would not download, just showed a download button. I deleted it and problem went away
    it solved my problems too...
    04-06-2014 01:15 AM
  9. Ashok Kumar K R's Avatar
    I too keep getting the same problem my screen saying "Currently unable to download.please try again later". And my device processing getting too slow when I using Internet. . Please give me a solution for this problem..
    06-13-2014 04:52 AM
  10. AxlMyk's Avatar
    Try the fix 2 messages before yours..

    AC App on SGS3
    06-13-2014 05:12 AM
  11. Vishnu Verma1's Avatar
    same problem i am also facing:
    what have to do for mms setting how?
    please tell.
    06-21-2014 01:23 AM
  12. eyezak76's Avatar
    Solved! I had the same problem. There was a mms that I had not downloaded, I deleted the message and bingo... no more annoying "currently unable to download" notifications.
    Cheers guys, wouldn't have sussed it without you lot :-)
    08-01-2014 07:11 AM
  13. Steve Waring's Avatar
    I had the same problem. Deleting the message thread with the problem image fixed it.
    08-27-2014 03:23 AM
  14. zegarot's Avatar
    noo if we keep bumpin this, someone will help us...

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    I have the same problem on my s5 .go to manage application and see if you disapled any programs .enable them back agian update them and see if that solve the problem
    12-28-2014 10:04 AM
  15. autoe77's Avatar
    I figured it out!! To rectify the problem permanently, go to your message settings and under MMS settings deselect auto-retrieve
    05-28-2015 08:02 PM
  16. Sid here's Avatar
    I have had also the same problem since last two week then i noticed that what happened when this error is poping up again and again i noticed that when i recive a picture message in inbox i mean in text message it says download and i can't see the image after that whenever i turn on my Wifi this error pops up you should better delete all your inbox messages you may also get one of that picture message that is trying to download. i hope this will work it worked for me.
    05-29-2015 03:19 AM
  17. ch41ky's Avatar
    After having trouble with kodi on my android box I decided to factory reset I am now unable to download kodi from my browser?? Anyone that can help please
    05-29-2015 05:06 AM
  18. gjagiello's Avatar
    This answer worked for me! I noticed I had an incoming message with an attachment that hadn't been downloaded, but was expired. Deleted the message -- sadly, I couldn't grab the file first -- and I no longer get that extremely annoying error.

    Thanks!
    05-30-2015 10:36 AM
  19. naumankhan's Avatar
    No need for factory reset.

    I also face the same problem and I fixed it by;

    1. Go to SMS settings.
    2. Select Multimedia Messages
    3. Uncheck the Auto Retrieve Option

    Hope it will work :-)
    06-11-2015 03:57 PM
  20. tony daquino's Avatar
    Make sure sim card data is enabled!
    07-10-2015 09:50 PM
  21. dontdrop_that's Avatar
    I just went into application manager and stopped all apps that was running. The ones I didn't stop was the ones that needed to run the phone. My phone is running a lot quicker though. Back to the problem it still happening.

    Sent from my GT-I9300 using Android Central Forums
    Mine does that to. Brand new s6
    07-16-2015 11:14 AM
  22. Andrei Woedy's Avatar
    I keep getting a message pop up on my screen saying "currently unable to download.please try later".
    I haven't got a clue what is trying to download because I physically haven't downloaded anything and nor can I see what is downloading.
    Anybody having or had the same message? Its well annoying.

    Sent from my GT-I9300 using Android Central Forums
    I have the same exact problem. Since the new update its been constantly saying that and i need it to stop soon.
    08-18-2015 05:19 PM
  23. GuinguetteStyle's Avatar
    Hello everybody!

    I have got the same problem like you for 1 week and I finally found what was wrong.

    These are some pictures that someone sent me by MMS which the cell phone couldn't download. Why? In my case, it is a French phone, so I disabled the mobile data because I am currently in the US.

    The mobile phone requires data to download the pictures, not the Wi-Fi. this is why I got everytime this tiring message : "Currently unable to download. Please try again later."
    So I deleted the MMS I received in the thread.

    I hope it'll do the same for you guys.
    Hope my message will be helpful.

    Excuse my French, I tried to do my best to explain to you the solution as good as possible.

    Regards,

    GS
    08-28-2015 12:33 PM
  24. HFLDev's Avatar
    i checked, it's not an OTA Update. if it is , he would ask u to download now or later. it's A GPS. trying to get info of ure location.
    cuz 1 min after this GPS popup.
    09-08-2015 08:38 AM
  25. Sameh Adel1's Avatar
    Hey Guys,

    I just wanted to share my experience with you all and hope it will be helpful. I have Note 3 updated to lollipop but I believe all Android phones are similar.

    First of all ANDROID IS CRAZY "Literally", you will not understand when the problem will happen to your phone and how to fix it, especially that the problems may be interrelated, and one fix may not be enough until you know really what is wrong with your phone.

    Now to the subject, my phone was getting this "unable to download" error message, then same time suddenly from no where I get an error on the notification menu "sign-in request" with Gallery Picture beside it, and when I click on this message it requests to log in with Picasa and then all google applications disappear from the phone, and when I go inside "Apps" (on the bottom right of your phone desktop) I found them disappeared from the inner folders of Google, then suddenly out of no where all apps get redistributed over the pages within Apps and Google Apps return back again distributed also. All of this besides when I was restarting the phone it was taking around 5 minutes to open phone's desktop.

    To fix the above I made Wipe data and factory reset more than 5 times in 2 days with no result.

    Then after some search I did the below fixing (after one more factory rest):
    1- Went to Settings - "General" Tab - Accounts - Google then click on the e-mail beside the Sync symbol, then scroll to the end of the page and uncheck "Sync Picasa Web Albums".
    2- Went to Settings - "General" Tab - scroll down to About Device - click on Software updates then uncheck "Wi-Fi only". (Of course this is going to charge if not subscribed to mobile data package).
    3- Went to Messages - click on menu - Settings - Multimedia messages, then uncheck Auto retrieve.
    4- Activate "Mobile Data" from notification menu and disable Wi-Fi.
    5- Restart the Phone.

    All of the above fixed my problems, but again we have to remember, Android is crazy, at least for me.

    Hope this is useful to somebody out there.

    Thanks
    Sameh Adel
    10-05-2015 01:57 AM
102 12345

Similar Threads

  1. Replies: 21
    Last Post: 08-27-2016, 02:12 PM
  2. MMS unable to Download?
    By tonksnatcher in forum HTC Hero
    Replies: 25
    Last Post: 06-19-2013, 08:32 PM
  3. Galaxy S II "currently unable to download" MMS
    By Raptor95259 in forum Samsung Galaxy S II
    Replies: 4
    Last Post: 10-07-2011, 05:18 PM
  4. Currently unable to download. Please try again later.
    By doobie581 in forum Verizon HTC Thunderbolt
    Replies: 3
    Last Post: 06-09-2011, 09:35 AM
  5. Unable to download (download unsuccessful)
    By elementfiftyfour in forum Samsung Moment
    Replies: 1
    Last Post: 12-27-2009, 06:21 PM
LINK TO POST COPIED TO CLIPBOARD