1. TDAYz's Avatar
    Hello, guys, I have a problem, my "new" S3 won't turn on.
    Brother gave it to me, cause he didn't need it, the problem is that it doesn't turn on.
    I don't have info on it's version, I literally just go the phone and nothing else with it.
    So what happens is that when I plug it in it shows the charging indicator, the blank one, not the green one, and nothing moves. It doesn't move at all.
    I tried download mode, and it goes into the screen where it warns me and suggests pressing volume up to continue, yet again i press it and nothing happens, it is completely stuck.
    Tried recovery mode too, stuck on Samsung Galaxy S3 GT-19300.
    When I try to turn it off with the power button, it turns off for a few second, then comes back to the same screen.

    What can I do in my power to fix this? Thanks in advance. The screen is cracked a little bit if that changes anything
    08-18-2014 01:04 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The first thing to try is a new battery.
    08-18-2014 01:26 PM
  3. TDAYz's Avatar
    well, the good news is after a few tries I managed to get it in both recovery and download modes, though kies doesn't really want to connect to my device
    08-18-2014 02:00 PM
  4. GSDer's Avatar
    If you take the battery out and reinsert it, does the phone turn itself on (without you pressing the Power button)?

    If you can get it to boot into Recovery mode you should clear the system cache and perform a Factory Reset. If things don't improve then it's time to boot into Download mode and use Odin to reload the stock firmware.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-18-2014 07:10 PM

Similar Threads

  1. Galaxy S5 Call waiting NOT showing up.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-29-2015, 02:29 AM
  2. Camera shortcut on lockscreen
    By gwhizkids in forum Verizon Galaxy S III
    Replies: 2
    Last Post: 08-18-2014, 03:28 PM
  3. ssh to android with X11/GUI ?
    By gargavf in forum General News & Discussion
    Replies: 1
    Last Post: 08-18-2014, 03:24 PM
  4. Replies: 1
    Last Post: 08-18-2014, 03:19 PM
  5. Sd card problem on samsung tab 3
    By thatkid96 in forum Ask a Question
    Replies: 2
    Last Post: 08-18-2014, 03:15 PM