09-25-2018 12:23 AM
37 12
  1. Rahim Ullah's Avatar
    i cant download any app from google play in galaxy S4!!! when i press install it show "downloading" but doesnt start download!!!
    Plz helppppppp!!!!!!
    07-20-2013 02:02 PM
  2. meyerweb#CB's Avatar
    Try clearing the app's cache. I have an S3, not an S4, so how you get there might not be quite the same, but on the S3:

    Go to Settings / Application manager. Scroll all the way right, to the "All" tab. Scroll down to "Google Play Store" and tap that row. Tap "Clear cache", then "Force Stop."

    Now go back to the home screen, and restart the app. See if that fixes it. If not, try the same thing again, but this time "Clear data" instead of cache.

    If that still doesn't work, go back to the Application manager, tap the menu button, and "Reset app preferences."

    If none of those work, check out this thread. It may have some other ideas: http://forums.androidcentral.com/sam...d-working.html
    07-20-2013 03:16 PM
  3. nickgalaxys4's Avatar
    Yes I would for sure clear cache and force stop the app.
    07-21-2013 01:51 PM
  4. Llysa Ngina VI's Avatar
    Thank you this has saved me. Had the same problem
    10-14-2013 07:59 AM
  5. markakirby's Avatar
    i did all this but it didnt work.
    11-28-2013 11:08 AM
  6. Rosni Ahmad's Avatar
    Thank you for the info. Now my play store able to download
    12-10-2013 11:02 PM
  7. Knight_Hound's Avatar
    Okey. maybe.. just maybe.. (but i hope not)
    I'm the only one that have this weird **** freaky problem on my device (Samsung Galaxy Ace 2 - GT-I8160)
    the problem is same like all of people in this thread, BUT mine was more ADVANTAGE.
    why I said that??? cuz my phone still can update and download BUT ONLY FOR SOME APK!!
    example: I can download/update Google Search, Google +, Maps, etc BUT I can't update GMAIL.
    well cuz GMAIL is not really important to me, so it's okey it can't update..
    BUT this is happen to many APK out there, I even can't download NOVA LAUNCHER, GO LOCKER, and even SKYPE!!
    the proses show "DOWNLOADING" status but the download never start!!
    I read all the suggestion made from page 1 - 2 but neither one of them work for me..
    I even FACTORY RESET my Ace 2 but NOT WORK!!
    this is frustating me.. so anyone can help solve my problem here?
    before I really gave up and toss this **** phone to the sea..

    [ In Settings / Application manager, scroll all the way to the right, then scroll down until you find downloads. If it is marked as disabled, tap that row, tap the enable button, exit and try the Play store again. ] NOT WORK!!

    [ If it's not disabled, or you did the above and it still won't work. scroll down to Google Play store, tap that row, and tap the Clear cache button, then the Force stop button. Exit, and try the play store again. If it still doesn't work, repeat but tap Clear data, then Force stop ] NOT WORK!!

    [ Reset app preferences technique. ] NOT WORK!!

    [First of all make sure there is no data limit active or reached by going in
    Settings >> Data usage.

    2. Make sure time zone in settings is set correct. That helps if u have travelled to other zone or is wrong selected.

    3. You can clear data of play store by going in Settings >> apps setting >>all tab >> google play store>> clear data.

    4. If this doesnt work and u are on custom rom then flash gapps again or if u are on stock then wipe / reset phone] NOT WORK!!
    1 thing here I desribe I'm not using any custom ROM or whatever is it only ROOT previeleges

    [ You can also try enabling the Google Account Manager of your device. This worked for me. For detailed steps please visit HOW TO FIX GOOGLE PLAY STORE LOADING ISSUE - News - Bubblews ] NOT WORK!!!

    Sent from my **** Samsung GT-I8160
    06-16-2014 04:03 AM
  8. S B2014's Avatar
    Great Job man!
    A1d3 likes this.
    08-19-2014 01:17 PM
  9. viswanatha iyer's Avatar
    can not down load any apps in my android mobile moto e
    08-21-2014 04:42 AM
  10. Jackpot50's Avatar
    Clearing hatch worked great
    08-26-2014 06:20 AM
  11. alex4785's Avatar
    Man thank you for this great post
    10-09-2014 01:26 PM
  12. William Davies2's Avatar
    Didn't work for me either.
    04-22-2015 03:38 PM
  13. Kamiano's Avatar
    Thanks...this solved my problem. I had to clear cache and data.
    04-24-2015 11:28 AM
  14. Katina Lewis's Avatar
    I have a Samsung galaxy s4 mini and I just got the 4.4.2 update last week. Not only can I not move apps to my SD card anymore but Now my apps won't update nor can I download any new ones. I cleared my cache and cleared the data like y'all stated above and it let me update 3 apps but not its back to not working. I tried clearing things again and it didn't work. Can anyone help?!
    05-28-2015 09:22 AM
  15. Mitul Patel3's Avatar
    1. Open your device's main Settings menu.
    2. Select Apps or Application manager (depending on your device, this may be different).
    3. Select the Google Play Store app Google Play.
    4. Select Clear cache.
    5. Select Clear data.

    Download Manager
    1. Open your device's main Settings menu.
    2. Select Apps or Application manager (depending on your device, this may be different).
    3. Select Download Manager.
    4. Select Clear cache.
    5. Select Clear data.

    just try this above steps it will help u to solve ur problem
    mlggoob1008 likes this.
    06-24-2015 07:48 AM
  16. galaxynebula's Avatar
    Million tks.

    My Whatapps version expired; press update and Playstore keep looping ....
    Lost communications for a whole day ...

    Can't fix the problem 1st time by "Clear cache" + "Force stop" + reload PlayStore...
    OK when I "Clear cache" and "Clear data" at the same time... and then "Force stop" and reload PlayStore.
    07-12-2015 08:24 PM
  17. Usman Ch's Avatar
    Error 194
    Please tell me the sollution
    08-11-2015 04:44 AM
  18. Deepu Reddy1's Avatar
    09-10-2015 12:16 AM
  19. Kim Lawson's Avatar
    Thanks for this. The extra step of clearing cache/data on the Download Manager solved this problem on my S4 :-)
    11-06-2015 10:01 AM
  20. salmanabbasi's Avatar
    clearing cache and data solved the problem for me
    11-10-2015 01:56 AM
  21. GHaustin's Avatar
    “””” A Fix For Not Being Able To Download Or Install Apps From The Google Play Store
    For People Who Have Tried EVERYTHING And It Still Doesn’t Work !!!!!!”””””””””

    To keep a long story short, I had decided to start using an older Android phone of\my wife’s. So I decided to factory reset it so I could start fresh on it. Well after it restarted it immediately being to ***** about not being able to connect to server. Then when I open the play store everything I tried to download was Error retrieving information from server. I tried everything I could think of but nothing worked. Then hitting the forums and trying everything listed in them at least 10 times. So I was about to just give up then my little voice said try this one last thing and to my surprise it WORKED. Everything was working, updating and downloading. Here are the step to what I did.
    1. Remove all accounts and yes this means do a factory reset
    2. Restart the device
    3. After start up DO NOT and I mean DO NOT create, link or sign in using your google account info. Hit skip this step and let the device fully start up.
    4. After is has started and you have a data connection open the Play Store
    5. At this time NOW sign in with your google account info.
    6. Just sit back and enjoy watching the updates come zooming in.
    I don’t know why this worked or how but it worked. I am posting this so that others who are as frustrated as I was, might have a chance at PEACE. May this post save others and lead to calm.
    Mary Cate Cahill likes this.
    11-12-2015 06:27 PM
  22. bency003's Avatar
    I didn't want to create an androidcentral account but anyway I wanted to let you all know how it worked for me.

    Every time I opened playstore after cache or reset or whatever, google would ask me to tick "keep me up to date with news and and offers from google play" but I DIDN'T WANT TO BE KEPT UP TO DATE. So i never checked it and I always had the error "cannot download app....."

    This time after trying all the options above with no success I ticked the box to keep me up to date AND IT DOWNLOADS NOW!

    I presume now that 'ticking the box' means that you accept googles rules etc and can then go forward from there.

    Hope this works for you guys too. Good luck!
    11-14-2015 10:58 AM
  23. davidlmusic's Avatar
    Thank you so much! Sorted now....
    01-11-2016 02:33 AM
  24. Robert Slyter's Avatar
    I had game apps then factory reset and tried to download them again and app store says not compatible with this version but I had those games before. Can someone help please.
    01-16-2016 04:24 PM
  25. Nicky Albertyn's Avatar
    Have a look in:

    Settings > Data Usage:

    Scroll through the list of apps to Google Play Store, click on it then scroll down to 'Restrict background data' and make sure it is not ticked. Also in the list of aps look for one called 'Media' (it might not be there) and also check that Restrict background data is not ticked. This worked for me ;-)
    02-10-2016 10:04 PM
37 12

Similar Threads

  1. [APP][2.1+] Glextor AppManager Free
    By glextor in forum Android Apps
    Replies: 78
    Last Post: 04-07-2017, 04:34 AM
  2. Does outlook app give sound notification?
    By Vxlgsi in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 11-12-2015, 04:44 PM
  3. Accu weather app
    By hydrogen3 in forum LG Optimus G
    Replies: 6
    Last Post: 03-05-2015, 10:02 AM
  4. Need a fast, snappy SMS app
    By Pabben in forum The Android Central Lounge
    Replies: 5
    Last Post: 07-20-2013, 09:06 PM
  5. Replies: 2
    Last Post: 07-20-2013, 12:57 PM