1. joleesays's Avatar
    Hello,

    I hope you guys can help me with this. I have a Verizon galaxy s4 that I transferred to straight talk. Calls, texts, SMS, internet all work with no problem.

    The problem I am having is during incoming calls. The phone is showing a plus sign before the phone number that is calling me (Example: our area code is 607. so if 607-607-6076 calls me, the phone shows +60 7-607 6076) This doesn't seem like a big deal, but if I miss a call and try to just tap the number to return the call, I get an error message saying I cannot make international calls.. My phone settings are correct as far as I can tell. I have it set that I live in the U.S.

    This is a pretty annoying problem when you miss a call and can't easily dial back. You have to quickly memorize the number to go to a fresh screen and re-dial it manually.

    Anyone have this issue or a solution?
    natly22 likes this.
    06-11-2014 02:24 PM
  2. mhinc's Avatar
    Hello,

    I hope you guys can help me with this. I have a Verizon galaxy s4 that I transferred to straight talk. Calls, texts, SMS, internet all work with no problem.

    The problem I am having is during incoming calls. The phone is showing a plus sign before the phone number that is calling me (Example: our area code is 607. so if 607-607-6076 calls me, the phone shows +60 7-607 6076) This doesn't seem like a big deal, but if I miss a call and try to just tap the number to return the call, I get an error message saying I cannot make international calls.. My phone settings are correct as far as I can tell. I have it set that I live in the U.S.

    This is a pretty annoying problem when you miss a call and can't easily dial back. You have to quickly memorize the number to go to a fresh screen and re-dial it manually.

    Anyone have this issue or a solution?
    The only thing I can think of is to check our APN settings and make sure they are correct for STRAIGHT TALK
    HOW TO UPDATE DATA SETTINGS
    06-11-2014 04:40 PM
  3. joleesays's Avatar
    I've checked my APN settings and even tinkered with them to match what other people have posted. It is SO annoying
    06-16-2014 10:26 AM
  4. mhinc's Avatar
    I've checked my APN settings and even tinkered with them to match what other people have posted. It is SO annoying
    Okay so let's go over some settings then. There has to be a solution for this.

    Tap your PHONE icon from your main screen. Once in there, tap your bottom left menu button. You should have a menu pop up with an option for CALL SETTINGS. Tap that option.
    Once in CALL SETTINGS, tap on ADDITIONAL SETTINGS.
    Okay now that you are in Additional Settings, There should be an option for AUTO AREA CODE. Tap that, and see if someone has put in the +1 in that box. I am guessing that's the issue. If there is a +1 or ANYTHING in the box for that matter, deleted it. And exit. And that's that. You are good to go, no more +1
    I really hope that was it otherwise I am stumped. let me know!
    06-19-2014 06:55 AM
  5. Estos Huevos's Avatar
    hello,

    i bought a factory unlocked phone from overseas and i had it activated with Net10 (which i guess it uses ATT network) well i also have the same problem also i did all that but i didnt have anything in there wit the +1 filled in so i dont know what to do because its annoying as hell to rememer the contact phone number so i hope someone can help me out to figure this out ..oh before i forget my friend bought the same phone but he doesnt have that problem so now im confused here!! plz help me
    07-06-2015 05:44 PM
  6. Mike Larry4's Avatar
    It does not work
    08-12-2015 11:06 PM
  7. love musix's Avatar
    I also have a unlocked phone and I am having problems with it my are code is 361 and when dialing out it says 36 1 so it dials budapest in europe. I would like to know if you got it fix and how plz. Thanks in advance.
    natly22 likes this.
    10-01-2015 12:05 PM
  8. natly22's Avatar
    Glad I'm not the only one. Was thinking it was something I did when configuring my APN settings. I also live in the 361 area on Cricket/ATT network with a Verizon Galaxy Note 4 running on 4G LTE. What I find odd is that even though we all have the same issue, the specifics are different. My incoming calls read +361 instead of 1361. I only have the issue with incoming calls but as Joleesays said... can't return a call without using the dialer to type it out, which is a pain. Already tried adjusting my APN settings and went through everything under call settings with no such luck. I have updated current country, tried adjusting the area code for all my contacts that sync to Google with the number fix app, checked my sim for errors n even tried restoring the firmware after wiping the cache. I think it most likely might have something to do with the assisted dialing settings. By default it is turned on but under area/city code it lists 136. I have tried deleting all spaces, turning the assistant dial off, adjusting the area code to the correct number n even adding a 1 to make it "1361" in which case my phone either wouldn't work after or the issue remained. I'm running out of ideas at this point n waisted enough time on it allready so anyone with any other ideas or info on the subject please please help out here. Btw, my Note 4 is NOT rooted and running Android 5.0.1
    02-19-2016 11:34 PM
  9. Blahhh283's Avatar
    Go on your dial pad and hit the menu button , then go to call settings, scroll down and you will see other call settings.. Then make sure that the U.S dialing is NOT checked...

    This worked for me because I checked the U.S dialing box.
    04-28-2016 09:44 PM
  10. burdettebh's Avatar
    Glad I'm not the only one. Was thinking it was something I did when configuring my APN settings. I also live in the 361 area on Cricket/ATT network with a Verizon Galaxy Note 4 running on 4G LTE. What I find odd is that even though we all have the same issue, the specifics are different. My incoming calls read +361 instead of 1361. I only have the issue with incoming calls but as Joleesays said... can't return a call without using the dialer to type it out, which is a pain. Already tried adjusting my APN settings and went through everything under call settings with no such luck. I have updated current country, tried adjusting the area code for all my contacts that sync to Google with the number fix app, checked my sim for errors n even tried restoring the firmware after wiping the cache. I think it most likely might have something to do with the assisted dialing settings. By default it is turned on but under area/city code it lists 136. I have tried deleting all spaces, turning the assistant dial off, adjusting the area code to the correct number n even adding a 1 to make it "1361" in which case my phone either wouldn't work after or the issue remained. I'm running out of ideas at this point n waisted enough time on it allready so anyone with any other ideas or info on the subject please please help out here. Btw, my Note 4 is NOT rooted and running Android 5.0.1
    An app called Pfizer worked for me. Gets the link to setup

    http://forums.androidcentral.com/ver...rnational.html
    05-16-2016 07:02 AM
  11. Saltlife19's Avatar
    Go on your dial pad and hit the menu button , then go to call settings, scroll down and you will see other call settings.. Then make sure that the U.S dialing is NOT checked...

    This worked for me because I checked the U.S dialing box.
    YES! Thank you - this worked for me! Now I can actually call someone back through their text messages they send me, and the + is no longer there.

    01-10-2018 11:59 AM
  12. Molly McDonel's Avatar
    I was having this problem on my note 5.
    I powered off the phone, restarted in recovery mode and then wiped the cache. Rebooted phone and so far so good. We will see if it acts up again. Fingers crossed!
    02-28-2018 11:24 AM
  13. goku2100's Avatar
    This thread here: https://forums.androidcentral.com/sa...ng-option.html

    It's specified to check the Assisted Dialing function first. If that doesn't work, the second option is to use prefixer app. When I used the prefixer app to fix this problem, settings I had:
    For incoming calls, I had the rules as follows: When number matches (any number)
    Include secret/hidden numbers: Yes
    number in contact list: Either
    Roaming: Either
    Network operator: Any

    Actions
    Remove Characters: \+
    Add number to call log: Prefixed


    This worked. Once all of my calls had gone through the prefixer (you might want to delete/ignore the old calls in your call log with the + before them), from then on, the calls appeared appropriately in my call logs and I was able to dial out properly without issue.



    However, I wasn't happy with having to use the prefixer app, I want as few apps on my phone as possible.


    So.......

    Before you proceed, just want to tell you the specs of my phone: Samsung Galaxy S5 Sprint (G900P) using Android 6.0.1 Marshmallow. I do not know if this will work on your phone, just an FYI, this may do nothing on your phone, or worst case if you corrupt the file, soft brick your phone.


    So, your phone has to be rooted for the following solution to work. Using ESfile explorer with root privileges (best version is 3.2.5.5), I went into the root directory of the phone / --> system --> csc --> feature.xml or others.xml (if feature.xml isn't there. FYI, feature.xml takes precedence over others.xml if both are in the CSC folder). A backup copy of feature.xml or others.xml should be in some sub folders of CSC folder.

    Anyway, ensure you have permissions to write to either feature.xml or others.xml, open one of the files in ES Note editor, (view this file in landscape mode, much easier to read) scroll to the bottom and then scroll up to find the following line :" <CscFeature_RIL_SupportVolteTotalCallTime>TRUE</CscFeature_RIL_SupportVolteTotalCallTime> "

    Now, I'm not entirely sure why this worked but this is what I changed it to:
    " <CscFeature_RIL_SupportVolteTotalTime>TRUE</CscFeature_RIL_SupportVolteTotalCallTime>"

    If you delete the entire line, it does not fix this issue. If you try to change the value from "TRUE" to "FALSE" it does not fix this issue. I discovered having this malformed script is the only thing that worked. I used the "CSC features expert" program and saw that it has a tendency to corrupt the others.xml or features.xml file with incorrect syntax and whatnot.

    I wish I knew exactly what inside of the others.xml is prompting the phone to behave with the + symbol before incoming calls, but for now, my solution (at least for me) works well enough. I have no idea if this creates any other issues as I do not have VOLTE capability anyway as I use the ATT network.
    04-17-2018 03:22 PM
  14. Lrh4609's Avatar
    Hello,

    I hope you guys can help me with this. I have a Verizon galaxy s4 that I transferred to straight talk. Calls, texts, SMS, internet all work with no problem.

    The problem I am having is during incoming calls. The phone is showing a plus sign before the phone number that is calling me (Example: our area code is 607. so if 607-607-6076 calls me, the phone shows +60 7-607 6076) This doesn't seem like a big deal, but if I miss a call and try to just tap the number to return the call, I get an error message saying I cannot make international calls.. My phone settings are correct as far as I can tell. I have it set that I live in the U.S.

    This is a pretty annoying problem when you miss a call and can't easily dial back. You have to quickly memorize the number to go to a fresh screen and re-dial it manually.

    Anyone have this issue or a solution?
    Found it! From your call screen push the three buttons in the search bar...go to settings... scroll down to more settings...go to other call settings and turn it on or off( haven't figured out the 2 colors blue and Amber) . Then the +1 should be removed! Happy calling!
    07-31-2018 08:37 AM
  15. Lord Vader's Avatar
    Found it! From your call screen push the three buttons in the search bar...go to settings... scroll down to more settings...go to other call settings and turn it on or off( haven't figured out the 2 colors blue and Amber) . Then the +1 should be removed! Happy calling!
    Neither your suggestion nor anyone else's here has worked on my Galaxy S9+. I made changes in my settings, installed Prefixer and set up the rules on that all as suggested in this (and similar) threads, but still I am plagued with EVERY incoming call having a "+" sign in front of it. This has the VERY annoying and problematic result of all such calls blocked by any call blocking app I've used (used for blocking the numerous spam and telemarketing calls I incessantly receive). Because every incoming call has the + sign in front of it, all calls are blocked: family, friends, work, doctor's office, etc.

    Can anyone help? I'm really getting quite frustrated by this, especially since I tried the fixes mentioned in this and similar threads.
    09-27-2018 12:30 AM

Similar Threads

  1. Nexus 5 KitKat 4.4.3 upgrade causing new issues/bugs
    By Samar Basrai in forum Google Nexus 5
    Replies: 28
    Last Post: 06-25-2014, 01:17 PM
  2. Mic still an issue?
    By frag06 in forum AT&T LG G2
    Replies: 2
    Last Post: 06-12-2014, 10:57 AM
  3. call recorder
    By Del Wright in forum HTC One M7
    Replies: 2
    Last Post: 06-11-2014, 06:09 PM
  4. Galaxy Note 3 Gallery/Camera Broken
    By Lexg2009 in forum T-Mobile Samsung Galaxy Note 3
    Replies: 1
    Last Post: 06-11-2014, 02:25 PM
  5. Replies: 0
    Last Post: 06-11-2014, 01:46 PM
LINK TO POST COPIED TO CLIPBOARD