1. Tyler Trott's Avatar
    Hello folks! 1st post.
    I did some searching but can not find a solution. There are certain apps (snapchat, Google play store) on my phone that will only work when mobile data is on or WiFi with airplane mode on. I would like to be able to use my WiFi at home without having to turn airplane mode on.
    Is there a way to fix this? Do I have to change settings on my router?
    I would appreciate any information. Thanks in advance!

    Posted via the Android Central App
    07-10-2015 03:00 PM
  2. jpullins's Avatar
    Try going to settings > mobile networks > mobile data > uncheck enhanced 4g LTE.

    Posted via the Android Central App
    07-10-2015 08:43 PM
  3. Tyler Trott's Avatar
    Try going to settings > mobile networks > mobile data > uncheck enhanced 4g LTE.

    Posted via the Android Central App
    I read about that somewhere but I can't find that option. Here are some screen caps of what I got.
    I called T-Mobile today and they are going to send me a new router! For free! Although, I would still like to find a solution to this before. Maybe I won't have to switch.

    Posted via the Android Central App
    Attached Thumbnails Certain apps not working on WiFi but work on mobile data-371.jpg   Certain apps not working on WiFi but work on mobile data-372.jpg  
    07-10-2015 08:50 PM
  4. jpullins's Avatar
    Oh OK I didn't know you had t-mobile. I should have asked in the beginning...hope the router solves your problem

    Posted via the Android Central App
    07-10-2015 11:10 PM
  5. Johndaniel Morales's Avatar
    I ran into the same problem. I noticed I had battery saver mode on, which limits certain background data to save power. I turned it off and rebooted and all my apps worked fine on data. I hope this helps!
    George Copeland and Rukbat like this.
    07-16-2015 12:47 PM
  6. jazz182838's Avatar
    Did you ever find a solution to this as I'm having the same problem although all apps work fine via wifi on my iPad so it's not my router.
    03-10-2016 06:55 PM
  7. hazibeecj's Avatar
    well u can try by following any of these steps. first turn your flight mode on only after that simply go to your wifi settings then connect to your network then turn your location/gps on. this will disable ur sim card as if there the sim card was taken out.and the phone will work accessing only your network.
    07-15-2016 08:47 AM
  8. drt3's Avatar
    I turned on airplane mode, then enabled WiFi. That fixed the problem, thanks for the tip. What is causing this behavior and how do I fix it permanently?

    I figured it out, IPv6 was enabled on my router. I disabled it and all apps work now.
    10-19-2016 11:08 AM
  9. George Copeland's Avatar
    I ran into the same problem. I noticed I had battery saver mode on, which limits certain background data to save power. I turned it off and rebooted and all my apps worked fine on data. I hope this helps!
    Thanks man, was about to pull my hair out but did what you suggested and problem solved.
    11-01-2016 06:52 PM
  10. hhdhdhdhdh's Avatar
    HEY so how exactly do I get rid of ivp6
    12-14-2016 05:49 PM
  11. Tech Untangle's Avatar
    Hello, there are following factors that may causing this issue. I recommend you to fix these
    1. Reset APN
    2. Allow data usage to apps
    3. Increase data usage limit to apps
    4. Reset Network settings
    07-03-2019 09:09 AM
  12. Rukbat's Avatar
    Necropost, but ...

    HEY so how exactly do I get rid of ivp6
    First, disallowing the router to handle IPv6 "solving" the problem is a symptom of another problem. If the app uses IPv4, or uses the canonical name of the site (the canonical name of this site is forums.androidcentral.com, its IPv6 address is 2606:4700::6812:5a19), the fact that the router can handle the IPv6 address of the site shouldn't cause any problem. But some phones seem to have a problem if both mobile data and WiFi are enabled at the same time, so when you're using WiFi, just disable mobile data. Even on an older phone, where that's not as simple as pulling the notification bar down, it's trivial to go to Settings, find mobile data, and turn it off. And IFTTT should be able to automate that - turn WiFi on and mobile data is turned off, turn WiFi off and mobile data is turned on. (If not, I know that Tasker can [I've used it to turn on Mobile data when I lose my WiFi signal, and to reverse the situation when I'm home], but Tasker isn't free. [If you learn to use it, though, it's well worth the $3 it costs. My screen, when I'm reading something and don't want to be disturbed, is set to not turn off, but back to the 30 second timeout when I close any of the apps that trigger that task. When I run My Places or Maps, GPS is enabled. When I don't have either one as the foreground app, it's disabled. (I haven't used Waze in a long while, or that would still be on the list of apps triggering that task.) Simple "AI".])
    07-29-2019 02:54 PM

Similar Threads

  1. Instagram/Snapchat won't refresh/load on WiFi connection
    By kiingy in forum Samsung Galaxy S5
    Replies: 20
    Last Post: 07-29-2019, 03:14 PM
  2. Help! my Zenfone 2 is not 'Fast Charging' why?
    By albert1285 in forum ASUS ZenFone 2
    Replies: 4
    Last Post: 07-10-2015, 04:53 PM
  3. Can I use my normal cell phone number to make wifi calls?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 07-10-2015, 04:17 PM
  4. Replies: 1
    Last Post: 07-10-2015, 02:56 PM
  5. Replies: 1
    Last Post: 07-10-2015, 02:39 PM
LINK TO POST COPIED TO CLIPBOARD