Certain apps not working on WiFi but work on mobile data

Tyler Trott

New member
Jul 10, 2015
2
0
0
Visit site
Hello folks! 1st post.
I did some searching but can not find a solution. There are certain apps (snapchat, Google play store) on my phone that will only work when mobile data is on or WiFi with airplane mode on. I would like to be able to use my WiFi at home without having to turn airplane mode on.
Is there a way to fix this? Do I have to change settings on my router?
I would appreciate any information. Thanks in advance!

Posted via the Android Central App
 

jpullins

Well-known member
Aug 6, 2012
144
0
0
Visit site
Try going to settings > mobile networks > mobile data > uncheck enhanced 4g LTE.

Posted via the Android Central App
 

Tyler Trott

New member
Jul 10, 2015
2
0
0
Visit site
Try going to settings > mobile networks > mobile data > uncheck enhanced 4g LTE.

Posted via the Android Central App

I read about that somewhere but I can't find that option. Here are some screen caps of what I got.
I called T-Mobile today and they are going to send me a new router! For free! Although, I would still like to find a solution to this before. Maybe I won't have to switch.

Posted via the Android Central App
 

Attachments

  • 371.jpg
    371.jpg
    17.2 KB · Views: 76
  • 372.jpg
    372.jpg
    23.5 KB · Views: 76

jpullins

Well-known member
Aug 6, 2012
144
0
0
Visit site
Oh OK I didn't know you had t-mobile. I should have asked in the beginning...hope the router solves your problem

Posted via the Android Central App
 

Johndaniel Morales

New member
Jul 16, 2015
1
0
0
Visit site
I ran into the same problem. I noticed I had battery saver mode on, which limits certain background data to save power. I turned it off and rebooted and all my apps worked fine on data. I hope this helps!
 

jazz182838

New member
Mar 11, 2016
1
0
0
Visit site
Did you ever find a solution to this as I'm having the same problem although all apps work fine via wifi on my iPad so it's not my router.
 

hazibeecj

New member
Jul 15, 2016
1
0
0
Visit site
well u can try by following any of these steps. first turn your flight mode on only after that simply go to your wifi settings then connect to your network then turn your location/gps on. this will disable ur sim card as if there the sim card was taken out.and the phone will work accessing only your network.
 

drt3

New member
Oct 19, 2016
1
0
0
Visit site
I turned on airplane mode, then enabled WiFi. That fixed the problem, thanks for the tip. What is causing this behavior and how do I fix it permanently?

I figured it out, IPv6 was enabled on my router. I disabled it and all apps work now.
 
Last edited:

Tech Untangle

New member
Jul 3, 2019
1
0
0
Visit site
Hello, there are following factors that may causing this issue. I recommend you to fix these
1. Reset APN
2. Allow data usage to apps
3. Increase data usage limit to apps
4. Reset Network settings
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
Necropost, but ...

HEY so how exactly do I get rid of ivp6
First, disallowing the router to handle IPv6 "solving" the problem is a symptom of another problem. If the app uses IPv4, or uses the canonical name of the site (the canonical name of this site is forums.androidcentral.com, its IPv6 address is 2606:4700::6812:5a19), the fact that the router can handle the IPv6 address of the site shouldn't cause any problem. But some phones seem to have a problem if both mobile data and WiFi are enabled at the same time, so when you're using WiFi, just disable mobile data. Even on an older phone, where that's not as simple as pulling the notification bar down, it's trivial to go to Settings, find mobile data, and turn it off. And IFTTT should be able to automate that - turn WiFi on and mobile data is turned off, turn WiFi off and mobile data is turned on. (If not, I know that Tasker can [I've used it to turn on Mobile data when I lose my WiFi signal, and to reverse the situation when I'm home], but Tasker isn't free. [If you learn to use it, though, it's well worth the $3 it costs. My screen, when I'm reading something and don't want to be disturbed, is set to not turn off, but back to the 30 second timeout when I close any of the apps that trigger that task. When I run My Places or Maps, GPS is enabled. When I don't have either one as the foreground app, it's disabled. (I haven't used Waze in a long while, or that would still be on the list of apps triggering that task.) Simple "AI".])
 
Last edited:

Forum statistics

Threads
942,946
Messages
6,916,609
Members
3,158,748
Latest member
bluegarland692