12-03-2018 04:57 AM
46 12
tools
  1. patman1784's Avatar
    I had the same problem as some in here. This thread didn't solve my issue nor did many other suggestions from other sites but I did find my solution. My S6 Edge when connected to my new Surface Pro 4 on Windows 10 would charge and not show up as a media device. It worked fine on my older Windows 7 laptop. I downloaded and installed the Media features pack for windows 10 (insert your version here) and make sure you pick the right file (32 or 64 bit). I rebooted and next time I plugged in my S6 it was connected as a media device.
    Hope this helps some of you out there.
    02-14-2016 12:22 AM
  2. tempUser10's Avatar
    Stupidly, I made the mistake by selecting "Use USB for Charging" on my Samsung S7 edge (I know this is for the S6), which caused me to loose the other options for transferring data and only displayed the "cable charging".
    I managed to fix this issue by going onto the dialler *#0808# and changing the option to "CP" - only because when I tried selecting the option "MTP + ADB" under "AP", it would say that it saved the changes but would not keep the selection after I went onto it again. Whereas, changing it to "CP" solved the problem and it once again showed me the options for transferring data from my android phone to my laptop using the cable that came with the phone.

    Hope this helps anyone that come across this issue.

    (Only made an account to post this reply)

    On second thoughts.. it was a temporary solution. Once the usb was unplugged, the USB options stayed and after changing it to AP, still have the same issue. Final note: there was an issue with one of my USB port which I was using.
    Attached Thumbnails Help my Galaxy S6 Edge is not showing MTP/PTP and also fast charging isn't working?-screenshot_20160331-004106.jpg   Help my Galaxy S6 Edge is not showing MTP/PTP and also fast charging isn't working?-screenshot_20160331-004946.jpg  
    03-30-2016 07:59 PM
  3. fhoran's Avatar
    I just spent a good many hours trying to figure this out until I saw your suggestion. I never would have thought to go to "Notifications" to make a settings change. Thanks. It worked!
    03-31-2016 02:08 PM
  4. dylanholmes222's Avatar
    This has been driving me crazy. I discovered this issue after buying my 2016 civic which has android auto. Nothing would work to get the car or PC to recognize my Note 5, charging only over usb. I tried: compressed air to clean the port, factory reset *#0808# method, usb debugging on developer mode, nothing worked... so I decided to get an insurance replacement, but since that was ordered I thought I might as well mess with the physical USB port. I scraped the pins with a knife and bent the pin array block thing up (it looked really close to bottom to me) and guess what, MTP RECOGNITION. Turns out the USB charging cables bundled with the early adopters where poorly designed and actually damaged the USB ports with normal use over time. WTF Samsung...
    04-12-2016 08:49 PM
  5. Nikkisupermom's Avatar
    Mine was doing the same thing yours did there was an error at the bottom of my screen that always said: the last usb device you connected to this computer malfunctioned
    When I searched that I found this

    Solution 1: Remove Power Supply to Fix USB Device Not Recognized
    Step 1:
    Remove your Power Supply plug from PC.
    Step 2:
    Now Restart your PC.
    Step 3:
    Not connect your USB device to the USB ports. That’s it.
    Step 4:
    After the USB device connected to your PC, then plug in Power Supply to PC.

    Solution 2: Uninstall Unknown USB device
    If the above method is not working, then use below steps to solve this issue.
    Step 1:
    Open RUN (Windows Logo + R) and type “devmgmt.msc” and click OK.
    Step 2:
    Now expand Universal Serial Bus controllers.
    Step 3:
    Attach your device which is not recognized.
    Step 4:
    You will see an Unknown USB device (Port reset failed) with yellow sign in Universal Serial Bus controllers.
    Unknown USB device (Port reset failed)
    Step 5:
    Now right click on it and click Uninstall to remove them.
    Step 6:
    Now restart your PC, the drivers are automatically reinstall after restart. That’s it.
    Step 7:
    If not working, then follow below Solution.

    Solution 3: Re-install USB Drivers
    If USB Device Not Recognized because of corrupt USB drivers, then below steps are solve the corrupt USB drivers and also solve USB not recognized problem.
    Step 1:
    Open Device Manager (Right Click on Windows Logo and Click Device Manager).
    Step 2:
    Now find and expand Universal Serial Bus controllers. Now right click on USB drivers and click Uninstall. Do for all USB drivers one by one.
    Step 3:
    Now Restart your PC. The USB drivers are automatically re-install and solve the corrupted USB devices.

    There is more if these don't work....https://www.wiknix.com/usb-device-not-recognized/
    05-11-2016 02:24 PM
  6. tamasvarga's Avatar
    Hi!

    Did you find any solution for this?
    Problems:
    - I can't connect my S6 to PC. When I plug in the USB cable, it says the device is charging slowly, if I tap it, nothing happens. (original cable)
    - I can't fast charge the phone with original charger and cable
    - Gear VR not connecting, I just hear a repeating sound, and the phone freezes after disconnecting

    I also had some software updates, I don't know if it caused the problems or it's hardware related. I tried everything, developer options on, USB debugging is on, tried *#0808#, rebooted multiple times, cleaned the USB port with air duster. Interesting thing is, that sometimes it works (maybe because I'm messing with the settings), but later it's wrong again.

    Phone model: SM-G920F
    Android version: 6.0.1

    Thanks in advance!
    05-30-2016 05:08 PM
  7. DanaHauser's Avatar
    Hi Frustrated!

    It's your USB cable.

    The S6 and your PC need the deed for speed. Get rid of your old cables and all will be fine.

    Dana.
    07-04-2016 08:22 PM
  8. buzzyclonecattleman's Avatar
    Tried everything in this post. Only thing that fixed it was a Factory Reset.
    07-13-2016 01:33 AM
  9. Rhedtodes's Avatar
    Downloading files (music, photos or Word) from your samsung S6 or 7 to a computer.
    I was having the same problem to transfer files from my Samsung, so I went to customer service and learned how. Here it is, hope it helps you.
    1. Connect phone to computer with a USB
    2. Swipe down from top left corner and click on ´connected as a video device´
    3. Choose either ´transfering files´or transfering images´ and your phone will return to home screen. You won´t touch the phone after this, just the computer.
    4. Now go to ´my computer´ and you will see your samsung on the side menu and on the active page.
    5. Double click Samsung and ´phone will appear on the active page´.
    6. Double click ´phone´ and your files will appear. Click one and your files on the phone will appear. DCIM for your photos,( Camera or screenshot will appear), your music and other files will also show. Open the files you wish to copy to your computer with the left click and drag or copy to the computer file you want to copy them to. If you want to move them to your computer while deleting them on the phone, use the right click, move them to the file and it will ask you if you want to copy or move, click move. And that’s it, I hope this has been helpful.
    07-20-2016 06:38 AM
  10. r_growley's Avatar
    Prior to my last Windows update, my Galaxy and PC communicated just fine. Something about the last Windows update changed the communication. Now my PC doesn't recognize my Galaxy. I think it's not a Galaxy problem.
    08-18-2016 09:53 AM
  11. abdoomaster's Avatar
    Hi guys,

    I had the same problem and I thought that the USB cable was not working. I solved the issue by enabling Developer options and change USB Configuration to MTP or to whatever setting you want. I hope this helps

    Help my Galaxy S6 Edge is not showing MTP/PTP and also fast charging isn't working?-screenshot_20160829-182803.jpg
    08-29-2016 06:37 PM
  12. AspenQn's Avatar
    I have the same problem. Just developed after the most recent Verizon OTA update. Took it into the VZW store where after a couple of people tried to work on it, suggested I either buy a new phone or do a factory reset. I opted for factory reset but needed to back up my phone before I hit the button. Unfortunately when I plugged in my oem cable it shows that the last USB malfunctioned. Tried other ports on my laptop to no avail.

    What is the *#808# I keep seeing in these threads? Any other way to back up? I am FED UP...
    08-30-2016 07:44 PM
  13. squirt199's Avatar
    No options if you tap charging
    09-08-2016 03:59 PM
  14. Manolis Christodoulou's Avatar
    I have the same problem but it is going more complicated according to some test I have done.
    Two phones, two computers. HTC One Lollipop and Galaxy S7 Marshmallow , and Vaio Laptop Ubuntu 16.04 and Lenovo S100 Chromebook Chrome OS 53 stable.
    Now MTP connection tests:

    VAIO - HTC One - Works
    VAIO - S7 - Works
    S100 - HTC One - Works
    S100 - S7 - The phone doesn't recognize USB connection. It only charges with no other options.

    Tried #0808#, tried USB troubleshooting, nothing worked. I used the same cable in all tests. If it is the phone why it connects to VAIO. If it is the Chromebook why it connects to HTC One? Big mess.
    09-11-2016 05:39 AM
  15. Asterix Gaulois's Avatar
    Have you tried looked in the "Developer Options>.USB Configuration"? If you have that option, you will a list of choice for each mode of USB connection.

    Regards,
    11-21-2016 03:39 PM
  16. KidShelleen3's Avatar
    When you are connected to the PC, swipe your notification bar from the top, you will see all your settings icons, like WiFi, Sound, Flashlight, etc., then below that you also have notification BARS, like "connected to Wifi" " 2 messages" "charging" etc. CLICK on the bar that says CHARGING (it says tap here for more options when you are connected to a PC) and a new screen will pop up that says, "USE USB FOR".... Then you select the file transfer option. Then you will be able to see your device files s if you have a USB device plugged into the computer.

    Fast charging does not happen when connected to a PC.

    Every once in a while I will get a message that says I am not using my original charger (which I am) then I just unplug and plug back in, then fast charging works again when using a wall outlet.
    12-23-2016 11:43 PM
  17. KidShelleen3's Avatar
    use Samsung Switch and use the PC option.
    12-23-2016 11:44 PM
  18. August Shao's Avatar
    yes that the main problem you see s6 doesnt have that option of changing it to file mtp/ptp the option isnt therein settings and what i did was *#0808# and i also checked if it was in mtp or not but it was in mtp+abd still it only say charging so i havent been able to identify the problem i even checked with different cables and different charger i have been browsing through the net and i have seen some people with the similar issues and they also havent been able to identify the issue and i dont think its the usb port problem as it still does charge so. An thank you for your suggestion.

    Thanks, This solved my problem
    08-16-2017 06:31 AM
  19. Honey1900's Avatar
    I'm also experiencing this, or something very similar on my non-Edge S6. Symptoms:

    - it doesn't fast charge anymore.
    - when connected to a PC, the notification says "Charging", no MTP/PTP notification appears.
    - Windows/Linux do not recognize the device at all. This means no file transfers, no SmartSwitch/Kies.
    - OTG USB, however, it DOES work

    I've tried the following, to no avail: different PCs, different USB ports, different cables, different chargers. Also performed factory reset, booted into safe mode, and the *#0808# trick. Nothing works.

    Firmware version/build number: G920FXXU3COI9
    Same here for Note 5 .. I even changed the battery and micro USB port.

    Any Update????
    12-18-2017 10:32 PM
  20. Zaki Khan2's Avatar
    Here's what i did and it did work

    Connect phone to pc via usb cable
    on phone, select *#0808#, select AP then select MTP+ADB under USB Settings and then Reboot, while keeping the phone connected to PC.
    08-30-2018 12:26 PM
  21. Michael Borgen's Avatar
    I had the same problem as some in here. This thread didn't solve my issue nor did many other suggestions from other sites but I did find my solution. My S6 Edge when connected to my new Surface Pro 4 on Windows 10 would charge and not show up as a media device. It worked fine on my older Windows 7 laptop. I downloaded and installed the Media features pack for windows 10 (insert your version here) and make sure you pick the right file (32 or 64 bit). I rebooted and next time I plugged in my S6 it was connected as a media device.
    Hope this helps some of you out there.
    I tried all solutions proposed on this website it didn't work for me but I found a workaround. After exhausting all the options which might have helped, but still not allow me to connect my Galaxy S6 to my Mac or PC computer, the answer is...
    I plugged my USB thumb drive into a cheap amazon purchased USB to micro-usb adapter, and plugged that into my phone charger micro USB port. Immediately, thumb drive menu popped up I was able to click on it and see the files copy what I wanted over from the flash drive directly onto my internal storage on my phone.

    Hope this helps everyone else. This was keep me up late at night really pissing me off not being able to put music on my phone!!!
    12-03-2018 04:57 AM
46 12

Similar Threads

  1. Promo and Unlimited data
    By jmanches4286 in forum Motorola Droid Turbo 2
    Replies: 11
    Last Post: 11-03-2015, 04:44 PM
  2. MMS not working
    By Zendroid1 in forum Nexus 5X
    Replies: 6
    Last Post: 10-30-2015, 07:35 PM
  3. How can I downgrade my Lenovo A7000 which came with Lollipop 5.0 to KitKat?
    By AC Question in forum Lenovo Android Tablet Discussion
    Replies: 1
    Last Post: 10-30-2015, 12:34 PM
  4. How do I turn on mobile data on my Samsung Galaxy S3 mini?
    By AC Question in forum Samsung Galaxy S3 Mini
    Replies: 1
    Last Post: 10-30-2015, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD