1. AlphaVictor87's Avatar
    I've gone through every setting i can think of and i'm not sure why it's not working. Even if my phone accuracy was off a bit i'd still be within the circle denoted on the location for my phone.

    I use it for work and home and i have the timer set for 10 min before locking. My location is set to high accuracy.

    No other ideas on why it won't work.
    04-17-2017 11:19 AM
  2. LineKill's Avatar
    It is not working at all or is it not working sometimes?
    04-17-2017 11:29 AM
  3. AlphaVictor87's Avatar
    It is not working at all or is it not working sometimes?
    it's not working at all. I even tried using bluetooth for my fitbit which i always have on me and that doesn't work either.
    04-17-2017 11:32 AM
  4. LineKill's Avatar
    it's not working at all. I even tried using bluetooth for my fitbit which i always have on me and that doesn't work either.
    As far as Trusted Places are concerned, when you open Google Maps does it accurately pin point your location.
    04-17-2017 11:52 AM
  5. AlphaVictor87's Avatar
    As far as Trusted Places are concerned, when you open Google Maps does it accurately pin point your location.
    Very accurate, When i look the entire radius of my phone's "location" is within the circle marked on google maps.
    04-17-2017 12:46 PM
  6. LineKill's Avatar
    Was Smart Lock working before or is this the first time you started using it? What type of screen lock are you using?

    Try the following and see if this remedies the problem. It does not really matter until the end, but do them in this order:



    Search for Trust Agents in settings. If Smart Lock (Google) is off, turn it on. If it is on turn it off and then on again.

    Clear the cache for the Google app.

    Boot into recovery and wipe the cache partition. Restart from recovery.

    Go to Trusted Places in your settings. Turn the Home/Work location(s) off and on again. Delete any dropped pins. Drop 2 or 3 extra pins at Home/Work locations. Back out of settings.

    See if it works properly now🤞
    thecomicbookandme likes this.
    04-17-2017 01:11 PM
  7. AlphaVictor87's Avatar
    Was Smart Lock working before or is this the first time you started using it? What type of screen lock are you using?

    Try the following and see if this remedies the problem. It does not really matter until the end, but do them in this order:



    Search for Trust Agents in settings. If Smart Lock (Google) is off, turn it on. If it is on turn it off and then on again.

    Clear the cache for the Google app.

    Boot into recovery and wipe the cache partition. Restart from recovery.

    Go to Trusted Places in your settings. Turn the Home/Work location(s) off and on again. Delete any dropped pins. Drop 2 or 3 extra pins at Home/Work locations. Back out of settings.

    See if it works properly now🤞
    Thanks for all the tips I will try this tonight. And I don't think it was ever properly working
    04-17-2017 05:13 PM
  8. LineKill's Avatar
    Thanks for all the tips I will try this tonight. And I don't think it was ever properly working
    Your welcome. Now, even if it does start working for you, it is not 100% consistent. There will be times when you will still have to use your chosen unlock method e.g. pin, pattern, etc. However, the consistency will be raised by dropping the additional pins. Good luck!
    04-17-2017 06:46 PM
  9. pappcam's Avatar
    it's not working at all. I even tried using bluetooth for my fitbit which i always have on me and that doesn't work either.
    Fitbit uses BLE or Bluetooth Low Energy which works differently than full Bluetooth connections and Trusted Devices doesn't work with BLE devices.
    LineKill and AlphaVictor87 like this.
    04-17-2017 08:00 PM
  10. AlphaVictor87's Avatar
    Fitbit uses BLE or Bluetooth Low Energy which works differently than full Bluetooth connections and Trusted Devices doesn't work with BLE devices.
    Ahh well that's good to know. Thanks!
    04-18-2017 08:35 AM
  11. AlphaVictor87's Avatar
    Was Smart Lock working before or is this the first time you started using it? What type of screen lock are you using?

    Try the following and see if this remedies the problem. It does not really matter until the end, but do them in this order:



    Search for Trust Agents in settings. If Smart Lock (Google) is off, turn it on. If it is on turn it off and then on again.

    Clear the cache for the Google app.

    Boot into recovery and wipe the cache partition. Restart from recovery.

    Go to Trusted Places in your settings. Turn the Home/Work location(s) off and on again. Delete any dropped pins. Drop 2 or 3 extra pins at Home/Work locations. Back out of settings.

    See if it works properly now
    it looks like this is working for me at work finally!! I placed like 4 pins in a grid around where my phone usually gravitates on google maps. I'll test at home tonight too!
    LineKill likes this.
    04-18-2017 11:24 AM
  12. LineKill's Avatar
    it looks like this is working for me at work finally!! I placed like 4 pins in a grid around where my phone usually gravitates on google maps. I'll test at home tonight too!
    That is great news, I am very glad to hear that! It should work for you at home as well, but I will keep my fingers crossed🤞just in case.
    04-18-2017 11:51 AM
  13. pappcam's Avatar
    it looks like this is working for me at work finally!! I placed like 4 pins in a grid around where my phone usually gravitates on google maps. I'll test at home tonight too!
    I also had to pin 2 or 3 locations around where I wanted Smart Lock to work. Now with the ease of the fingerprint I don't use Smart Lock except in my vehicle with the Bluetooth connection used as a Trusted Device.

    Glad you got it working.
    04-18-2017 11:58 AM

Similar Threads

  1. Will this phone be as sluggish as the Priv?
    By Eggmundo in forum BlackBerry KEYone
    Replies: 13
    Last Post: 07-21-2017, 06:12 AM
  2. Replies: 2
    Last Post: 06-08-2017, 11:21 PM
  3. During a call the person is not listening
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-17-2017, 12:43 PM
  4. Replies: 1
    Last Post: 04-17-2017, 12:30 PM
  5. Galaxy S6 wifi tethering not properly working on win8-laptop
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-17-2017, 11:04 AM
LINK TO POST COPIED TO CLIPBOARD