1. kanyon40's Avatar
    I have the S7 and have some custom ring tones and notification sounds that I have been using. When I got the phone I was able to set all the notification sounds across different apps just how I like. Just in the last couple of days I have had some bluetooth issues where my phone drops connection to my car. I decided to factory reset the phone to fix it. Now, I have a couple of apps that I can't get custom notifications set for.

    I am trying to set custom tones for Outlook (both for email and calendar notifications) and for Facebook Messenger. Both show me the same list of options for tones, but none of the 26 custom notification sounds that I have imported to the phone show up. The notification files were placed into the notification folder on the internal storage of the phone. They have showed up for all the other apps I have tried to use them with. Just not these two apps, which is weird because they worked fine before resetting the phone.

    Any thoughts on why or what I might try? Thanks.
    05-10-2016 03:21 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try deleting those tones from the Notifications directory, then copying them back again.
    05-12-2016 01:13 AM
  3. catzgomew's Avatar
    I have the same problem. I have tried this and no go. I can only see stock notifications for FB Messenger. I want to use a different tone. Where can I add it so it will pick it up in the list when I try to change it?
    07-06-2016 10:46 AM
  4. dpreview_Horshack's Avatar
    I had this same issue. It's specific to the selective permissions feature that was added in Android 6. You can fix it by going to Android settings -> Applications (or your Android skin's equivalent) -> Specific app (Facebook, Outlook, etc..) and then enabling the 'Storage' permission for the app. This will allow the app access to the custom notification/ringtones that you have stored on your internal storage and/or SD card.
    07-12-2016 09:24 PM
  5. Zach Shafer's Avatar
    TY this was driving me crazy it worked like a charm
    08-20-2016 12:16 AM
  6. Ah Jeff's Avatar
    I had this same issue. It's specific to the selective permissions feature that was added in Android 6. You can fix it by going to Android settings -> Applications (or your Android skin's equivalent) -> Specific app (Facebook, Outlook, etc..) and then enabling the 'Storage' permission for the app. This will allow the app access to the custom notification/ringtones that you have stored on your internal storage and/or SD card.
    Your post helped me and will help a lot of other people and I just want to say 'Thank you!'.
    11B1P and KimBob249 like this.
    08-29-2016 12:43 AM
  7. badcat's Avatar
    Yeah, me too. This was bugging me for the longest time and your solution fixed it. Many thanks.
    Yappa likes this.
    09-20-2016 07:29 AM
  8. lovendestroy's Avatar
    WORKED! Thank you so much. The only thing I'll note is that I have both "Applications" and "Applications Manager" menus under Settings. I was slightly confused at first, but figured it out when I clicked the Applications Manager and saw the choices. Thanks again!
    09-27-2016 11:39 AM
  9. Treatz's Avatar
    Totally forgot about permissions.

    THANKS!
    10-13-2016 11:19 AM
  10. rdol's Avatar
    Nope does not work here. Using android 6.01. In the application manager and then Outlook it does state all the permissions the app uses. None of them is related to central storage. One of them is related to the SD-card. None of the permissions can be changed......

    What is going wrong...?
    12-14-2016 08:05 AM
  11. David Norwood's Avatar
    dpreview_Horshack Thank you . The permissions were all off on Outlook and the standard ringtones did not show. As soon as I gave Outlook permission to look at storage, Boom, there you have it - all of the ringtones on my Nexus 6P
    12-14-2016 04:09 PM
  12. Alan Berow's Avatar
    Worked perfectly. Thanks.
    12-15-2016 04:12 PM
  13. Alan Berow's Avatar
    I am using the same version and had to make a small change to find the option.
    Settings ->Device->Applications->Application Manager->Outlook->check Permissions - Calendar and Storage = ON, Notifications = Allowed

    Outlook->Gear icon (settings)->Scroll to Calendar->Notifications, pick account if needed->Sound->select sound.

    Before I notice dpreview_Horshack's advice, I put the sound file in several places on my phone. When I tried to set the notification, I found that the copies in the notifications folder and the Android/Media/com.google.android.talk/Notifications folders were both visible. I got rid of the second and was good to go.

    I hope this helps.
    Yel Solomon likes this.
    12-15-2016 04:30 PM
  14. Bigfoots695's Avatar
    I have a Note 5. with 6.0.1: Spent some hours trying to figure out why I couldn't use custom sounds downloaded and added to Notification folders. Found solution here immediately and fixed in a minute after checking Android Central. Many thanks.
    12-18-2016 03:03 AM
  15. oZo's Avatar
    Simple answer, and it works wonderfully! Thanks!
    10-24-2017 09:06 AM
  16. Zethembe Mbatha1's Avatar
    I'm on P10 plus oreo, all permissions are set but new email sound is written none and can't be changed
    07-06-2018 02:43 AM
  17. rcalderaro's Avatar
    Thank you so much for this! I just got a Galaxy S9+ and couldn't figure out how to do this.
    07-15-2018 01:48 PM
  18. Yel Solomon's Avatar
    I am using the same version and had to make a small change to find the option.
    Settings ->Device->Applications->Application Manager->Outlook->check Permissions - Calendar and Storage = ON, Notifications = Allowed

    Outlook->Gear icon (settings)->Scroll to Calendar->Notifications, pick account if needed->Sound->select sound.

    Before I notice dpreview_Horshack's advice, I put the sound file in several places on my phone. When I tried to set the notification, I found that the copies in the notifications folder and the Android/Media/com.google.android.talk/Notifications folders were both visible. I got rid of the second and was good to go.

    I hope this helps.
    Thanks man
    09-04-2018 11:50 AM
  19. Nerotic1214's Avatar
    I have tried all these directions for my s8. Nothing works. Still shows the same default ones as before.
    10-05-2018 05:27 PM
  20. ms_dollar's Avatar
    I have tried all these directions for my s8. Nothing works. Still shows the same default ones as before.
    New here but wanting to provide the solution that worked for me (I literally registered just to reply to this hoping it may help).

    I went into the File Manager and copied the notification tones that I was wanting to show up in the list and pasted them into the Notifications folder on my phone's Internal Storage. Once I did that they showed up in the list and I was able to change my notification tones. (I had previously checked my Outlook permissions and Storage was already allowed so I had to get a little creative). Hope this helps someone else! 😊
    brsipaq likes this.
    11-05-2018 08:11 AM

Similar Threads

  1. Replies: 1
    Last Post: 05-10-2016, 04:39 PM
  2. how can i get wifi connection and the pas word for Sprint Samsung Galaxie S7
    By Cheryl Diggs in forum General Help and How To
    Replies: 1
    Last Post: 05-10-2016, 02:55 PM
  3. Replies: 1
    Last Post: 05-10-2016, 02:53 PM
  4. Replies: 0
    Last Post: 05-10-2016, 02:26 PM
LINK TO POST COPIED TO CLIPBOARD