1. alib4's Avatar
    I had a software update this morning and now my home button only directs to Google Assistant. Long press, short press, double/triple press.
    I just want to get my home button working again. Please help!
    Samsung Galaxy S7
    Software: G930PVPU4BQD2/G930PSPT4BQD2/G930PVPU4BQD2
    05-11-2017 09:56 AM
  2. Hendleal's Avatar
    I had a software update this morning and now my home button only directs to Google Assistant. Long press, short press, double/triple press.
    I just want to get my home button working again. Please help!
    Samsung Galaxy S7
    Software: G930PVPU4BQD2/G930PSPT4BQD2/G930PVPU4BQD2
    Any luck?? I had this same issue and can't figure it out
    05-11-2017 01:01 PM
  3. CWinkler's Avatar
    Saw this as a way to turn Assistant on or off ... might help you out

    Turn on
    On your phone, touch and hold the Home button.
    When asked if you want to turn on the Google Assistant, tap Yes.

    Turn off
    On your phone, touch and hold the Home button.
    At the top right, tap More and then Settings.
    Next to "Google Assistant," turn off the switch.
    05-14-2017 06:13 PM
  4. Taelorvans's Avatar
    Any luck?? I had this same issue and can't figure it out
    I can't figure it out either and it's driving me crazy. I'm so frustrated.... ☹
    05-26-2017 08:47 PM
  5. cipo3a's Avatar
    Turn off Google assistant:

    Long press the home button
    -> blue button at the top right corner
    -> *triple dots* at top right corner
    -> Setting
    -> *triple dots* at top right corner
    -> Phone
    -> "Google Assistant," turn off the switch.

    Restart you phone. The problem should be fixed now.
    You can turn the assistant on again.
    beckymau likes this.
    06-01-2017 12:40 PM
  6. Jeff223344's Avatar
    I have the same problem and no direct solution but a work around. If you have MacroDroid installed, you can write a simple macro that will bring you to your home screen. Mine works as follows:
    1. Short Press Home button. 2. Google Assistant starts. 3. Swear. 4. Turn phone over and back (face down -> face up). 5. Back to home screen.
    My MacroDroid macro watches for the face down-face up motion (the "Trigger") and goes to the home screen ("Launch Home Screen" action).
    I sure hope Google and/or Samsung fix this!

    Samsung Galaxy S7 Edge. Android 7.0, security patch as of 8/1/2017.
    09-01-2017 10:41 AM
  7. Martin MacRae's Avatar
    Ok I think I've cracked this.

    - if Assistant is on, follow CWinkler's instructions above
    - if when you press the home button you get a popup saying you're missing out on assistant, go into Settings > Notifications and find the Google app. - Turn the notifications off
    - Restart your phone

    You should then be back to normal - worked for me anyway!
    09-03-2017 04:00 PM
  8. TimmyTwo2's Avatar
    I had been having this issue for at least a week, but I think I finally figured out what was causing it. I left the Google Beta and went back to the normal Google app then joined the beta again and updated, but I don't think it was Google that was the issue. I have an app called Drivemode that I enabled the accessibility access in the system settings for it, which allows it to control the switches access. I turned off the accessibility for Drivemode this morning and so far so good with the button working. My suggestion is check your system settings under accessibility for anything switched on and try turning it off.
    dwhitcomb likes this.
    09-21-2017 05:58 PM
  9. Gringo 74's Avatar
    Settings > apps > setting icon > default apps > Assist & voice input > assist app

    Then change google to your prefered launcher.

    In my case I just wanted the home button to go to the home screen
    So I selected the "home launcher"app from playstore.
    Then had a home screen widget "Dhome" from playstore to use with the launcher.

    Its working now but what a mission for just a simple task!!
    Jerzgirlz likes this.
    10-04-2017 01:50 PM
  10. Jerzgirlz's Avatar
    Settings > apps > setting icon > default apps > Assist & voice input > assist app

    Then change google to your prefered launcher.

    In my case I just wanted the home button to go to the home screen
    So I selected the "home launcher"app from playstore.
    Then had a home screen widget "Dhome" from playstore to use with the launcher.

    Its working now but what a mission for just a simple task!!
    Gringo 74's instructions worked perfectly. Quite simple and worked. Thank you.
    10-15-2017 09:37 PM
  11. Jerzgirlz's Avatar
    Settings > apps > setting icon > default apps > Assist & voice input > assist app

    Then change google to your prefered launcher.

    In my case I just wanted the home button to go to the home screen
    So I selected the "home launcher"app from playstore.
    Then had a home screen widget "Dhome" from playstore to use with the launcher.

    Its working now but what a mission for just a simple task!!
    Gringo 74's instructions worked perfectly. Quite simple and worked. Thank you.
    10-15-2017 09:37 PM
  12. jbdroid71's Avatar
    Why do any android users put up with with ANY of these "work arounds"? These complaints should go directly to Google for a permanent FIX. Our phones are supposed to be "smart" but instead they are "dumb" I have the same problem using Google assistant with a Plantronics PT Legend. None of the above "solutions" have fixed this issue. Help us Andoid Central!!!

    BTW using Samsung S7 using Android 7.0
    10-23-2017 01:10 PM
  13. jbdroid71's Avatar
    Why do any android users put up with with ANY of these "work arounds"? These complaints should go directly to Google for a permanent FIX. Our phones are supposed to be "smart" but instead they are "dumb" I have the same problem using Google assistant with a Plantronics PT Legend. None of the above "solutions" have fixed this issue. Help us Andoid Central!!!

    BTW using Samsung S7 using Android 7.0
    10-23-2017 01:10 PM
  14. sri v2's Avatar
    Disabled google from settings/apps. Never got this disturbance again!
    Snd delete the voice recordings

    https://history.google.com/history/audio
    Attached Thumbnails Google Assistant Home Button-screenshot_20171205-095240.jpg  
    12-05-2017 04:14 AM
  15. dwhitcomb's Avatar
    I had been having this issue for at least a week, but I think I finally figured out what was causing it. I left the Google Beta and went back to the normal Google app then joined the beta again and updated, but I don't think it was Google that was the issue. I have an app called Drivemode that I enabled the accessibility access in the system settings for it, which allows it to control the switches access. I turned off the accessibility for Drivemode this morning and so far so good with the button working. My suggestion is check your system settings under accessibility for anything switched on and try turning it off.
    I had to uninstall DriveMode to get my home button functionality back. Thanks for the heads-up. I had changed several settings yesterday and wasn't sure which one was causing the problem, but for sure-- it was DriveMode accessibility. Ugh-- so much wasted time.
    12-05-2017 02:36 PM
  16. beckymau's Avatar
    Had this problem this morning, perfect solution.
    12-06-2017 04:32 AM

Similar Threads

  1. Replies: 2
    Last Post: 06-12-2017, 12:27 PM
  2. How to block Google Play Store OTA update in the background?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-11-2017, 01:01 PM
  3. Replies: 1
    Last Post: 05-11-2017, 12:38 PM
  4. Replies: 1
    Last Post: 05-11-2017, 09:54 AM
LINK TO POST COPIED TO CLIPBOARD