09-20-2017 11:58 AM
30 12
tools
  1. tekjock's Avatar
    I got my Galaxy S8 the week it came out, and on Tuesday 5/30 I started having an issue where my work email app was not working correctly (Email app called Good). Whist troubleshooting that, I started to notice that apps would download and show 100% downloaded and then not install. I then do a restart after it would install that app on startup, as well a bunch of notifications, and app updates would pop up.

    The issue started with the Good email app, where I would logon to it, I would get new emails, then it would stay open. Normally the app would lock up after a couple minutes. If I would close out of the app from the in app menu’s. log on to it again and it would work that one time, then stop working again. This is a app that uses a company server.

    Now it seems to be affecting more then one of my devices. I also have a Galaxy Tab A and I cannot seem to install anything on there either. It also seems that the app will download 100%, and then hang. Then minutes, to an hour later it is installed. I have read on some forums that a factory reset has not always worked.

    I have done the following:
    • Reinstalled the Good email app several times using different data sources (Mobile data, 3 different Wifi’s).
    • Restarted the phone numerous times.
    • In the App Manager I have
      • Google Play Store:
      • Cleared Cache
      • Cleared App data
      • Uninstalled updates
      • Google Play services
        • Clicked manage Storage, and cleared all data
      • Google Services Framework
        • Cleared Cache
        • Cleared App data
      • Reset the app preferences
    • From the internal storage settings, cleared the cache
    • [From my tablet] removed google account and re-added

    Things I have not tried yet:
    • Factory Reset – this is the one thing I do not want to do.

    I went to this site http://downdetector.com/status/google-play and I see a comment from today.
    Extra long delay in installing apps or updates after downloading, this has been happening quite regularly sometimes more than an hour. This happens also on my wife's android phone.
    06-06-2017 04:05 PM
  2. dzstoys's Avatar
    Same thing happening with my AT&T S8+.

    I did everything from your list above and went as far as a factory reset and still have the problem, but only from th Google Play store. The Galaxy Apps Store and the Gear Store work fine.

    Not the answer, but I have found that when an install freezes, if I:
    • close all open apps using the recents button and "close all"
    • go back to the Play Store, the app that was stuck will either already have been installed or it will install soon after going back to the Play Store.



    It does not always show up in the "recently updated" list, but the newest version of the app seems to have been installed on my phone.

    This is annoying if I have multiple apps or updates installing, but it seems to be a work around to get apps installed faster.
    PJRed2008 likes this.
    06-06-2017 04:56 PM
  3. PJRed2008's Avatar
    Good post @dzstoys. Google's servers do get overloaded with slowdowns showing up.
    06-06-2017 05:10 PM
  4. Scottage's Avatar
    I started to notice that apps would download and show 100% downloaded and then not install. I then do a restart after it would install that app on startup, as well a bunch of notifications, and app updates would pop up.
    I got a Galaxy S8 Plus from Tmobile about a week ago, and I've been having the same issue, along with another issue that feels related because of the timing. At first, the Google Play store would download apps when I told it to, and installation would begin the instant the download bar hit 100%.

    A day later, I noticed that there was a bit of a delay between the 100% download and the install beginning. A bit later, it seemed to just no longer begin the installation step at all. Sometimes it would finish, but much later.

    The other issue I noticed was that two widgets I had been using would stop updating. (Weather Underground and Ubiquity Music) For both of them, they would work perfectly fine right after install. After maybe a half-hour of use, they would both start to lag behind further and further in refreshing.

    The Weather Underground widget would fall behind, not updating until long after it was suppsoed to. Removing and re-adding the widget would leave it stuck with no data to display for maybe an hour before it finally caught up. If I opened the app itself, it was able to retrieve the update in a second or two, no problem. Only the widget failed. I've used this one for at least a year without issue on two previous phones.

    Ubiquity Music is a media control app that handles whatever is playing, showing titles and album art along with basic controls. After install, it worked flawlessly, frefreshing the track info and album art immediately when the track changed. Maybe a half hour later, it started to fall behind, and a bit later still it just no longer updated at all.

    Just as dzstoys described, I noticed that if I fiddled around with closing apps or restarting the phone, the installs would suddenly finish. Doing this also caused the widgets to refresh. If I cleared the data for Google play and restarted the phone, all of these things would seemed to work fine again for a bit, but the issue always returned shortly after. The issues seem related in some way simply because they come and go at the same time, with the same actions triggering Google Play Store and the widgets to suddenly work for a moment, suggesting that the same thing is causing them to fail... whatever that thing is.

    I've tried all of the troubleshooting steps that tekjock listed, plus I've done two full factory resets. I've run with only the factory-installed apps for a while, and the Google Play issue returns anyway, so it's not any app I'm installing that causes it. (including the aforementioned widgets) The issue happens the same on wifi or via mobile data. I've tried sticking with the default Samsung TouchWiz launcher, and I've tried alternate launchers, no difference there. I tried uninstalling the Secure Folder app, after finding one suggestion online of it possibly being related, but that made no difference either.

    Whatever this is, I hope there's a fix soon. I wasted a LOT of time over the past few days trying to fix an issue that I assumed I had caused somehow.

    EDIT: There was a new Samsung update to download the next day, but the patch notes suggest it's only to make Bixby work better. It had no effect on this issue.

    I did try installing package disabler pro (It wasn't installed during earlier attempts, so it's not a cause for the issue) and disabling Bixby entirely, to see if that might be the cause, but that didn't change the issue either. I tried disabling a few other items that were confirmed bloatware or items I don't use, but again, no effect on the issue.

    I have noticed that this issue extends to notifications as well, though it's a bit harder to spot that. Apps that would normally pop up a notification tend to do it after minutes of delay, rather than immediately.
    06-07-2017 05:49 PM
  5. wodniQ's Avatar
    Hello, I don't think it's only S8 problem, because I have the same on international S7. For about a month ago I've noticed that some my notifications are delayed, I can't install apps from Google Play (the app gets downloaded and stuck) or my samsung weather widget can't refresh. I've tried many methods like factory resets, wiping apps cache but with no results. I see that after wipe, when software is fresh it's working like a charm for about 1-2 hours, but after that the problem returns. I've reinstalled Google Play Services app and it started working again for an hour. So maybe this is a problem? I don't know. waiting for other opinions and solution.
    06-11-2017 12:08 PM
  6. shabbs's Avatar
    Hmmmm - I've been observing this lately on my S8+. Google App updates having issues and my widgets not updating (Weather Underground, MiClock). Very frustrating. Not sure what's up. I'm using Nova Launcher. What is going on?
    06-12-2017 08:35 PM
  7. shabbs's Avatar
    FWIW my issues cleared up by the next morning. Very strange. Almost like the phone is having a brain fart for several hours. Frustrating.
    06-13-2017 01:13 PM
  8. blackfire's Avatar
    This is happening today to two of our devices at home. My wife and I both have Galaxy S8, and both are having issues installing apps. They download fine (based on progress bar and percentage shown at the app page), but they take forever to install. After a long time, sometimes over an hour if at all, then a "installed app" notification may show up.

    This started happening today around 1pm PST. Then we started noticing other issues with the phones:
    1. Sending MMS through Samsung Messages app (default SMS app) is not working.
    2. I used Lightroom to edit a few photos about 2 hours before this started happening; now I wanted to edit a few more, and I can't seem to import any photos to Lightroom.

    I don't know if these are related in any way (probably not?), but I wanted to mention it just in case. I'll update my thread if these issues are resolved around the time the Play Store issues are resolved too.
    06-17-2017 09:09 PM
  9. daniellee004's Avatar
    I've been having the same problem with my Verizon s8+ starting sometime last week. A couple days ago, I realized that I had more than 10 app updates, which I found really strange since I have auto-update turned on. After checking, I saw that the app that was updating was stuck on 100%, and not installing. I tried a factory reset (without properly backing up my data; I lost all my texts, some photos, and am now locked out of my Gear S3), to see if it solved the issue. It did for about a day, but the problem resurfaced. Tried every suggested solution out there, none of them worked. Really frustrated here.
    06-18-2017 08:07 AM
  10. blackfire's Avatar
    This is now resolved for me. I cleared cache and data for both Google Play Store and Google Play Services. Then rebooted the phone again and everything started working fine, including Lightroom. I guess it was more related to Google Play Services than the Store.

    This solved the issue on both mine and my wife's S8.
    06-18-2017 12:24 PM
  11. daniellee004's Avatar
    I tried the clear cache method again, the problem still persists for me.
    06-18-2017 04:51 PM
  12. blackfire's Avatar
    Sorry to hear that. Did you also clear the data, or only the cache?
    06-18-2017 05:17 PM
  13. Voyager555's Avatar
    Try going to settings, apps and locate all the google play programs and check their permissions. I noticed on mine not all were checked and when i selected all of them now it works. I also cleared my gmail sync issue.

    hope it works for you
    06-23-2017 12:08 AM
  14. Marek Wrobel's Avatar
    I have the same issue with Galaxy S7 and tab S3. Google calendar widget also freezes (both devices). Clear data and cache and set permissions didn't help.

    I've noticed that after restart device one app installs correctly and problem stars again.
    07-02-2017 01:53 AM
  15. Elastep's Avatar
    same for me om s8+ att...
    actually even more - seems all background updates are stopping when application install is pending.
    Tried all things I could think of.. No luck
    07-06-2017 04:14 PM
  16. arunma's Avatar
    I'm experiencing the same problem on my T-Mobile Galaxy S8+. Good to know I'm not the only one, and that the S8/S8+ is not the only device affected. If nothing else, it means a factory reset is unnecessary!

    I've noticed that when this happens, if I wait long enough (about two to five minutes), the app in question does end up installing.
    07-06-2017 07:01 PM
  17. Elastep's Avatar
    Yep. It seems like something is making some phone process sleep and then when it's finally woken up for a short period of time the app is being finally installed. I also noticed that in the evening everything worked just fine... So not sure what's going on. Could it be some application security scanner which is down?
    07-07-2017 02:31 PM
  18. rtkwebman's Avatar
    I have this problem on both my Note 4 and my brand new Tab S3, the only fix I could figure out was simply disable the Google app (Google Quick Search). Problem is, this seems to be an issue that needs fixing but how do we know when or even if it is being addressed? When can I start using my Google Search tool and speech to text again? Yes it disables speech to text as well when you disable the Quick Search.
    Fabian_K and leej00 like this.
    07-08-2017 11:11 AM
  19. Fabian_K's Avatar
    Thanks, that worked for me
    07-10-2017 03:28 PM
  20. wgs84's Avatar
    Hello, I don't think it's only S8 problem, because I have the same on international S7.
    Yeah, I don't think this problem is limited to just the S8. I have the Tmo GS7, and sometimes apps would just get stuck at 100% and never install until I force close Google Play and reopen it. And there are a few other issues with my phone that I have good reason to believe are related:

    1. The pictures I save to Private Mode don't show up in the Gallery for 5-10 minutes after I enable it. Then after I turn off Private Mode, the Private Mode albums persist in the Gallery for 5-10 minutes.
    2. If I download a picture from the Internet and then tap on the new notification about it, it will take 5-10 minutes for that picture to open.
    3. If I go to check for new system updates (Download updates manually), it does nothing, and nothing shows up for 5-10 minutes.

    But as soon as one of those problems go away, ALL four of the problems go away, so they must be linked by some underlying cause. It would be great if you guys could confirm your phone is experiencing these issues too.

    I've already reset a bunch of apps, reset Media Storage, wiped the Dalvik. This happened already once earlier this year, and I factory reset it, and now it's happening again.
    07-10-2017 09:54 PM
  21. gernerttl's Avatar
    I was having the same problem on both my S8+ and Tab S2. It seems to be working now. I'm not sure what was causing it.
    07-11-2017 01:25 AM
  22. Marek Wrobel's Avatar
    Hi, I just solve this problem on my both devices (S7, Tab S3). I uninstalled lot's of apps and in some moments everything started to work perfect (after uninstall each app I tested result by change note in Google keep and see if widget refresh - in some moment its starts refresh immediately). Now I love my devices again, and gradually install needed apps, checking if everything works fine.

    My guess is: VLC cause troubles. But I'm not sure, in both cases after uninstall VLC and few more apps problem disappeared.
    07-11-2017 01:41 AM
  23. Elastep's Avatar
    I rrrreally rrreally doubt VLC is the cause.
    VLC does not have any services nor permissions and is not even installed on my phone...
    Still the issue is here.
    07-11-2017 11:53 AM
  24. shaun123456's Avatar
    Hi guys, I was having the same problems described here on my S7 and tab S3. The apps would download at 100% and not install, maybe after a few hour it installs. I also noticed notifications are delayed and the unread markers on app icons are not updated after I read the messages.

    I tried clear data for play store and play services and deleting google account, none of them worked.

    I factory reset my tab s3 and thing worked ok until the google app updated and the next app stuck at 100%.

    So I disabled the google app on my s7 phone and everything returned to normal.

    I informed google about this problem and fix and hopefully they'll figure it out.
    jlhdoes likes this.
    07-12-2017 07:21 AM
  25. Marek Wrobel's Avatar
    Hi,

    So I confirm that this is not VLC problem. Today morning my two devices S7 and tab S3 again stoped refresh widgets and don't install updates. So last time just uninstalling lots off app helped.

    As suggested I stopped Google app and everything started working again. After 1 hour I started Google app again and everything works fine for now. (Both devices the same behavior).

    I use google pixel launcher on both devices, my devices are not official supported. Do you think it can be a problem ? What do you use (launcher ?)
    07-13-2017 02:54 AM
30 12

Similar Threads

  1. Optimizing apps doesn't finish?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2017, 05:58 PM
  2. Installing a bigger SD card
    By Jodel10 in forum General Help and How To
    Replies: 1
    Last Post: 06-06-2017, 05:55 PM
  3. Replies: 1
    Last Post: 06-06-2017, 04:51 PM
  4. usb port not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2017, 03:45 PM
  5. My google bar is not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2017, 03:32 PM
LINK TO POST COPIED TO CLIPBOARD