1. Rhys Dean's Avatar
    When trying to use the maps the full message is shown on a green screen "Google maps needs to change your location settings. When it's safe, check the notification on your phone"

    The phone doesn't do anything when you click this notification. The message only comes up when the S9 locks. All location settings are enabled and I have reinstall android auto and cleared data also from Google maps as well. This message just stays on the screen and you can't go back out of it. All worked perfectly before updating to Android Pie.

    This means android auto is unusable at the minute.

    Help!
    Attached Thumbnails Upadted my S9 to Android Pie and Android Auto has become unusable-20190204_184238.jpg  
    02-04-2019 02:36 PM
  2. osubass1's Avatar
    try going to SETTINGS>BIOMETRICS and SECURITY>LOCATION

    make sure this is turned on.
    02-05-2019 09:32 AM
  3. Berry van Zijp's Avatar
    I've got exactly the same problem. Any idea yet?
    02-07-2019 07:03 AM
  4. Richs9's Avatar
    What a brick i now have after update . Bluetooth now locks up phone when connected to audio device. DO NOT DISTURB now has no setting to allow text and calls only. Volume button no icon to alter other volumes system or media. And this is just on the first day what else will i find.
    02-07-2019 07:26 AM
  5. Rhys Dean's Avatar
    Everything is on.
    02-07-2019 12:08 PM
  6. Rhys Dean's Avatar
    Nope it's really frustrating.
    02-07-2019 12:08 PM
  7. BrianSullivan's Avatar
    I have the same error.
    It effects both Google Maps and Waze. With Waze you don't get the ugly green screen error, instead your location just stops updating.
    I believe that it is related to the "lock screen" time out. As soon as the lock screen happens you get the error.
    02-07-2019 04:25 PM
  8. Rhys Dean's Avatar
    I don't get how they can't test something like this. Seems it's basically unusable until a software update comes out.
    02-08-2019 01:26 PM
  9. lucianus_luciferus's Avatar
    Have you enabled all necessary permissions for the android auto app on your phone?
    02-08-2019 03:03 PM
  10. osubass1's Avatar
    i use Android Auto every day and it works for me without issue.

    I would suggest clearing the app cache and uninstalling it. then download and reinstall it.
    02-08-2019 04:11 PM
  11. Rhys Dean's Avatar
    Yes all enabled.
    02-09-2019 03:07 AM
  12. Rhys Dean's Avatar
    i use Android Auto every day and it works for me without issue.

    I would suggest clearing the app cache and uninstalling it. then download and reinstall it.
    Done numerous times.
    02-09-2019 03:07 AM
  13. kbury's Avatar
    I've got exactly the same issue on my Discover pro since the pie update on my S9.
    Already saw a topic on the Samsung community also.

    https://us.community.samsung.com/t5/...LP/td-p/457283
    02-09-2019 10:25 AM
  14. Berry van Zijp's Avatar
    The issue is solved for me. I've activated Always On Display, after i found out that the connection was working when the phone was unlocked, and the gps signal was lost at the moment the screen turned black. I also checked my energy save settings and disabled the option that the Always On Display can be turned off. Perhaps this can work for you as well!
    02-09-2019 10:46 AM
  15. Berry van Zijp's Avatar
    See my general reply for my solution!
    02-09-2019 10:52 AM
  16. kbury's Avatar
    I turned of the "Energy Save Mode" completely and that solved it
    02-10-2019 03:03 AM
  17. 3029's Avatar
    Turn of power mode, I tried this and seems to now work
    03-04-2019 02:49 AM

Similar Threads

  1. How do i connect to my hifi
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-04-2019, 07:17 PM
  2. Why my TMobile REVVLPLUS won't take pics
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-04-2019, 07:07 PM
  3. I'm using smart launcher 5 with pie
    By robinhelenehebert in forum Samsung Galaxy Note 9
    Replies: 3
    Last Post: 02-04-2019, 06:15 PM
  4. moisture in USB port icon and warning
    By joemontana57 in forum Samsung Galaxy S9 & S9+
    Replies: 2
    Last Post: 02-04-2019, 02:49 PM
LINK TO POST COPIED TO CLIPBOARD