1. rmartin's Avatar
    Just started getting this error while trying to send a text. I've tried pulling battery/restarting, doesn't help. I recetly installed appbrain app and it did some updates to 'talkback', 'google streetview', and amazon mp3. I uninstalled these updates and still get this error. I can receive texts fine. Has anyone seen this, do I need to call Sprint?
    09-11-2010 11:05 PM
  2. njbianco#AC's Avatar
    You need to call sprint.
    09-12-2010 01:31 AM
  3. zeropcs's Avatar
    I have seen an error close to this before, did your city recently start requiring you dial all 10 digits to place a call instead of 7?
    09-12-2010 09:50 AM
  4. rmartin's Avatar
    No, I don't think so, my wife also has an Epic on the same plan and she can send texts fine. I ended up doing a hard reset and its working now. Not sure what would have caused this.
    09-12-2010 10:00 AM
  5. Tecchief's Avatar
    Got similar message a few days ago, started when I tried to send an invite via text for TiKL, I took it in for service, guy at the store/my best friend, tried everything, ultimately had to reset the phone.

    I just tried today to send that invite again via text, error message comes back. Just updated the PRL and rebooted the phone looks like its gone again. I think it might be related to the app but I can't be sure yet.
    09-19-2010 06:14 PM
  6. eriksseven's Avatar
    I've also had this happen several times a few days ago. What I did was deleted the "text message thread" -- or the back and forth conversation I'd been having with the person. Then I went back to my contacts list and started a NEW text message for them (starting over essentially).

    For whatever reason this seemed to create a "good" phone number...

    *FYI* I also didn't think about this as being a LARGER issue--I thought it was probably due to the CRAPPY service I have at my house. This is what led me to try several things, including what I just mentioned.
    09-19-2010 06:56 PM
  7. aceboogie's Avatar
    Had this problem and just set up contacts as mobile and it works for me
    09-19-2010 06:59 PM
  8. tp72's Avatar
    I've had this same problem with the same person. I always have to restart my phone.
    09-26-2010 11:27 PM
  9. egeorge1's Avatar
    My wife has been having this trouble. She found when she changed her contact number to include the area code it worked fine. I haven't had this issue because I always save contacts with the area code included.
    09-27-2010 11:16 AM
  10. Rderosier86's Avatar
    im getting the same issue and just install tikl
    10-09-2010 03:01 PM
  11. rmartin's Avatar
    I got this problem right after I installed tikl also. Uninstalling didn't help, I ended up doing a hard reset to fix the problem.
    10-09-2010 06:43 PM
  12. estebancam's Avatar
    Everyone here needs to go to

    about phone>system updates> update profile

    All the PRL does is update your Preferred Roaming List, in other words, it finds towers that the phone might not have known were there, and it selects the towers to connect to next time you are in that area, as it puts them in a preferred list.

    Updating your profile is what really changes things. It basically re-activates your device on the network. I'm not 100% sure if updating your profile will work, but give it a try. It usually solves every network issue I ever have.
    10-10-2010 12:22 PM
  13. pablomentabo's Avatar
    im getting the same issue and just install tikl
    I just had the same issue after installing TiKL too. The way I fixed it was by going to the contact that I tried to contact in TiKL and deleted all the text messages I had in the built in texting app's history (the whole thread of txts at once). I did this after TiKL was uninstalled but IDK if that really matters. I know one thing, if this is how TiKL will affect my phone then I am not going to try this app out again, I'll stick to txt or sending recorded voice over MMS instead
    10-11-2010 01:52 PM
  14. tlab's Avatar
    I had the Code 0: Bad phone number when using google voice search when I would send text to ... I would try and text my wife with voice commands and I would get this error, but I could send a text manually with no problem. I had the word "[wife]" in her contact in case of an emergency someone could call my wife. I took out the [wife] part and it stopped giving me the bad phone number error.
    02-06-2011 06:33 PM
LINK TO POST COPIED TO CLIPBOARD