1. DangerSwan333's Avatar
    I started noticing this problem last week, but I can't say how long it's been going on for. I got this phone a month ago (it was a replacement for a previous S3 that was malfunctioning), and have not installed any apps that I did not already have on the previous device.

    I noticed, first, that my battery was draining faster than the previous device had. I know that this can kind of be a crapshoot, so I thought nothing of it. I just keep it plugged in to a charger all day, don't use it too often. Then, it started losing battery even during charging. I finally looked at the battery use display, and noticed that the Wi-Fi was always on, even though I had actually manually turned it off (it was showing as off on the statusbar). The only way I could get a break in the Wi-Fi showing as "on" on the battery screen was to turn the phone in to Airplane mode.

    Frustrating enough, I figured I'd do it until I found a fix.

    Starting today, however, not only is the Wi-Fi always on (again, despite being turned off, unless the phone is Airplane), but now the GPS is always on (again, manually turned off). While I can't say this for certain about the Wi-Fi, I do know that no new apps have been installed, and no apps have updated since yesterday when the GPS was NOT always on, and Airplane Mode does not kill GPS. The only option to disable the GPS has been to turn the phone off. By that, I mean, literally having the phone off, as the GPS turns right back on upon powering on the device.

    I've done some research, and found this thread regarding the GPS on an S4, but it doesn't seem to be the same issue.


    I have tried factory reset, and I've also tried restoring it to a mirror of my old device--neither have fixed the issue. Any ideas?
    04-29-2014 04:19 PM
  2. GSDer's Avatar
    Welcome to the forums!
    I've also tried restoring it to a mirror of my old device
    I'm not sure what you mean by that statement, but if a Factory Reset didn't help and you're having weird problems then I'd suggest reloading the firmware from scratch. If that doesn't help then your replacement needs to be replaced.

    Using the Samsung Kies software would probably be the safest way to go about reloading the firmware.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-30-2014 01:35 AM

Similar Threads

  1. New M8 and will only work on WIFI!
    By rich 89 in forum HTC One M8
    Replies: 9
    Last Post: 05-02-2014, 03:46 AM
  2. Watchon problem and update?
    By Kulu21 in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 2
    Last Post: 04-30-2014, 03:33 PM
  3. usb computer android file not working
    By amysorel12 in forum Huawei
    Replies: 0
    Last Post: 04-29-2014, 01:23 PM