01-06-2012 12:23 AM
36 12
tools
  1. jrdatrackstar1223's Avatar
    For those who have figured out how to do this...is it possible to use Google Voice for only visual voicemail? It has been causing me a lot of battery drain lately, and I think its due to it retrieving my text messages.
    05-30-2011 03:06 AM
  2. jrdatrackstar1223's Avatar
    Bump....I know someone on here knows how to do this. I keep seeing people say "you don't need to integrate GV for visual voicemail" but never give steps on how to set up GV that way.
    05-30-2011 04:19 AM
  3. debh945's Avatar
    Sign into your GV account from your computer, go to your GV settings and choose "Disable Sprint Integration". You can set up GV voicemail from here also.

    And fyi, it is the middle of the night for most folks, it doesn't do much good to bump a 1 hour post. Be patient, someone will help you.

    Sent from my Nexus S 4G using Tapatalk
    05-30-2011 04:46 AM
  4. eddieras's Avatar
    i found the following directions on google help, posted by beastwork - i also use GO SMS Pro and after following these directions GO SMS handles everything. the regular texts of course but also the transcribed voice mails all show up in GO SMS and i get notifications only from GO SMS.

    SOLUTION: ok folks I figured this out on the nexus running gingerbread.

    took a lot of testing but I have my phone set up so exactly the way I think most of you would like to have it.

    Here is the action i'm getting
    - stock Android messenger is now capturing complete text conversations, similar to pre Google voice installation
    - GV is still capturing text conversations on my phone and and on the GV internet service
    - I have eliminated all notifications from GV (however my phone is still capturing all GV data)
    - I am getting SMS and voice mail alerts through Stock android messenger service (no duplication from GV)

    Here are the steps (from Google Voice and disabling text messages on Nexus S. - Google Voice Help)
    Stock android messenger (Settings)
    1. Check auto-retrieve
    2. Check Notifications

    Google voice (Settings)
    1. Sync and notifications settings
    2. check "text messages" and nothing else. do not check "Synchronize Inbox" and do not check "inbox notifications"

    In online Google Voice settings
    1. "Phones" --> edit google voice enabled phone --> check "Receive text messages on this phone"
    2."Voicemail & Text" -->check "send a text (SMS) message to [your phone]"
    05-30-2011 06:51 AM
  5. jrdatrackstar1223's Avatar
    Sign into your GV account from your computer, go to your GV settings and choose "Disable Sprint Integration". You can set up GV voicemail from here also.

    And fyi, it is the middle of the night for most folks, it doesn't do much good to bump a 1 hour post. Be patient, someone will help you.

    Sent from my Nexus S 4G using Tapatalk


    Thank you for your help. Unfortunately, when I chose to not have Sprint integration and perform a test call, the message I receive as the caller is "Please enter the phone number you wish to dial". The only way I can configure my visual voicemail from the website is if I enable my sprint integration.

    Right now I have it set up for sprint integration and turned off call screening and also have it set to only notify me via text message, so its technically what I want I guess (only get notfied via stock android messenger). I guess I'm just trying to get around Google Voice being a battery drain, but to still be to receive my visual voicemail.
    05-30-2011 07:46 AM
  6. jrdatrackstar1223's Avatar
    i found the following directions on google help, posted by beastwork - i also use GO SMS Pro and after following these directions GO SMS handles everything. the regular texts of course but also the transcribed voice mails all show up in GO SMS and i get notifications only from GO SMS.

    SOLUTION: ok folks I figured this out on the nexus running gingerbread.

    took a lot of testing but I have my phone set up so exactly the way I think most of you would like to have it.

    Here is the action i'm getting
    - stock Android messenger is now capturing complete text conversations, similar to pre Google voice installation
    - GV is still capturing text conversations on my phone and and on the GV internet service
    - I have eliminated all notifications from GV (however my phone is still capturing all GV data)
    - I am getting SMS and voice mail alerts through Stock android messenger service (no duplication from GV)

    Here are the steps (from Google Voice and disabling text messages on Nexus S. - Google Voice Help)
    Stock android messenger (Settings)
    1. Check auto-retrieve
    2. Check Notifications

    Google voice (Settings)
    1. Sync and notifications settings
    2. check "text messages" and nothing else. do not check "Synchronize Inbox" and do not check "inbox notifications"

    In online Google Voice settings
    1. "Phones" --> edit google voice enabled phone --> check "Receive text messages on this phone"
    2."Voicemail & Text" -->check "send a text (SMS) message to [your phone]"

    I think this has worked....thank you.
    05-30-2011 07:55 AM
  7. Bujin#IM's Avatar
    That seems to work great - I had pretty much given up on having visual voicemail. Thanks!
    05-30-2011 11:42 AM
  8. Zerocool84's Avatar
    I'm currently using voice only for voicemails. You active it the same way you do on any phone. Go into Google Voice settings then phones tab, click on to blue link to activate Google voicemails on this phone NOT Enable Google Voice on your Sprint phone. When you click activate it'll give you a number to call on your phone and that's it. You must make sure full Google Voice integration NOT enabled on your phone.
    05-30-2011 03:41 PM
  9. jrdatrackstar1223's Avatar
    I'm currently using voice only for voicemails. You active it the same way you do on any phone. Go into Google Voice settings then phones tab, click on to blue link to activate Google voicemails on this phone NOT Enable Google Voice on your Sprint phone. When you click activate it'll give you a number to call on your phone and that's it. You must make sure full Google Voice integration NOT enabled on your phone.
    Can someone please clarify how to do this? I'm curious as to how you can access the voicemail tab when you select to not integrate Sprint? Like I said, when I say not to integrate Sprint, I get no option for voicemail because there is no number to associate voicemail for. When I select not to integrate Sprint, I do a test call to see if visual voicemail works. I get a message (as the caller leaving the voicemail) asking me to "dial the number I wish to call". Again, I thought I said it setup the way I want, but apparently I don't because people are saying they are selecting to not integrate with Sprint.
    05-30-2011 04:39 PM
  10. Zerocool84's Avatar
    Can someone please clarify how to do this? I'm curious as to how you can access the voicemail tab when you select to not integrate Sprint? Like I said, when I say not to integrate Sprint, I get no option for voicemail because there is no number to associate voicemail for. When I select not to integrate Sprint, I do a test call to see if visual voicemail works. I get a message (as the caller leaving the voicemail) asking me to "dial the number I wish to call". Again, I thought I said it setup the way I want, but apparently I don't because people are saying they are selecting to not integrate with Sprint.
    Maybe it's because I've had Google Voice before so I have all the options from my Google Voice account. Have you had Google Voice before? Do you have a Google voice number? You might have to make a Google Voice number to get voicemail only on your phone. Does it show your current phone number then under your number does it had Edit and Delete buttons? Next to those buttons should be "Activate Google voicemail on this phone" in blue and a question mark next to it.
    05-30-2011 05:38 PM
  11. jrdatrackstar1223's Avatar
    Maybe it's because I've had Google Voice before so I have all the options from my Google Voice account. Have you had Google Voice before? Do you have a Google voice number? You might have to make a Google Voice number to get voicemail only on your phone. Does it show your current phone number then under your number does it had Edit and Delete buttons? Next to those buttons should be "Activate Google voicemail on this phone" in blue and a question mark next to it.

    The only options I have are to uncheck Google Voice from my Sprint number. I also have an option to select my e-mail address? Is that what I'm supposed to do? When I select to disable my Sprint number on Google Voice, the page refreshes and I no longer have an option for phone settings. From here, the only way I can get back to the screen to edit stuff on my Google Voice number is if I activate Google Voice on my phone. Then I go back to Google Voice online and make changes.
    05-30-2011 06:25 PM
  12. Kloneicle's Avatar
    Edit: Ok, I got this working.

    Did I have google voice setup previously? No
    Did I have a google voice account ready? Yes (ie; I never completed the 4 step process upon registration)
    Do I have a gmail account? Duh
    Did I have Sprint Intergration Currently Setup? No

    Step 1, login to google voice account, and follow the 4 step guide initially shown as a first time google user and link your phone number to Google.
    Step 2, upon completion login to Google Voice on your phone using the Google Voice App. (You may get a error, don't worry just skip)
    Step 3, configure the Google Voice from the web with the following options, Settings > Voicemail > Edit <your number> > (Send a text (SMS) message to) This Box Needs to be Checked.
    Step 4, go to your Google Voice app on your Phone and go to Menu > Settings > Sync & Notifications > (Synchronize Inbox) This Box Needs to be Unchecked, (Text Messages) This Box Needs to be Checked, (Inbox Notifications) This Box Needs to be Unchecked !TO UNCHECK YOU FIRST NEED TO TURN ON SYNCHRONIZE INBOX, THEN TURN OFF WHEN ITS UNCHECKED!

    I did this, and I have the following results;

    My Number is Listed under Google Voice but the words (SPRINT GOOGLE VOICE) are not shown.
    I receive a single Text Message from Sprint saying I have a voice mail.
    The Google Voice App contains both text and voice mail, but without text message notifications.
    I still receive my Text Messages in my Default Messaging App with the same notifications I had prior to setup.
    There is no duplication of notifications.

    I believe that is what were all looking for.
    05-31-2011 08:46 AM
  13. theblizzard2009's Avatar
    i found the following directions on google help, posted by beastwork - i also use GO SMS Pro and after following these directions GO SMS handles everything. the regular texts of course but also the transcribed voice mails all show up in GO SMS and i get notifications only from GO SMS.

    SOLUTION: ok folks I figured this out on the nexus running gingerbread.

    took a lot of testing but I have my phone set up so exactly the way I think most of you would like to have it.

    Here is the action i'm getting
    - stock Android messenger is now capturing complete text conversations, similar to pre Google voice installation
    - GV is still capturing text conversations on my phone and and on the GV internet service
    - I have eliminated all notifications from GV (however my phone is still capturing all GV data)
    - I am getting SMS and voice mail alerts through Stock android messenger service (no duplication from GV)

    Here are the steps (from Google Voice and disabling text messages on Nexus S. - Google Voice Help)
    Stock android messenger (Settings)
    1. Check auto-retrieve
    2. Check Notifications

    Google voice (Settings)
    1. Sync and notifications settings
    2. check "text messages" and nothing else. do not check "Synchronize Inbox" and do not check "inbox notifications"

    In online Google Voice settings
    1. "Phones" --> edit google voice enabled phone --> check "Receive text messages on this phone"
    2."Voicemail & Text" -->check "send a text (SMS) message to [your phone]"
    awesome, it was driving me crazy that GV took over text messages... now i can get back to stock app. BTW, this works on Optimus S
    05-31-2011 10:18 AM
  14. jrdatrackstar1223's Avatar
    Edit: Ok, I got this working.

    Did I have google voice setup previously? No
    Did I have a google voice account ready? Yes (ie; I never completed the 4 step process upon registration)
    Do I have a gmail account? Duh
    Did I have Sprint Intergration Currently Setup? No

    Step 1, login to google voice account, and follow the 4 step guide initially shown as a first time google user and link your phone number to Google.
    Step 2, upon completion login to Google Voice on your phone using the Google Voice App. (You may get a error, don't worry just skip)
    Step 3, configure the Google Voice from the web with the following options, Settings > Voicemail > Edit <your number> > (Send a text (SMS) message to) This Box Needs to be Checked.
    Step 4, go to your Google Voice app on your Phone and go to Menu > Settings > Sync & Notifications > (Synchronize Inbox) This Box Needs to be Unchecked, (Text Messages) This Box Needs to be Checked, (Inbox Notifications) This Box Needs to be Unchecked !TO UNCHECK YOU FIRST NEED TO TURN ON SYNCHRONIZE INBOX, THEN TURN OFF WHEN ITS UNCHECKED!

    I did this, and I have the following results;

    My Number is Listed under Google Voice but the words (SPRINT GOOGLE VOICE) are not shown.
    I receive a single Text Message from Sprint saying I have a voice mail.
    The Google Voice App contains both text and voice mail, but without text message notifications.
    I still receive my Text Messages in my Default Messaging App with the same notifications I had prior to setup.
    There is no duplication of notifications.

    I believe that is what were all looking for.
    this too has worked for me.....thanks everyone
    05-31-2011 10:32 AM
  15. jeffreynothing43's Avatar
    this too has worked for me.....thanks everyone
    It sounds like even though text notifications have been disabled via Gvoice - the texts are still going to it... Is that correct? If so, this is not really a solution in my opinion. I think its really poor that we lost NORMAL Gvoice settings because Sprint thought they would be cute and set it up for people who aren't tech savvy. What a load of ish... Is anyone else annoyed by this?
    06-09-2011 12:36 PM
  16. jrdatrackstar1223's Avatar
    It sounds like even though text notifications have been disabled via Gvoice - the texts are still going to it... Is that correct? If so, this is not really a solution in my opinion. I think its really poor that we lost NORMAL Gvoice settings because Sprint thought they would be cute and set it up for people who aren't tech savvy. What a load of ish... Is anyone else annoyed by this?
    i totally agree....it's not really the answer I was hoping for but it's a "solution" I suppose because it can still take up battery.....
    06-09-2011 02:46 PM
  17. vansmack's Avatar
    There are a lot of solutions here, so I thought I'd just throw in how I did it (updated for Voice App .4.2.36).

    ON THE WEB, GV SETTINGS:

    PHONES: I have my Spint number Enabled as my GV number, under the heading "Sprint Mobile Phones" I have a check box marked "Receive Text Messages on This Phone" and a check next to "Notify Me of new voicemails via text."

    VOICEMAIL AND TEXTS: Put a check in the box next to "Transcribe Voicemails" that way my text notification of a VM also attempts to transcribe the message.

    ON THE PHONE: (v. .4.2.36)

    Open Voice. Got to Settings, then Sync and Notifications.

    - Receive Text Messages "Also via the messaging App."
    - Voicemail Notifications Checked.


    What does this get me?

    SMS notifications on the phone are sent via default SMS app, not GV. However, I can still send/receive texts at voice.google.com when on my computer or tablet.

    VM is all handled through GV, and notifications of new VM are sent to my phone via text with an attempt at transcription (IE, visual voicemail). I can still listen to all VM by calling myself (VM), through the GV App on the phone or via voice.google.com.

    Hope that helps. It's the near perfect solution for my needs right now, until Google separates VM and SMS (oh and adds MMS support!).
    06-09-2011 03:40 PM
  18. bmathe02's Avatar
    @vansmack

    When I do the step:

    "You should also check your phone settings (Home Screen->Menu->Settings->Call Settings->Voicemail Service->Google Voice"

    I do not have any other option other than my carrier.

    But it seems to work just fine. However I do get a copy of the texts in my google voice app. I want to ask if that is the same for you as well.
    06-09-2011 06:10 PM
  19. gramamoose's Avatar
    Does this also allow to send and recieve texts while on a call???
    Every phone I've had up to this one has been able to do that. Including the Epic 4G.
    I did not have GV on either of those so I didn't know it was going to disable that.
    I do want to keep visual vm but also want to be able to text while on a call. I do that a lot (believe it or not).
    As well as GV not being able to send/recieve picture texts. What's up with that???

    Also, when I use call waiting, it returns to screening calls. Is there anyway to disable that? It is annoying!!!
    06-09-2011 07:17 PM
  20. gramamoose's Avatar
    i found the following directions on google help, posted by beastwork - i also use GO SMS Pro and after following these directions GO SMS handles everything. the regular texts of course but also the transcribed voice mails all show up in GO SMS and i get notifications only from GO SMS.

    SOLUTION: ok folks I figured this out on the nexus running gingerbread.

    took a lot of testing but I have my phone set up so exactly the way I think most of you would like to have it.

    Here is the action i'm getting
    - stock Android messenger is now capturing complete text conversations, similar to pre Google voice installation
    - GV is still capturing text conversations on my phone and and on the GV internet service
    - I have eliminated all notifications from GV (however my phone is still capturing all GV data)
    - I am getting SMS and voice mail alerts through Stock android messenger service (no duplication from GV)

    Here are the steps (from Google Voice and disabling text messages on Nexus S. - Google Voice Help)
    Stock android messenger (Settings)
    1. Check auto-retrieve
    2. Check Notifications

    Google voice (Settings)
    1. Sync and notifications settings
    2. check "text messages" and nothing else. do not check "Synchronize Inbox" and do not check "inbox notifications"

    In online Google Voice settings
    1. "Phones" --> edit google voice enabled phone --> check "Receive text messages on this phone"
    2."Voicemail & Text" -->check "send a text (SMS) message to [your phone]"


    Answering my own question, , ,
    This worked to return my texting while on the phone. . .
    And it also sent me a text to stock android sms of a vm, and even transcriped it!
    Only thing I have yet to try is the call waiting. . .
    06-09-2011 07:43 PM
  21. jeffreynothing43's Avatar
    Ok, here it comes… I was extremely frustrated with the Sprint/Gvoice integration and was not happy with the work arounds provided on any of the forums. I imagine I am not the only person who is frustrated that we couldn’t use Gvoice like we did prior to the Nexus S4G. Anyhow, I found a REAL solution – a fix!! I did this yesterday and can verify this really does work.

    So I flashed a stock deodexed ROM…I imagine this will work even with people just running stock, but since I already had Gvoice running correctly on my stock I flashed Gerbil ROM to test. Just go in and remove the Gvoice apk. Reboot. Then go to the market and download Gvoice. At first it was giving me force closes, but I rebooted and it let me enter the app after. After I had downloaded the app from the market and went to set up my Gvoice account it went through the NORMAL process of setting up. It did not ask for integration or anything close to how it was setting it up with Sprint’s Gvoice app that came on the phone. Anyhow – I can verify that this did indeed work. I hope that this helps some people

    And just to add...here's a little blurb I found about Google Voice that may give some insight as to where Google is going with this...

    http://www.engadget.com/2011/06/10/g...-old-ones-for/
    06-10-2011 08:30 AM
  22. vansmack's Avatar
    @vansmack

    When I do the step:

    "You should also check your phone settings (Home Screen->Menu->Settings->Call Settings->Voicemail Service->Google Voice"

    I do not have any other option other than my carrier.

    But it seems to work just fine. However I do get a copy of the texts in my google voice app. I want to ask if that is the same for you as well.
    No sir....

    See attached:
    06-10-2011 11:54 AM
  23. bmathe02's Avatar
    I will have to look into this further. thanks
    06-10-2011 12:29 PM
  24. jrdatrackstar1223's Avatar
    No sir....

    See attached:
    WTH...THIS IS EXACTLY WHAT I'M LOOKING FOR. I followed the directions that you posted and I do not have this option in my phone either....
    06-10-2011 12:33 PM
  25. vansmack's Avatar
    When you guys call your voicemail, are you getting Sprint or are you getting GV?
    06-10-2011 12:51 PM
36 12
LINK TO POST COPIED TO CLIPBOARD