1. DomProJr's Avatar
    I recently sold my Galaxy S3 on T-Mobile, i tried to restore it to factory settings to wipe it clean and the whole process went south somehow.

    I have posted a picture with this in hopes as to maybe someone could help me.

    I tried odin and kies, cant seem to move from this screen.

    Please help me...
    Attached Thumbnails Phone Stuck on Firmware Upgrade, sent to samsung, they didnt fix it-20140328_164517.jpg  
    03-28-2014 04:08 PM
  2. Atif78672's Avatar
    same problem i've tried everything and to repair it would cost more than the phone apparently.
    08-11-2014 11:36 AM

Similar Threads

  1. ADB Sideload - "Starting it now on port 5037"
    By andreglud in forum HTC One X
    Replies: 3
    Last Post: 10-27-2016, 07:42 AM
  2. Replies: 1
    Last Post: 07-03-2014, 11:42 PM
  3. WiFi not connecting on Galaxy S4
    By GetsugaTenshou in forum Android 4.4 KitKat
    Replies: 5
    Last Post: 03-29-2014, 08:52 AM
  4. Screen stuck at 0% brightness
    By DWesty in forum General Help and How To
    Replies: 4
    Last Post: 03-28-2014, 07:23 PM
  5. Replies: 0
    Last Post: 03-28-2014, 03:05 PM