1. edwardofcpp's Avatar
    My s4 has had a problem with the sim card for months where it would not be able to detect my sim card. I would randomly get a "sim card not detected" popup, which then forces my phone to restart. After searching online, I was able to find a temporary fix of shoving a piece of paper in the back to apply pressure on a certain area. This made the restarts less frequent but still didn't completely solve the problem. I was satisfied with just this solution, but just yesterday, my phone did the typical sim card restart but instead of the phone loading back up normally, I got a "emergency calls only". The phone detects my sim card (since the notification bar on the top doesn't have a simcard crossed out indicating that it's not detected), but it's saying no service even though I'm hovering around 3 to 4 bars. Specifically, when I open the phone and have the password lock screen come up, I have a (No service) right above the Emergency Call button. Is there anyway to fix this?

    Booting in safemode doesn't change anything, and I already checked my IMEI on tmobile's website and it said this:
    Congratulations! Your device is ready for use. Select one of the SIM cards on the previous page to get started.
    12-02-2015 03:46 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you tried contacting T-Mobile for a replacement SIM?
    12-02-2015 03:54 PM
  3. hubermania's Avatar
    Try rubbing a pencil eraser over the brass pads on the SIM card. Then go to a T-Mo store and get a new SIM card.
    12-02-2015 04:50 PM
  4. edwardofcpp's Avatar
    Nope, I can't until the weekend. I was thinking this was a problem with the actual phone itself and not the simcard, since applying pressure to the back of the phone helps the phone detect the sim card.
    12-02-2015 05:09 PM

Similar Threads

  1. Replies: 5
    Last Post: 12-05-2015, 02:18 AM
  2. Why doesn't my Galaxy S6 Edge send photos or video via text message?
    By AC Question in forum Samsung Galaxy S6 edge
    Replies: 2
    Last Post: 12-04-2015, 01:37 PM
  3. How do I install a new sd card?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 12-02-2015, 03:54 PM
  4. Replies: 1
    Last Post: 12-02-2015, 02:09 PM
  5. Replies: 0
    Last Post: 12-02-2015, 02:04 PM
LINK TO POST COPIED TO CLIPBOARD