Android System Storage Settings Detects SD Card, Files Not Displaying. What could it be?


AC Question

Android System "Storage" Settings Detects SD Card, Files Not Displaying

Being a BLU fan, I have a BLU Neo 4.5. A few days ago, I had this really strange experience; I have my 64 GB external SD card inserted and my phone's storage setting detected it. 64GB. However, when I went to my file browser, it said that no contents were available and when I tried to move an app to the SD card, it said "Could not move app." I rebooted the phone and perfect. I could do it.

However, later, the apps no longer worked. Does anyone know any possible reason as to why this is happening? I'm running Android 4.2.2

What I've Tried, My Guess & More Info

My guess is that I also used this same exact SD card on another phone, moving the same exact apps to it. Maybe formatting the SD will help? I already formatted my phone (factory reset) and so far, the file browser has not yet said that the SD card was empty.

What do you think I should do next? Format the SD Card to be safe, or carry on as it seems to be okay after the device's factory reset? Usually, is something like this more hardware or software-related? From what I know, it's usually software-related.

Also, on a side-note, it says that the phone only supports a 32GB SD, but I have a 64GB inserted and it works just fine, seemingly. Could that also be it?


Well-known member
Oct 17, 2015
Visit site
Re: Android System "Storage" Settings Detects SD Card, Files Not Displaying

I think you could format the SD card just to test it if that does not work try and see if you can test it in another device.