Battery draining fast.

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
My mum has the Sony E4G & when the battery reaches 19-20% she puts it on charge & the phone says it's charging but the battery continues to drop rapidly. Last night it shot down to 1% on charge. We have tried different cables & it still happens. Also the phone takes over 4 hours to charge. The screen on time was 1 hour 54mins then had to be charged. Any idea what the problem is?
 

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
Yes she has Facebook & the messenger app which she has restarted due to the bug but hasn't restarted her phone though. Will try that.

The phone is on 4.4.4 Kit kat & is 14 months old.
 

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
I think the battery is knackered. She had it on charge & it was on 37% she sat down & had something to eat, must of been about 20 mins to 30 mins checked her phone again & it said 100%. Pretty sure that's not normal plus it doesn't turbo charge.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,715
4,876
113
Visit site
I agree that the battery is likely failing. Unfortunately, since the battery isn't user-removable, she would either have to bring it to a repair shop to replace the battery, try replacing it herself (looking on YouTube for any DIY videos), or get a new phone.

Do you know if she typically lets the battery run down to zero or near-zero? If so, that's a good way to shorten a battery's overall lifespan -- advise her to get into the habit of charging her phone when it reaches 30-40%.
 

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
She wants a new phone so looks like we will go that route. She has a few times let the phone go to 0% or near 0%. Last night the phone was on 26% & it turned itself off.
 

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
Looks like the battery has lost the ability to hold a charge now, 3 days before we get the new phone. Yesterday it stayed on 11% & 12% while on charge for ages then went to 100%. Mum took it off charge later & we went out & about 5 mins later her phone beeped to let her no the battery was at 15% so she pulled it out her pocket straight away & it was on 1% so just turned it off. A few hours later we got home & I put her phone on charge the screen lit up saying Sony Xperia then it showed the battery at 100% straight away. This is so weird. Looks like the phone can only be used permanently connected to the charger.
 

Lucy Davies

Well-known member
Mar 14, 2014
1,146
0
0
Visit site
My dad has a similar problem now. When his phone hits 20% the battery goes to 0% within seconds but his phone has done this since day 1. Does the phone just have a bad battery? The phone is a Sony Xperia E4G running android 4.4.4 KitKat.
 

Forum statistics

Threads
943,777
Messages
6,920,012
Members
3,159,225
Latest member
Jason S