Bluetooth phone audio died on me!?!

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
I have a big problem: I can no longer use my Bluetooth headset for phone calls. Media works fine, but I can't hear callers and they can't hear me through the headset. I've tried multiple headsets, and the same thing happens. I found a BT "phone audio" setting for each device that was somehow unchecked for every single one of my devices. I thought, ok, this is odd, let me check off that box so this will work again - IT WON'T LET ME! So now, I cannot make calls from any Bluetooth headset, and can't change the setting to allow it. Does anyone have any ideas on a solution? I did a reset and was able to make it work for one call, but then it went back to not working. I didn't download any new apps, and I can't find a Bluetooth permission in any of the ones I have to see if that was the issue. I can't figure it out and it's extremely irritating!:mad:
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
HA!! After searching several iterations of my problem, it seems I may have found a solution in a very old thread. I recently changed my OK Google settings to allow me to use it from any screen, but for whatever reason, that disables your ability to use a BT headset for phone calls! (What baffles me is this topic was brought up way back during the Kit Kat days and was allegedly fixed with Lillipop, yet, here on Marshmallow, it's back???) I guess I will have to live without that feature which is not a must have. Calls via BT definitely are!!

See below... This didn't fix it
 
Last edited:

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
HA!! After searching several iterations of my problem, it seems I may have found a solution in a very old thread. I recently changed my OK Google settings to allow me to use it from any screen, but for whatever reason, that disables your ability to use a BT headset for phone calls! (What baffles me is this topic was brought up way back during the Kit Kat days and was allegedly fixed with Lillipop, yet, here on Marshmallow, it's back???) I guess I will have to live without that feature which is not a must have. Calls via BT definitely are!!

Wow! Just two nights ago I was going mad trying to figure just this out. Thanks for the tip. Im gonna miss my easier OK Google but I prefer my $140 earpiece work instead!
 

Maher Salfiti

Member
Dec 29, 2012
12
0
0
Visit site
Actually, it didn't work. I went into safe mode and had no issues repeating phone calls through BT, however, after going back to normal mode, the issue came back. This tells me it probably is NOT the Google app, as that is a stock app. Something in a third-party app is more likely the culprit. Now I have to figure out which app update screwed this up! Grrrrrrr!
 

commanderw

New member
Feb 18, 2017
1
0
0
Visit site
I have the exact same issue. Something is wrong here. Have media bluetooth, no cell bluetooth. In the past with an HTC 8 after 1.5 years of owning the device, the bluetooth simply stopped working and would only work after factory resets for a week. This hopefully isn't happening again. Please let me know if you discover a solution.
 

Maher Salfiti

Member
Dec 29, 2012
12
0
0
Visit site
Safe mode was not as successful as I thought at first. Once I turn off Bluetooth and turn it back on, the phone audio setting is off again, and that's whether I actually connect to anything or not. Basically, I have to restart the phone every single time to get any of my headsets to work for a call. I do NOT want to do a factory reset. I may wait for Nougat to see if it gets fixed. So annoying!!
 
Last edited:

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
Actually, it didn't work. I went into safe mode and had no issues repeating phone calls through BT, however, after going back to normal mode, the issue came back. This tells me it probably is NOT the Google app, as that is a stock app. Something in a third-party app is more likely the culprit. Now I have to figure out which app update screwed this up! Grrrrrrr!

Yes, you are correct, it worked twice yesterday and today nothing! I also noted that on the dialer the mute button was grayed out too. It must be an app or the last system update from verizon in December as I know I used bluetooth for calls many times and had no issues.

Nougat users, do you have the same issue or just us left overs?
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
I don't think it was the most recent security patch. I got that in December (I think), but this issue just popped up this last Wednesday. It can't be a third-party app because it also happens in safe mode. I think it is a system app that was recently updated, but who knows which one! I see a couple of Moto users having the same issue as well, so it's not exclusively an HTC problem.
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
A Moto user found a workaround that's slightly better than a restart. Open Bluetooth Share in the list of system apps, and clear the data. You won't lose anything, but it will reset the Phone Audio setting. I'm going to try to get a shortcut set up for that process.
 

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
I have to say at this point Im so fed up with this crap Im seriously considering an IPHONE because they dont pull this crap, and when they do they fix it. No wonder HTC is drowning. I should have gotten the hint after spending 2.5 years taking crappy purple pictures with my M7!
 

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
I just uninstalled "Boost+" and restarted my phone. The bluetooth now works for call (twice). I will try again later and see if it stuck!
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
Well, I hope that works, however, I don't even have that app on my phone! The problem seems to come back once you turn off BT and then turn it back on.
 

TBoltJ

Well-known member
Mar 29, 2011
412
12
0
Visit site
Well, I hope that works, however, I don't even have that app on my phone! The problem seems to come back once you turn off BT and then turn it back on.

Yes, you are correct, I just tried it and once again no bluetooth. Are the Nougat people having this issue too?
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
I haven't done much testing yet but is the best current "fix" just to leave BT on all the time?

A Moto user found a workaround that's slightly better than a restart. Open Bluetooth Share in the list of system apps, and clear the data. You won't lose anything, but it will reset the Phone Audio setting. I'm going to try to get a shortcut set up for that process.

That's one way, or you clear the data in the "bluetooth share" app. Your option is easier, but also kills the battery
 

NEXUS_HTC_PS

Well-known member
Nov 21, 2013
968
0
0
Visit site
I haven't done much testing yet but is the best current "fix" just to leave BT on all the time?

I've been on nougat since November as well, never had any Bluetooth problems. I keep Bluetooth on all the time. I never turn the toggle off. I also never use the power saving modes either. Maybe it has to do with a doze error. If the problem if persistent and a huge annoyance, my recommendation would be to flash the RUU from HTCs website. Start fresh with a fresh flash.

https://forums.androidcentral.com/e...2Fsupport%2From-downloads.html&token=vMu-Crx-
 

Forum statistics

Threads
943,759
Messages
6,919,940
Members
3,159,216
Latest member
Bongo