Can I get some help saving my old phone?


New member
Jul 21, 2015
Visit site
Please Help Save my Old Phone

My apologies if this is addressed elsewhere in the forum, but if it is I couldn't find least, not exactly what I'm dealing with.

Phone: Verizon Samsung Galaxy Nexus (Toro)

I was running an unofficial Cyanogenmod 12.1 on my phone for about 2 months with no problems. Last week the phone just shut off on it's own, and since then I've been stuck.

Here's what I can do (note, all these things can only be done if the phone is plugged in and has the battery response at all if just on battery):

I can boot into the boot loader, and can toggle through the options (recover mode, start, etc), but every time I try to go int recovery the phone restarts, enters the google splash screen for a few seconds, then it flickers and shuts down, showing only the "battery charged" icon.

Same thing happens if I just try to start the phone splash screen, flicker, dead.

I've tried flashing a stable version of CM11 via the CM installer, but the phone just shuts down to the batter icon during the install.

My computer won't recognize the phone via usb (it keeps trying and failing, and trying and failing...again and again and again).

I tried accessing the phone via ODIN to flash the stock android 4.2.2 rom back onto it, but with no luck. Same problem as described above (i can also boot into ODIN Mode, but it stays on "downloading" and never gets past it - again, this is only when plugged in).

Before the crash the battery life was fine, and the "battery charged" icon shows it being fully charged whenever plugged in.

I've tried pulling the battery for long periods of time (overnight, all day, etc). Same result.

I feel like I hard bricked the thing...but if I did I wouldn't expect to be able to turn anything on...

Thanks, in advance for any suggestions!


New member
Mar 14, 2011
Visit site
Re: Please Help Save my Old Phone

I'd you can get the boot loader (fastboot) recognized via USB, it very well may be bricked. It sounds if the boot partition is damaged or corrupted. It almost sounds if the phone got wet and the USB port is damaged somehow. With out replacing parts I'm not sure if you'll get it fixed. You may want to just look for a gently used 1st vzw moto x as a cheap replacement. You'll get a pretty stock experience with it