CM10 Boot Loop, Need Recover, Broken Home Button

BostonBeats88

Well-known member
Mar 16, 2011
151
11
0
Visit site
Hello All! I hope you are doing well in 2013.

Been a while since I've been around the AC Forums since I just replaced the screen on my SGS3 so I'm back from the TB.
I have a unique issue on my hands and I suspect the response is going to be "tough titties."

But here goes....I recently replaced a cracked screen on my SGS3 and the replacement went better than expected (but not perfectly). The screen and digitizer worked great, however after closing my phone up and booting it up I realized that my camera was not being recognized by the phone. Bummer! So I dismantled the phone and checked all the connections. Viola! Camera is working better than ever. Man that thing is sexy... I digress. Unfortunately my home button stopped working. (YIKES!) This was not a huge issue since I just downloaded an app that hangs out in the notification bar:
https://forums.androidcentral.com/e...5hc2F0by5rb2tvcm9kdXlvc2F0byJd&token=1-Tu21ln

Anyway, I was pleasantly rooted running CM10.0 and it was a wonderful time. Then I came across the BT audio issue and decided to go with a nightlies (CM10.1) to see if that resolved the issue. I flashed 10.1 from 1/8/13 and 1/6/13 but didn't like them as much as 10.0 so I flashed back to CM using the CM updater in the settings. The phone rebooted and flashed the nightlies fine however the CM10.0 is stuck in a CM boot ani loop. BUMMER!

So this is the issue, I really would like to boot into recovery or even do that ODIN thing which I am getting mad skills at however with my nonexistent home button (PWR+HOME+VOL up/down) are out of the question!

Do you guys know of any work around. I could even just wipe the phone everything is backed up, I just need to get outta this boot loop.

I think I have already answered my own question: "Sucks for me!"
But you guys are the brightest, most innovative, and best looking crowd around so I thought I'd ask.

Best of luck in 2013, health, wealth and happiness to all!

-BB88
 

paintdrinkingpete

Well-known member
Dec 12, 2009
2,917
276
0
Visit site
Hello All! I hope you are doing well in 2013.

Been a while since I've been around the AC Forums since I just replaced the screen on my SGS3 so I'm back from the TB.
I have a unique issue on my hands and I suspect the response is going to be "tough titties."

But here goes....I recently replaced a cracked screen on my SGS3 and the replacement went better than expected (but not perfectly). The screen and digitizer worked great, however after closing my phone up and booting it up I realized that my camera was not being recognized by the phone. Bummer! So I dismantled the phone and checked all the connections. Viola! Camera is working better than ever. Man that thing is sexy... I digress. Unfortunately my home button stopped working. (YIKES!) This was not a huge issue since I just downloaded an app that hangs out in the notification bar:
https://forums.androidcentral.com/e...5hc2F0by5rb2tvcm9kdXlvc2F0byJd&token=t0kPZT01

Anyway, I was pleasantly rooted running CM10.0 and it was a wonderful time. Then I came across the BT audio issue and decided to go with a nightlies (CM10.1) to see if that resolved the issue. I flashed 10.1 from 1/8/13 and 1/6/13 but didn't like them as much as 10.0 so I flashed back to CM using the CM updater in the settings. The phone rebooted and flashed the nightlies fine however the CM10.0 is stuck in a CM boot ani loop. BUMMER!

So this is the issue, I really would like to boot into recovery or even do that ODIN thing which I am getting mad skills at however with my nonexistent home button (PWR+HOME+VOL up/down) are out of the question!

Do you guys know of any work around. I could even just wipe the phone everything is backed up, I just need to get outta this boot loop.

I think I have already answered my own question: "Sucks for me!"
But you guys are the brightest, most innovative, and best looking crowd around so I thought I'd ask.

Best of luck in 2013, health, wealth and happiness to all!

-BB88

At any point are you able to connect via ADB with the computer? If you can get to the phone via command prompt with ADB, you could issue the command "adb reboot recovery" or "adb reboot bootloader" -- but if you're stuck in a bootloop I doubt this is actually possible.
 

BostonBeats88

Well-known member
Mar 16, 2011
151
11
0
Visit site
At any point are you able to connect via ADB with the computer? If you can get to the phone via command prompt with ADB, you could issue the command "adb reboot recovery" or "adb reboot bootloader" -- but if you're stuck in a bootloop I doubt this is actually possible.

I figured that hooking up the phone via USB and pushing commands is the way to go, however I don't think the phone "checks" a USB connection until it is fully booted (normal booted, or Odin booted) hence my issue.

Those ADB commands are very helpful and I will keep them in mind! Thanks for the response!
 

BostonBeats88

Well-known member
Mar 16, 2011
151
11
0
Visit site
Since I seemed to have stumped you all, I am going to swap out the working LCD (and broken homebutton) with the old (broken screen working home) one in hopes that I can boot into recover and swap the LCDs in the middle. This is the best shot I can think of. Fingers crossed.

Good thing I have some beers and your company. Going to be a long night!

-BB88
 

BostonBeats88

Well-known member
Mar 16, 2011
151
11
0
Visit site
In case you were curious, the Galaxy does not appreciated having the LCD's swapped out. Seems to kick into low power and stops driving the LCD.

Figured that was going to happen. On to plan B!
 

paintdrinkingpete

Well-known member
Dec 12, 2009
2,917
276
0
Visit site
I figured that hooking up the phone via USB and pushing commands is the way to go, however I don't think the phone "checks" a USB connection until it is fully booted (normal booted, or Odin booted) hence my issue.

Those ADB commands are very helpful and I will keep them in mind! Thanks for the response!

That's what I figured -- sounds like a big mess.
 

BostonBeats88

Well-known member
Mar 16, 2011
151
11
0
Visit site
Sure was! I actually got it fixed which is wonderful.

Lessons learned:
1. The home button does not communicate with the mobo via the snap connector that the LCD uses.
2. Instead the home button contains a ribbon with exposed contacts, when the mobo is installed in place there are little tabs that contact the ribbon and communicate with the home button. Its a fickle one! (I literally had the phone in separate pieces, (lcd, mobo, frame) and finagled the home button contact to actually trigger VOL DW+HOME+PWR)
3. It looks possible to install a new home button if yours fails, its a big mess when you have to dig that deep though.
4. If you have a rooted phone save all your links to tutorials, file downloads, and any batch files that you use. It saves headaches.
5. Always follow root procedure.
6. Use caution when using rom updaters (IE CM updater). They love bricking your phone. Instead control it with ROM manager.
7. Back up your roms.
8. Always have a #00 screw driver on hand! :)


I hope that my train wreck of a situation can help some adventurer in the future. I'm always available to PM but I don't check all that frequently.

Happy SGSIII-ing and Rooting!

-BB88
 
Last edited:

Pranjal Mishra1

New member
May 5, 2018
1
0
0
Visit site
hi, I am having the exact same issue, only difference is, my phone doesn't get past samsung
logo. My question: is it possible to fix the home button manually. I have samsung galaxy grand duos I9082!
Any help would be appreciated.
Thanks!
 

Forum statistics

Threads
942,878
Messages
6,916,363
Members
3,158,718
Latest member
Addity