Constant Error: java.lang.SecurityException

TrophyNostalgia

Well-known member
Jul 31, 2013
46
0
0
Visit site
Hey guys,

So I'm not sure if it was after a recent update, but in the last couple of days my HTC 10 has erratically started popping with dialogue on-screen that states the following error message:

"Error: java.lang.SecurityException:
PermissionDenial: writing
com.htc.launcher.LauncherProvider uri
content://com.htc.launcher.settings/favorites?notify=true from pid=28864
uid=10156 requires com.htc.launch
er.permission.WRITE_SETTINGS, or
grantUriPermission()"

This appears for a brief second or two when I switch between applications or when I return to the home screen. It appears that something is attempting to perform a write function or setting adjustment for an HTC Launcher application? However, I don't do any coding, breaking, etc with my phone. Everything online points to this as being a developer code error. Any thoughts how to get rid of this or why it's happening in the first place? :-X

Thanks!
 

kwsv

New member
Jul 21, 2018
3
0
0
Visit site
I'm getting the same message. It started yesterday. Any help would be greatly appreciated!

Thanks bunches!!!
 

pootyash

Well-known member
Jan 22, 2011
118
0
0
Visit site
Me too! This pops up every time I send or receive a message on Textra but stops when switching to "Messages" app. Would this mean the problem is on Textra's end?
 

Caticusrex

New member
Jul 21, 2018
1
0
0
Visit site
Same issue here. It seems to have started when my phone updated Textra. It's definitely all Textra on my end. Any news as to a fix?

Cheers
 
Last edited:

Nikki LikesPandas

New member
Jul 21, 2018
1
0
0
Visit site
Same problem sending and receiving messages on AT&T M8. I switched to Android messages to avoid the error, set it as my default app then went back to Textra. Now I am no longer getting this error, but I've only sent a few messages since. We'll see if it's fixed, maybe this will work for someone else.
 

pootyash

Well-known member
Jan 22, 2011
118
0
0
Visit site
Just heard back from Textra:

"Known issue. Pls disable Badge App Icon in Textra settings which will fix it while the dev team is working on it."
 

Haley Brown2

New member
Jul 22, 2018
2
0
0
Visit site
I to started getting this error a few days ago..I seen textra mentioned in a comment below because I use textra too. Just uninstalled all apps downloaded in the last few days but it's still happening. It's annoying as hell.
 

Tim98TA

Well-known member
Jul 21, 2012
244
3
18
Visit site
Textra update this morning seems to have fixed it. I turned back on the Badge App Icon setting and did not get error.
 

Members online

Forum statistics

Threads
943,735
Messages
6,919,809
Members
3,159,193
Latest member
Captain Fluellen