Could I have bricked my Galaxy S6?

Mohammed Rakayby

New member
Jul 12, 2015
Visit site
bricked galaxy s6??

Hi there,
I've updated my S6 to latest 5.1.1 more than a week ago , then yesterday I left it to charge to come back and see it stuck in a boot loop . So I disconnected it from the charger and tried to reboot in recovery , no response.
then I tried to reboot in download mode , still no response .
Finally when I connected it via usb it was stuck on loop but not the boot one. it kept showing the battery charging icon then it dies , and so on but I managed to boot it in download mode and tried to flash stock firmware via odin (not sure if It's the same as the one already installed or not I tried to go for the latest on sam mobile) .
But Odin displayed "failed" as soon as it started, now when I connect the device I get the error while updating and "use the emergency recovery in smart switch" , I've tried that but it's no good.
Now I'm out of options , any ideas ??
sorry for the long description :)


Well-known member
Jan 13, 2011
Visit site
Re: bricked galaxy s6??

What is your model number is your phone, your country, and your carrier? You more than likely only have 5.0.2 firmware available to you, and unfortunately, you can not downgrade after taking the 5.1.1 update.

Was this an official OTA update or did you use a different international firmware version through odin?

Posted via the Android Central App

Trending Posts

Forum statistics

Latest member