Date/Time/Weather widget

cb2367

Well-known member
Jun 12, 2010
496
1
0
Visit site
The date/time/weather widget is not showing the correct information. The time displayed is one hour ahead of the system time. The weather is not correct. I've restarted the phone several times but it doesn't fix the problem.

Sent from my SPH-L710 using Android Central Forums
 

anon(631531)

Well-known member
Jan 5, 2012
1,586
11
0
Visit site
The date/time/weather widget is not showing the correct information. The time displayed is one hour ahead of the system time. The weather is not correct. I've restarted the phone several times but it doesn't fix the problem.

Sent from my SPH-L710 using Android Central Forums

Try uninstalling the weather app(should be accuweather), and then reinstalling it. Hope that helps. Also make sure that the "location services" are set. The phone must find your location, and the system settings should set the correct time, automatically.
 

cb2367

Well-known member
Jun 12, 2010
496
1
0
Visit site
I didn't change any system settings, so I don't know how the widget could have stopped working.

I removed the widget by long pressing it and then re-adding the weather widget. It still shows incorrect information. All options are selected in location services.

Sent from my SPH-L710 using Android Central Forums
 

Ytsejamer1

Well-known member
Oct 3, 2011
104
0
0
Visit site
By default, the weather/location refresh setting is set to NEVER. My Aunt who has the S3 told me she couldn't figure out why it still said it was sunny an 73 degrees in NY a few weeks ago. I checked into it and lo and behold...by default, refresh is set to never. Go into the applet by clicking on the clock, then go into settings menu and choose your appropriate refresh time.
 

FadedStardust

New member
Jul 11, 2012
3
1
0
Visit site
Or you could just manually refresh the widget using the little refresh button in the lower right corner, that's what I do. Saves battery.

Sent from my SGSII using Tapatalk 2
 

cb2367

Well-known member
Jun 12, 2010
496
1
0
Visit site
The widget was working just fine until the day I posted this message. Location services were enabled. The refresh setting was changed from it's default setting. I happened to be near a Sprint store, so I went in and asked a tech about this. Even when I did the manual refresh, it still didn't update. It turns out that there is sometimes a bug with AccuWeather. The widget is now showing the correct info.

Sent from my SPH-L710 using Android Central Forums
 

Sofya Leyzerova

New member
Mar 10, 2013
1
0
0
Visit site
Found this forum while I was having the same problem after the time change for Daylight Savings Time. Well, the internet didn't help but I managed to play around with my phone and figured out how to fix it on my own, so maybe this will help others as well.

1. Click on the accuweather clock widget on your screen
2. Click on the icon with the lines on it in the upper right corner of the screen.
3. Now click on the refresh icon at the bottom right corner of the screen.

Voila! Your clock widget should now be showing the right time. Hope this helps! :)
 

Gilbert Limen

New member
Jun 27, 2013
1
0
0
Visit site
Ok dude, I've the same problem with you, but now my problem already solved. Try this. Go to setting, more, and set your date and time. Use the automatic date and time & time zone. If that thing doesn't work. Turn off that and set your real date and time & your time zone. After that, if that thing doesn't work too, use the automatic like before. Hope it's work. :) I did that on my phone. And its work :)
 

Manel Kwon

New member
Jan 27, 2015
1
0
0
Visit site
Found this forum while I was having the same problem after the time change for Daylight Savings Time. Well, the internet didn't help but I managed to play around with my phone and figured out how to fix it on my own, so maybe this will help others as well.

1. Click on the accuweather clock widget on your screen
2. Click on the icon with the lines on it in the upper right corner of the screen.
3. Now click on the refresh icon at the bottom right corner of the screen.

Voila! Your clock widget should now be showing the right time. Hope this helps! :)

Thank you very much, this really work :)
 
Last edited by a moderator:

Jason Wright6

New member
Nov 1, 2015
1
0
0
Visit site
If none of these fix the problem as they didn't with me, here's how to fix it. First go to Settings, Privacy and Safety, Location. Then scroll down and click on Weather. On the next screen click on "clear cache" and "clear data" and choose yes to clear data. Go back to your home screen and the time will be reset to your correct system time and then you will need to re-add your location for the weather. Just click on "use current location" and voila, now your time is correct and weather back to normal.
 

DmitriStupak

New member
Mar 15, 2016
1
0
0
Visit site
What about people who are in static time zones?
After the daylight savings time my weather widget time is an hour behind the phone time and there seems to be no way to fix it - I tried everything suggested here and the two times are still off. I am located in Cayman Islands where we don't shift time an hour ahead and I can't pick a 'cayman islands' time zone as it's not in the list! Any ideas??
 

Trending Posts

Forum statistics

Threads
943,011
Messages
6,916,883
Members
3,158,774
Latest member
Xd3dp1gX