Default Browser won't set

imarek3

Well-known member
Jan 22, 2011
200
1
0
Visit site
When I click on a url in an email or anything else, I get a popup that lists my browsers (browser and chrome), so I click on either chrome or the browser and click Always to set it as the default for that type of action. The next time I click on the same url, I have to go through the same process all over again.

Does anyone have any ideas on how to set the default browser?
 
Jan 10, 2013
10
0
1
Visit site
You can go to app settings, then either the "browser", or Chrome. From either, you can clear defaults, then choose your preferred default browser. You could even disable one if you like.

Sent from my LG-LS970 using Android Central Forums
 

imarek3

Well-known member
Jan 22, 2011
200
1
0
Visit site
When I go into the All Settings > Applications and look at either Browser or Chrome, the Clear Default button is grayed out. So every time that I click on anything that takes me to a web page, I have to choose which browser I want even if I have chosen a browser previously and clicked on Always.

Setting the default browser is not working on my LGOG, which is Stock, non-rooted, not unlocked and on AT&T.

I have used Android for a couple of years and know that this behavior of asking which browser I want to use even when I have selected one and clicked always is not normal.
 

Little Darwin

Well-known member
Jun 11, 2011
335
3
0
Visit site
On my Sprint Optimus G, I simply disabled Browser, and left Chrome enabled as the previous poster suggested. That does what I wanted. As long as you don't have a need for one of them, this should do the job. If there is ever something I need to use something other than Chrome for, I will just go in and enable Browser.

Since the Clear Defaults is grayed out, it sounds like for some reason the default is never getting set for you.