Default calendar setup/"Complete Action Using"

computist

Member
Sep 9, 2010
8
0
0
Visit site
I installed Business Calendar today, and I'd like to make it the default on my phone. Specifically, I want GMail to launch Business Calendar instead of the Samsung Calendar when dealing with Invites I receive.

I don't want to use the Samsung Calendar as the default since apparently, you can't make it use the GMail app for replying to invitations. Everything I've found indicates that it will only use the Email 4.0 app. I'd like Business Calendar to launch instead, but I'm running into this weird loop that I can't get out of:

- If I tap 'Yes' to reply to an invite in GMail, it automatically opens the Samsung Calendar; clicking any of the Reply options here will only launch Email 4.0, as indicated above.

- If I disable the Samsung Calendar, I get the "Complete Action Using" pop-up list, which doesn't include Business Calendar; oddly, it's just the browsers on my phone that show up.

- When I check the "Launch by default" section of both the Samsung Calendar and Business Calendar apps in the App Info section of the Application Manager, I see: "No defaults set" and the "Clear defaults" button is grayed out.

- When I check the calendar settings in Default App Manager, it says "No Default App" and I can select either the Samsung Calendar or Business Calendar. Choosing Business Calendar here as the default has no effect; GMail still launches Samsung Calendar and I'm back in the loop again.

Perhaps a different way to approach this would be to customize the "Complete Action Using" list to display Business Calendar. Is there a way to do that?

I hope all that makes sense. Thanks for your patience as I explained. I searched this and other forums and couldn't find an applicable solution, but if I'm completely blind and stupid, a link to the appropriate thread would be appreciated.
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
Your description was quite clear. I don't use Business Calendar (https://forums.androidcentral.com/e...ps/details?id=netgenius.bizcal&token=OZgHM0sO - I assume it's by this company?) so I don't have anything worthwhile to suggest other than contacting the company business.calendar@appgenix-software.com to see if they can help.
You could try Calendar (201306302): http://market.android.com/details?id=com.google.android.calendar just to see how it behaves; perhaps it'll finally enable the selection box that you're looking for.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
 

computist

Member
Sep 9, 2010
8
0
0
Visit site
Thanks. I tried two or three other third-party calendar apps, just to see what would happen, and it looks like this is somehow coming from the GMail app. I couldn't get the phone to work with anything but the Samsung calendar (not even Google's own calendar app), nor get any of them to appear as usable apps in the "Complete Action Using" options when dealing with Invites.

After some Googling around, I found sort of a workaround with an app called Invitation Plugin. It should have been easier than this (although I don't know if it gets a whole lot easier than installing a small third-party app from the Play store) but it seems to be working now.

Thanks!
 

blade22222

Well-known member
Apr 27, 2011
548
7
18
Visit site
Go to settings, application manager, then hit the menu button, select reset app preferences.

Sent from my SCH-I545 using AC Forums mobile app
 

Trending Posts

Forum statistics

Threads
943,817
Messages
6,920,191
Members
3,159,246
Latest member
RomeoCatcher