Disabling Secure Lockscreen (Lollipop)

MongoXstomp

Member
Jan 12, 2011
10
0
0
Visit site
I was recently messing with the different lock screen security options possible however I noticed that I can no longer go back to "Swipe" to unlock. Does anyone know why this is? That and "none" are grayed out in the settings (see screen shot). Anyone know how to get myself back to swipe to unlock?

Posted via Android Central App
 

Attachments

  • 117378.jpg
    117378.jpg
    25.8 KB · Views: 142

xstinkyx

Well-known member
Nov 30, 2012
248
0
0
Visit site
Weird.

I don't use a screen lock at all. But I wanted to learn about and try out the various option so I went into the settings after reading your post. None and Swipe were disabled for me as well. I then set up a pattern lock (and tested it). Went back to settings and Swipe was still grayed out. Went into credentials (woah, so many) but didn't delete them. Clicked around a bit more and went back into lock settings and None and Swipe were then selectable (I now have it on swipe).

There's probably some easy explanation that will be posted here by someone...
 

Nonymous666

Well-known member
Nov 16, 2012
213
0
16
Visit site
I had a somewhat similar issue. I went to switch from PIN screen lock to none at all. Only to find that "None" was not listed as an option. It wasn't that it was greyed out; it was just not shown as a choice at all. I did a lot of googling and found several discussions of similar problems in earlier Android versions. Lots of talk about clearing credentials to fix it, and talk about people not able to clear credentials because that was greyed out. (as it is for me for some reason.)

I forget exactly what one of the posts I found said, but it gave me the idea of removing Lollipop's new "Guest" user. Once I did that, then "None" reappeared as a lock screen choice when I was "logged in" as myself.

BTW, I actually wasn't able to fully remove the "Guest" user. When I removed it, a new "Guest" was automatically and immediately created to replace it. Not sure if that's the way it's supposed to work (i.e., what if I don't want my phone to have "guest" access?), but at least it fixed my missing "None" lock screen choice.
 

dcnblues

Active member
Nov 20, 2014
25
0
0
Visit site
I use the app 'lock screen widget' which gives me a handsome little button I can leave on home page, but I have to have security on for it to work. I set it at max 30 minutes, but what I'd really like is for the button to activate security, and not have it activated otherwise. Any ideas? Thanks.
 

Tole Kutma

New member
Nov 23, 2014
1
0
0
Visit site
Thanks Nonymous666!!!!!
Removing the "Guest" user works for me and the "none" option is back!!!!!

Very strange behavior.... bad design.....
 

frenziedfemale

Well-known member
Nov 3, 2012
400
0
0
Visit site
Thanks Nonymous666!!!!!
Removing the "Guest" user works for me and the "none" option is back!!!!!

Very strange behavior.... bad design.....

Actually a very good design. If you are using a guest account it would be because you don't want someone accessing your account/settings etc... therefore screen lock security would be a must. You wouldn't want the guest to just go in and disable it. The unfortunate part is that as usual, Google has added this feature without explaining how to use it or how it works. Hence all the confusion
 

Nonymous666

Well-known member
Nov 16, 2012
213
0
16
Visit site
Actually a very good design. If you are using a guest account it would be because you don't want someone accessing your account/settings etc... therefore screen lock security would be a must. You wouldn't want the guest to just go in and disable it.
But using the guest account doesn't require screen lock security on the 'regular' account. It can still use plain old "swipe to unlock". It's only the "None" option that is taken away, not both None and Swipe to unlock.
 

Anish Naik

New member
Feb 11, 2015
1
0
0
Visit site
in settings>security you will find clear credentials options tap on it and it will ask u to clear credentials, clear it you will get your none and swipe options enabled again
 

dcnblues

Active member
Nov 20, 2014
25
0
0
Visit site
Yup, clear credentials is right there. But it's greyed out. Any ideas? As well, I have an option whether to 'Allow phone calls' for guest, but not to remove guest.
 

dcnblues

Active member
Nov 20, 2014
25
0
0
Visit site
Bump. Kind of hoping for some help on this. Really sick of unlocking phone all the time. Would like the lockscreen widget to work without screen lock having to be active.
 

Aidan Host

New member
Nov 16, 2012
1
0
0
Visit site
To remove the guest user, switch to Guest account and then open your quick settings (notification panel) and tap on the user switching icon (top right) and then you should see a Remove Guest option.
 

dcnblues

Active member
Nov 20, 2014
25
0
0
Visit site
Okay, I've done everything on this topic, but am no closer to getting what I want, which is
-Screen lock to be on Pattern
-Automatically lock to be off (there is no such option)
-Screen lock to be activated manually, only by the installed 'Lock Screen Widget' app. A button you can put on your home page which activates screen lock.

Is this or is this not possible? I can't believe there's no way to only lock the phone manually. Many thanks.
 

Gamal Naser

New member
Apr 13, 2015
1
0
0
Visit site
I had the same issue and it was solved after clearing the credentials which store the security pin and passwords. There is another turn aroud, but it is deep surgerical solution by restoring the device to the factory settings.
 

Username91

New member
May 16, 2015
1
0
0
Visit site
thanks, It's works. I remove Guest account from Guest account (Swith Guest account > settings > Accounts > remove Guest) and now, I see Screen option "None" :)
 

Forum statistics

Threads
943,023
Messages
6,916,940
Members
3,158,784
Latest member
sterrekroesbergen