DP5 - won't connect to WIFI

chenks

Well-known member
May 22, 2013
227
0
0
Visit site
installed DP5 on my Pixel 2 last night.
all good except that it won't connect to one of the 2 WIFI networks i use - makes no attempt to connect at all.

the SSID is hidden, so it's a manuall add, correct SSID, correct password.

the iphone sitting next to the phone is currently connected to it with no problems.
the pixel 2 on Oreo also had no problems connecting to it.

used Ping Tools Pro and that even doesn't detect the WIFI network on a WIFI scan.

any ideas?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
That's what beta versions are for. Make a list of everything - the make and model of the router, the settings in the router, the settings in the phone - and submit it as a trouble. It looks as if there may be a DP6 necessary. Better now than when it's already been installed on tens of thousands of phones.
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
No Wi-Fi issues with my Pixel 2 XL on DP5.

You might try resetting the network functions: Settings -> System -> Reset options -> Reset Wi-Fi, mobile & Bluetooth.

You'll have to re-enter your Wi-Fi info and re-pair any Bluetooth devices.
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
it was a clean install, not an upgrade.
so that wouldn't be applicable in this instance.

I don't think you can be sure about that. Have you tried it?

Also, since it is a manual add and a clean install, are you certain that you have entered the correct password? I can't tell you how many times Wi-Fi problems turn out to be a bad password, even in cases where the user was absolutely positive it was being entered correctly.
 

chenks

Well-known member
May 22, 2013
227
0
0
Visit site
yes i can be sure about it.
the phone was wiped, and the wifi network was added.
and please! do you seriously think i'd have posted about a potential bug without having made sure the password was typed correctly!

incidentally, i've found that if i change two advanced settings (not sure if these are new settings or not), then it will connect.
the first setting is "metered" - i manually set that to "unmetered".
the second setting is "hidden networking" - i set that to "yes", although it says this might be a security risk.

note that in Oreo i didn't need to set anything like this for this partilcular WIFI network. it worked simply by entering the SSID and password.
 

Forum statistics

Threads
943,007
Messages
6,916,853
Members
3,158,771
Latest member
planeboy