Droid X2 and 2.3.5

garyhavener

Member
Oct 4, 2011
14
0
0
Visit site
When I bought my phone in October of 2011, it came with gingerbread 2.3.3. The battery life was terrible and the phone was hot without any use at all. Shortly after that, I got an upgrade to gingerbread 2.3.4. The upgrade corrected both problems. This week, my phone upgraded to 2.3.5. Once again, my battery life is terrible and my phone gets hot without any use at all. Is anyone else experiencing these problems? I did a cache clean after the new upgrade.
 

Tuscani03

New member
Jun 2, 2011
2
0
0
Visit site
I was actually on the soak for the test and missed the window to post ...Crazy few weeks..lol// But im not the happiest about the upgrade I guess they just didnt care about giving the X2 any ICS action and just did this as a quick fix.... I bought it when it first came out and am up for upgrade in january and was going to get a new phone....but the phone gods heard my crys and killed my wifes Blackberry 9900 she got last summer and i worked out an early upgrade with verizon and have a Razr Maxx coming in 2 days she is getting the X2 because she doesnt really use her phone other than email and txt with the occational game.....i would say just root if you can and hold out to get a new one i know its not the best advice but i have had tons of dislikes with the X2.... its a solid phone and has a good UI when it workes but thats the problem when it works.....I feel you though my battery life went down the tube when i got the 2.3.5 upgrade, and I unrooted for it im so pissed!!:mad:
 

Devinator

Sūpā Saiya-jin Fō
Jul 27, 2011
3,000
147
0
Visit site
Is anyone else experiencing these problems?

My phone has never really had any battery issues. But, I just started experiencing them about a month ago. I don't remember when my phone was updated to 2.3.5, but, if it was recently, that would explain it. I tried all that I could think of to fix it. At first I thought it was the battery, so, I swapped out to a backup I had, and, it didn't help. Then I figured it was an app or something. Nothing has stood out as the problem yet. I wonder if it has something to do with 2.3.5. :confused:

If I figure out anything that helps, I'll try and remember to come back and post about it.
 

Trending Posts

Forum statistics

Threads
941,673
Messages
6,910,047
Members
3,158,020
Latest member
sipos