Galaxy S4 Keyboard Not Working Properly

Alex Pearce

New member
Aug 13, 2013
4
0
0
Visit site
One feature that I really love about the S4 is that it automatically saves new words you text. However, this feature has suddenly stopped working. This is my second S4 and the same thing happened on that one too! I have all the correct settings turned on, at least I'm like 98% sure I do. I use a lot, and I mean a lot, of curse words. The phone used to have these words saved in my phone so that when I would use the Swype feature, it would bring up one of my added words as a suggested word above the keyboard. The phone seems to be adding new words, but as soon as I back out of the keyboard, it erases everything. It's like it resets every time.

I've already tried going into the settings and clearing the cache and that only worked for about 5 minutes.

**Just a little side note: I've never changed keyboards. I've been using the same keyboard since I first turned the phone on.
 

Alex Pearce

New member
Aug 13, 2013
4
0
0
Visit site
Ok so I found the answer! You need to go into your keyboards settings. So bring up the keyboard, long press on the microphone to bring up more options, then click on the little cog. Make sure "Predictive Text" is turned on. Now here is the part I didn't know about. Click on Predictive Text and from there you can pick which accounts you want the keyboard to learn from. So I clicked on Messaging and now I have no problems. You can also have it learn from Facebook, Twitter, Email, and Contacts.
 

neo656

New member
Sep 1, 2013
1
0
0
Visit site
I've the same issue. Few days ago, everything was working fine. Regular words or special words taught by me were being predicted correctly by Swype keyboard. But now there seems to be a problem. I can't access the words taught by me and am certainly not able to teach it again. I've checked the predictive text setting, it's enabled as always. Thanks to Alex, I've taught it from SMS and contacts. Still seems like it learnt nothing!
Not a single new word.
 

linda nguyen1

New member
Oct 14, 2013
1
0
0
Visit site
same problem me.. its driving me crazy! i even tried adding my words to my contacts and its not working at all. my phone just isnt learning. it learns it when i type it out ten times but once i erase the text, it seems the word from the dictionary is erased as well.... all my settings are checked off correctly and nothing works! SOMEONE PLZ HELP ME ):
Also it was working from just last week..... i havent changed any settings or nothing idk why it would suddenly do that :(
 

troshs

Trusted Member
Jul 6, 2013
713
0
0
Visit site
Holy crap! I had no idea that setting was there. I was able to clean out all the stuff my phone kept adding to the clipboard inadvertently. Glad I read this.

Posted via Android Central App
 

Even Keiseraas

New member
Dec 19, 2013
1
0
0
Visit site
Yeah... But my keyboard does not work at all.. So i can't go to google store. (I can do it on the computer. But i need to log in on my phone when i download Swiftkey or Swype)
 

BluSkye218

New member
Oct 14, 2013
3
0
0
Visit site
One feature that I really love about the S4 is that it automatically saves new words you text. However, this feature has suddenly stopped working. This is my second S4 and the same thing happened on that one too! I have all the correct settings turned on, at least I'm like 98% sure I do. I use a lot, and I mean a lot, of curse words. The phone used to have these words saved in my phone so that when I would use the Swype feature, it would bring up one of my added words as a suggested word above the keyboard. The phone seems to be adding new words, but as soon as I back out of the keyboard, it erases everything. It's like it resets every time.

I've already tried going into the settings and clearing the cache and that only worked for about 5 minutes.

**Just a little side note: I've never changed keyboards. I've been using the same keyboard since I first turned the phone on.

Ok so I found the answer! You need to go into your keyboards settings. So bring up the keyboard, long press on the microphone to bring up more options, then click on the little cog. Make sure "Predictive Text" is turned on. Now here is the part I didn't know about. Click on Predictive Text and from there you can pick which accounts you want the keyboard to learn from. So I clicked on Messaging and now I have no problems. You can also have it learn from Facebook, Twitter, Email, and Contacts.

Thank you SO much Alex!! I had a Galaxy S4 Active phone (with OS 4.2.2) that I loved & everything was working great, until they pushed out OS 4.3, then OS 4.4.2 & I had tons of problems - turns out the stopped pushing out 4.4.2 because of the problems - long story short, I got a warranty replacement phone. But, the Predictive Text wasn't working.

As you mentioned, it seemed like it would remember words while I was texting, but as soon as I got out of texts & went back later, the words I thought it had learned were gone. I checked the settings & Predictive Text was enable - so I tried disabling it & re-enabling it, I tried switching from Samsung Keyboard to Swype keyboard, then back again - nothing seemed to work.

But then, I saw your post that the Predictive Text setting wasn't just a toggle to turn the feature On/Off, you could click on it as well to get more settings for it - & now that I've set it to Learn From Messages (SMS) - it works! Yea!!

Thank you!!

P.S. - I hate when everyone's solution is just to download a new keyboard - sweeping a problem under the wrong is not a solution I'll accept. When a feature that is supposed to work, isn't - I want to find a real solution, or an actual fix to the problem. Besides, I like the keyboard that comes on the phone & have tried others (on my husband's phone while trying to find him a replacement keyboard for his because his doesn't have the designated # row) and don't like them.
 

Barry Carter

Member
Oct 22, 2014
6
0
0
Visit site
Go to settings, Application manager and slide the bar at the top to ALL then scroll down to Samsung Keyboard. Select it and click CLEAR DATA. Then go back to home screen, select settings, MY DEVICE and scroll down to Language and input. Click it then click Sansung Keyboard and then click Predictive text. Turn on the feature and click one of the learning options. I used the Learn from messages.

After that go to home screen and everything should be fine.
 

Trending Posts

Forum statistics

Threads
941,685
Messages
6,910,092
Members
3,158,021
Latest member
tedyleted