• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Gboard Google Keyboard Not Syncing


New member
Dec 15, 2017
Gboard works fine on my Galaxy S7 (android 7.0). On my Galaxy Tab S (android 6.01), it does not sync. On first try it asks my google account to sync with. It seems to sync ok. I can hit 'sync now'. It will indicate the last sync time as if all is ok. But it does not know my words or shortcuts. If I try to go to personal dictionary, I can never get there. Tapping personal dictionary leave the keyboard settings area and brings me to my main settings screen. To be clear, I can get to the gboard dictionary and sync settings, but tapping personal dictionary link on that page sends me back to the main android settings screen. I tried on another tablet we have, Galaxy Tab 4 (android 5.02). Same behavior on this tablet, tapping personal dictionary goes to main android settings screen. There is no personal dictionary and there is no error message. I have removed/reinstalled, enabled all gboard permissions and wiped cache partition.
I was using Swype, it just doesn't get what I am swiping anymore. Way too many wrong words. I tried Swiftkey for about a month. Same thing. I tried gboard and we're like old friends. It just knows what I am about to swipe.