Gear S3 issues with WiFi

vladman

Active member
Dec 15, 2013
33
0
0
Visit site
Hi,

About a week ago, I bought a (used) Samsung Gear S3 Classis (from a good friend).

It's great, but I've got one issue I can't seem to resolve, and searching didn't really produce any relevant results either.

I've got WiFi setting on it to Auto, and I connect it to my 2.4G home network, no problem. Bluetooth on my phone is set to auto turn off later in the evening, and then back on in the morning. When bluetooth on the phone goes off, the phone should pick up the WiFi network, right? However, this never works. Even though I'd manually connected to the network successfully before, when the time comes for the watch to auto-connect, it never does. It says it's "standalone", and when I go into WiFi networks, it shows the correct network and "connecting" beneath it, but it never connects. Only forgetting the network, then manually reconnecting works, and then the cycle repeats itself when the time comes for the watch to automatically reconnect.

I tried rebooting the watch, the phone, and the router and that didn't help.

The watch is on the latest firmware 3.0.0.2.

Does anyone have any suggestions? I
 

themadscientist

Active member
May 26, 2013
38
0
0
Visit site
Hi,

About a week ago, I bought a (used) Samsung Gear S3 Classis (from a good friend).

It's great, but I've got one issue I can't seem to resolve, and searching didn't really produce any relevant results either.

I've got WiFi setting on it to Auto, and I connect it to my 2.4G home network, no problem. Bluetooth on my phone is set to auto turn off later in the evening, and then back on in the morning. When bluetooth on the phone goes off, the phone should pick up the WiFi network, right? However, this never works. Even though I'd manually connected to the network successfully before, when the time comes for the watch to auto-connect, it never does. It says it's "standalone", and when I go into WiFi networks, it shows the correct network and "connecting" beneath it, but it never connects. Only forgetting the network, then manually reconnecting works, and then the cycle repeats itself when the time comes for the watch to automatically reconnect.

I tried rebooting the watch, the phone, and the router and that didn't help.

The watch is on the latest firmware 3.0.0.2.

Does anyone have any suggestions? I

If its anything like the gear s2 I would only use bluetooth mode wifi drained the battery hella quick.
Never really had issues with wifi though on 2