Google Apps not working over WiFi!

kunalvanjare

New member
Mar 28, 2014
1
0
0
Visit site
Hello All!

This is my 1st post here.

I recently swapped my iPhone 3GS for a Moto G and immediately upgraded it to KitKat. Since then I've been facing a variety of problems. Firstly, my camera would intermittently stop working and give the 'Camera Error' message. This was subsequently fixed by Moto when they released an update.

But another problem has been everpresent right from the start. Over my home WiFi, a number of apps requiring Google Sign in fail to work! These are :

1. Play Store
2. Facebook
3. YouTube
4. Google Search (Bing search works just fine!)

These work just fine when i switch off my WiFi and turn to 3G.

I have done a lot of research and tried a number of supposed fixes that worked for other people. They include :

1. Checking the Date & Time on my device
2. Switching to Airplane mode and back
3. Deleting my Google Account & Signing in again
4. Clearing cache, force stop etc

None of these seem to work. But at times, all of a sudden they start working. But it's completely random cause if I try the next day or something, they revert back to their non-functional state.

My WiFi at home runs on Google DNS servers. I can access these websites through my laptop.

I have absolutely no idea over what to do. Any help would be appreciated.

Thanks,

KV
 

Luna1111

New member
May 14, 2015
1
0
0
Visit site
Hi,
I have the exact same problem! I tried everything i could find online but nothing seems to work... I would appriciate if you can update if this issue was solved and what was your solution.
Thank you
L
 

Trending Posts

Forum statistics

Threads
943,803
Messages
6,920,146
Members
3,159,242
Latest member
MelmanVT