Google Now keeps telling me that location service is off.

HunterKen7

Well-known member
Apr 6, 2013
151
0
0
Visit site
Ever since the update yesterday, Google Now keeps telling me that my location service is off. I checked and everything is turned on. I even cleared app data, reset phone, turned on / off google now and it still is telling me that it is off. Anyone else have this problem?
 

HunterKen7

Well-known member
Apr 6, 2013
151
0
0
Visit site
It seems I'm having issues with Location in general. Websites, other apps, weather are all having issues with determining my location. I have everything enabled. Arghhhh
 

LeoRex

Retired Moderator
Nov 21, 2012
6,223
0
0
Visit site
Was it working up until yesterday, or did you just notice (because you were trying out the update to Now)?

Google Location Services piggybacks on you data or Wi-Fi, so it's not like it could be a messed up GPS radio.

Check you Google account settings.. I know there is a location setting buried in there somewhere.

Any recent OS updates?

Sent from my SCH-I200
 

HunterKen7

Well-known member
Apr 6, 2013
151
0
0
Visit site
It was working fine up until yesterday. I've checked everywhere...Settings >> Location >> everything is checked. Google Settings app, everything is checked. It's like Location in general is broken somehow. Websites (google.com) can't get my location, the weather app is saying "My Location" now, and Google Now is telling me location services are off. I'm running stock Sense that came with the ATT HTC One
 

drfyzziks

Member
May 16, 2013
5
0
0
Visit site
Yeah, this is happening to me too. It's not a settings issue - all location settings are enabled, WiFi and GPS are active, etc. Full reboot of phone too, but the problem won't go away.

I suspect it's a bug in the Google Search app - I believe it auto-updated yesterday.
 

SCjRqrQCnBQ19QoYCtdl

Well-known member
Jul 29, 2011
1,322
2
0
Visit site
Mine is fine. I was going to suggest the green google settings app, but sounds like you are saying that is on too.

I know that google now gives the message that location services are off if the google settings app location setting is not on, regardless of the HTC Settings for location.
 

anon(5999904)

New member
May 17, 2013
4
0
0
Visit site
My location settings are definitely on. When i go into google now it says "Location service is off". When i go into maps it says "Please enable a My Location source in system settings". My weather app is just saying "Current location" instead of where i am. The only way location will work now, is if i have the GPS on.
 

SCjRqrQCnBQ19QoYCtdl

Well-known member
Jul 29, 2011
1,322
2
0
Visit site
My location settings are definitely on. When i go into google now it says "Location service is off". When i go into maps it says "Please enable a My Location source in system settings". My weather app is just saying "Current location" instead of where i am. The only way location will work now, is if i have the GPS on.

If it was me, and I was sure I had all the location settings on (phone and google settings app) and it still had the problems after a boot with fast boot off and fast boot on, I would do a factory reset.

If it still didn't work, I would go to AT&T and ask for a replacement. I don't think it is gong to be resolved at that point because it doesn't affect all the phones. I suppose google could have messed something up and could possible push an update but I very much doubt it if it is affecting a small portion of one phone model.
 

drfyzziks

Member
May 16, 2013
5
0
0
Visit site
If it still didn't work, I would go to AT&T and ask for a replacement. I don't think it is gong to be resolved at that point because it doesn't affect all the phones. I suppose google could have messed something up and could possible push an update but I very much doubt it if it is affecting a small portion of one phone model.

Forgot about fastboot - good suggestion, but didn't do the trick. I wouldn't be surprised if yesterday's updates did sneak a little bug in - we've seen that sort of thing before. I'll hold off on the factory reset for a couple days & see what happens.

Thanks.
 

HunterKen7

Well-known member
Apr 6, 2013
151
0
0
Visit site
I found out that it wasn't lying. The GoogleLocationService was not running. No matter what I did, it would not start. Go to Settings >> Apps >> Running and you should see a Google Service with GoogleLocationService running. Here are screenshots from my wide's properly working HTC One:
http://i.imgur.com/oW2nB6X.png
http://i.imgur.com/x3ZARzY.png
I ended up doing a factory reset (not deleting storage) and everything is fine. The service is running again. I dont know what happened!
 

omegis83

Member
Apr 28, 2013
5
0
0
Visit site
My One did the same thing but my theory is that if you turn GPS off, it takes a day or two for Google now to show the change once GPS is restarted. If that makes any sense. I'd get the same message that location services were off. After turning GPS on and it running for some time, the message went away and I started getting my navigation cards.

Sent from my HTC One using Android Central Forums
 

SCjRqrQCnBQ19QoYCtdl

Well-known member
Jul 29, 2011
1,322
2
0
Visit site
My One did the same thing but my theory is that if you turn GPS off, it takes a day or two for Google now to show the change once GPS is restarted. If that makes any sense. I'd get the same message that location services were off. After turning GPS on and it running for some time, the message went away and I started getting my navigation cards.

Sent from my HTC One using Android Central Forums

No that isn't it. I have gps off almost always, and still Google now is getting location info.

Posted via Android Central App
 

Trending Posts

Forum statistics

Threads
946,063
Messages
6,926,219
Members
3,160,062
Latest member
MariaWV