google now not working


New member
Jun 13, 2014

I am from sri lanka. My friend gave his nexus 4 phone to enable google now. I tried every method. I still cannot enable that service. He upgrade his phone to 4.4.3 day before yesterday. google now service( location service) not working for my country. But I have sony xperia z1. I enabled it after upgrade my phone to 4.4.2. even My friend have nexus 5. he also did the same method and now google now is working for his nexus 5. but I tried every method . still cannot enable it for nexus 4. please some one tell me how to do. I downloaded fake gps and tried not work. and I tried to disable google play service and sign out from google now and re enable google now account that method also not working.but that method work for nexus 5 and xperia z1. please tell me how to enable it for 4.4.3 nexus 4.


Retired Moderator
May 23, 2010
Follow the instructions on Google's support page to enable Google Now:

Since updating to 4.4.3, you might also want to consider clearing the device cache by going into recovery. For the Nexus 5, power off the phone, hold volume up+volume down+power. When the start screen displays use power down to select Recovery then power to accept. On the next screen (android with exclamation mark) hold power then press volume up and let go. Use volume down to select Cache and power to accept.

More information to do this in Recovery is available here:

Note: Don't select factory reset as that will clear the device.