Google pixel home button and app switcher button don't work

A

AC Question

Sorry if this is the wrong place to ask this. I found a thread with a similar issue but that solution (hard reset) doesn't seem to work in this case.

What's happening is, my wife has a Google Pixel with Android 7.1. The home button and the app switcher button both seem to register clicks (I touch it and it makes the click noise, does the press animation, and vibrates). However, other than clicking, those buttons don't seem to do anything. The back button still works fine.

Also, the shade can be pulled down, but no notifications show up, and if you pull down again, when it would normally show the quick settings, nothing happens. This all started today with no other changes to the phone. Everything worked fine prior to that.

I've also read that clearing the system cache might help but that option doesn't seem to be available from recovery mode.

Any help would be appreciated.
 

Kilian Wagner

New member
Dec 29, 2016
2
0
0
Visit site
I have the same problems , including each details. Making a reset helps temporary, but the issues coming back after a short period of time.

If you have a long time solution, please let me know.

FYI could find anybody who provides a useful suggestions or even understand the problem so far
 

Sebastian Hening

New member
Nov 14, 2016
2
0
0
Visit site
Same exact issue here. No help from google customer service besides factory reset (which is not a permanent fix)

Let me know if you find anything. Nothing has worked for me so far . WTF google
 

Neoelasticman

New member
Dec 30, 2016
1
0
0
Visit site
Hey, I'm the one that originally asked the question, finally created an account on the forum.

Anyway, we did a factory reset for now, but would be nice to have a better solution in case it comes up a third time.

We have a feeling that a particular app might have something to do with it, but we don't know for sure. The app, Trackr, works fine on my phone, a 6p. But the first time this problem happened on my wife's phone was soon after we installed that. The second time, the app had been installed for a while but she wasn't logged into it. Soon after she did that, the issue came up again. This time we're just not installing it. Fingers crossed.
 

pkcable

Q&A Team Leader, VR Expert
Ambassador
Jun 8, 2010
3,583
28
48
Visit site
Hey, I'm the one that originally asked the question, finally created an account on the forum.

Anyway, we did a factory reset for now, but would be nice to have a better solution in case it comes up a third time.

We have a feeling that a particular app might have something to do with it, but we don't know for sure. The app, Trackr, works fine on my phone, a 6p. But the first time this problem happened on my wife's phone was soon after we installed that. The second time, the app had been installed for a while but she wasn't logged into it. Soon after she did that, the issue came up again. This time we're just not installing it. Fingers crossed.

Thanks for joining! Yea it can definitely be an app! If anyone else can confirm let me know so I can mark this as a "best answer" :)
 

Kilian Wagner

New member
Dec 29, 2016
2
0
0
Visit site
It's like Google isn't really working the problem. I have sent some mails, regarding our issues, and they just have no idea what they could do.

Do you guys have the same that you install the new update 7.1.1. successfully and after a few hours or days the pixel runs on 7.1. again and is ready for the update again?

I will receive a new pixel for change, they said
 

Andrew Beniston

New member
Feb 5, 2017
1
0
0
Visit site
I have this exact same problem, I was using Filmic Pro video app and my storage became full will filming, the app when into a recording loop trying to stop and start, I hit the power button screen went black nothing after about two minutes the phoenix restarted in to safemode, I re-booted and then I have exact same problems OP has, it also seems my mobile network won't kick in, even if I try to manually turn it on. It appears that it's a lot of system side things, like my night time screen won't kick in even though it says it's on. Will talk to Google chat tomorrow see if they can do anything.
 

JPParadise

New member
Feb 20, 2017
1
0
0
Visit site
Same issue. Home button stopped working and app switcher square button too. Back button now needs double click. Also when I pull down the top menu all I get is an option for cellular data. There seems to be no fix and of course I can't back up my music to SD card bc, classically, Pixel has no slot so I am left to do this restore and just deal with it which is ridiculous.
 

GoldJazz45

New member
Jun 17, 2017
1
0
0
Visit site
Exact same issues with me: two home buttons not working and had black screens as well. Did install trackr a couple weeks ago and haven't tried reset yet. I thought it was a storage issue at first but will try to uninstall trackr first, then a reset since it doesn't appear that a solution is coming anytime soon...
 

xmfx

New member
Oct 17, 2012
1
0
0
Visit site
Exact same problem here on Google Pixel. The phone's storage space is nearly full. She said she was editing a picture when the issue started. Restarting the phone doesn't help. We are backing up the photos to google drive now and will try messing with it after that.
 

forbesgmail

New member
Apr 23, 2011
2
0
0
Visit site
Same issue happening here. I didn't install/use a new app, charged my phone while overseas... seems like my phone rebooted (asked for my pin in addition to my fingerprint, which only happens on on a fresh boot). Anyone find a solution? I'd rather not hard reset.
 

Buddha03

New member
Aug 6, 2017
1
0
0
Visit site
I am having the same issue and the only similarities I'm finding is that everyone's memory gets full. After I deleted many photos and videos and dumped them onto a PC hard drive for storage, I powered off for a few minutes. When I turned my phone back on, everything loaded properly and my buttons worked again. I believe the full disc is keeping it from loading properly and it needs space to run. I hope that helps.
 

Quinn Allen

New member
Aug 7, 2017
1
0
0
Visit site
I am having the same issue and the only similarities I'm finding is that everyone's memory gets full. After I deleted many photos and videos and dumped them onto a PC hard drive for storage, I powered off for a few minutes. When I turned my phone back on, everything loaded properly and my buttons worked again. I believe the full disc is keeping it from loading properly and it needs space to run. I hope that helps.

i have recently had this but my storage is nowhere near full, i don't want to do a factory reset as the issue has also turned off back up
 

petebank

New member
Dec 22, 2013
2
0
0
Visit site
I am having the exact same issue too! It just started this morning. Home button will show the little dots when I press it but nothing happens. Same with app switcher. In addition to that... The "settings bar" (not sure what you can the bar that comes down when you swipe from the top) will come down to show the first row but is non responsive including when I try to press the little down arrow to show the rest of the settings. I have to manually go into settings to see each one. My memory is only 60% full and I haven't downloaded any new apps and I don't have any of the apps I've seen mentioned in this thread already. I don't have a ton of time to mess with this and I've already tried rebooting. Guess I'll do a factory reset. I'm really really hoping that it doesn't come back after that. Had anyone had that NOT fix the problem for good?
 

BrianLT80

New member
Sep 22, 2017
1
0
0
Visit site
I am having the exact same issue too! It just started this morning. Home button will show the little dots when I press it but nothing happens. Same with app switcher. In addition to that... The "settings bar" (not sure what you can the bar that comes down when you swipe from the top) will come down to show the first row but is non responsive including when I try to press the little down arrow to show the rest of the settings. I have to manually go into settings to see each one. My memory is only 60% full and I haven't downloaded any new apps and I don't have any of the apps I've seen mentioned in this thread already. I don't have a ton of time to mess with this and I've already tried rebooting. Guess I'll do a factory reset. I'm really really hoping that it doesn't come back after that. Had anyone had that NOT fix the problem for good?

Just started for me this morning. Wonder if there's some update that impacted it.
 

Amb312

Well-known member
Dec 11, 2014
246
0
0
Visit site
Mine has been doing this the last 3 days. If they want me to switch back to the Note, they are doing a great job of convincing me.
 

skippy0667

New member
Sep 24, 2017
1
0
0
Visit site
Started with my Pixel XL yesterday. Have loved it right up until now. Home & app switcher buttons are useless. Also, email is not updating I just realized.
 

Ric Thompson

New member
Sep 25, 2017
1
0
0
Visit site
Started with my Pixel XL also...yesterday. Same...no home button, no app switcher, no email update.

Just called support and doing a factory reset. Not overly optimistic, but working correctly so far.

and i am running 8.0 current updates.
 
Last edited by a moderator: