Google Play Error

Girevik

Member
Jul 17, 2016
22
0
0
Visit site
I upgraded to a new Kindle Fire and am trying to get the Google Play Store installed on it. I was able to get it on my older Fire, but on this one I'm getting the message that the version of the app isn't compatible with my device. Any tips on how to fix this?
 

Forum statistics

Threads
945,084
Messages
6,924,132
Members
3,159,655
Latest member
bonnieeugene