Google Play problem - Error while retrieving info from server [RPC:S-5:AEC-0]


Jun 14, 2010
Visit site

two weeks ago, just before 4.3 Jelly Bean update hit my Nexus 4 I started getting this error: Error while retrieving info from server [RPC:S-5:AEC-0] when trying downloading or updating apps on google play.
I tried everything, updating through WI FI, mobile data, wi fi in two different countries, mobile data in 2 different countries(I am now on holiday ;). Tried all the crap suggested in various forums (clear data and cache from google service framework, google play services, google play store, download manager. tried creating second google account and updating through it, received same error. I even removed updates from Google Play Services as suggested in one of the forums. But now it gets same error as everything else.
The only thing I did not try is remove my main google account from the phone, reset the phone. I REFUSE to do so, because this is my daily phone, it is not meant to be reset every now and then just because google cannot sort out their services. By removing account from my phone I would lose my short messages, I would need to sync my various contacts, disable other syncs which google sets to default even though I don't want it to do so, etc. It is PITA and takes time which I don't really want to spend fixing something which was not my fault in the 1st place. So after two weeks of random tries to fix the problem with aforementioned 'fixes' I ended up with google play store which is now empty and does not show my installed apps in My Apps section, I have 20+(and increasing) apps which are failing every night I connect to wi fi network.
The worst thing of all this is, that I have to write about this problem here, because mighty google decided that google play customers don't have the right to have their own section in support forum if they are not developers. And when I try to write google play team an email, they tell me to call them(or rather they call me). For one, I am between the countries right now as I have been for the last 2 weeks, and them calling me would be impossible. Second, I can explain my problem over email better than over bad phone call with my broken english. In the email, I can post screenshots, explain it properly and give them time to sort out the problem, and give me a proper answer, instead of quick answer by rep who would call me.
Anyway, this is my rant, question: what the **** should I do? Maybe I hope that someone from android central picks up on this and redirects it to google people, because this problem randomly happens to many people during several years in the past. Some fixed it, some did not.

This is screenshots of my problem and current state of my google play: