GPS issue?

KyleBuch

Active member
Oct 31, 2009
33
0
0
Visit site
here recently I have been having to pull the battery out of my Hero to get the GPS to be accurate. I live on the coast, and sometimes the GPS will say that im about 70-100 miles off shore in the middle of the gulf... then when it finally comes back onshore, it cant get a direct lock on m position, its using the cell towers to estimate my position...
Ive had my phone since launch, and havnt had any major issues, just this.
Thanks!
 
Last edited:

rgss06

Member
Dec 5, 2009
12
0
0
Visit site
My phone locates me pretty well, although I am no where near the coast. Have you tried disabling the use wireless networks to determine your position? Maybe then it will just use gps satellites to locate your position. I have all three on, maybe for some reason you might need to disable one or the other to locate your position. I have read that the gps positioning is more accurate than the network one. You probably have tried these, if not I hope that helps.
 

Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
Somethings not right (but you already knew this :) )
Are you running any applications in the background that use location services? Possibly something has your GPS signal locked up.
 

troypolla

Active member
Jan 14, 2010
32
0
0
Visit site
if you want accurate gps locations you must turn on the gps satellites in the location menu. otherwise it just uses the cell towers to figure out where you are.
 

KyleBuch

Active member
Oct 31, 2009
33
0
0
Visit site
Somethings not right (but you already knew this :) )
Are you running any applications in the background that use location services? Possibly something has your GPS signal locked up.


Ya.. I use 2 apps that would use my gps.
radar now and weather channel
Both of those seem to always find my location, or at least close enough to get the local weather.
Perhaps reinstall both apps?
 

Andrew Ruffolo

Well-known member
Jan 5, 2010
3,567
172
0
Visit site
Ya.. I use 2 apps that would use my gps.
radar now and weather channel
Both of those seem to always find my location, or at least close enough to get the local weather.
Perhaps reinstall both apps?

try uninstalling and see if that fixes your issue temporarily. could be messing with your signal. i have no issues, but i only have maps and sprint nav using gps.
 

Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
rufflez is right on. Try uninstalling both, reboot then verify GPS is on. Run it that way for a bit and keep an eye on maps to ensure GPS stays functional.

If all is well for a day or so, try reinstalling the apps one at a time and test again.
 

bbrosen

Member
Dec 31, 2009
15
0
0
Visit site
My first hero had to be returned because of the exact problem, it happened with all stock apps only even, it would correct for a breif time then be off, way off, got it replaced and it fixed that issue, now to get rid of the laggy keyboard, slow and stuttering scrolling and freezes as well as sloooooow app loads, ill be happy
 

Andrew Ruffolo

Well-known member
Jan 5, 2010
3,567
172
0
Visit site
My first hero had to be returned because of the exact problem, it happened with all stock apps only even, it would correct for a breif time then be off, way off, got it replaced and it fixed that issue, now to get rid of the laggy keyboard, slow and stuttering scrolling and freezes as well as sloooooow app loads, ill be happy

You can keep your keyboard working snappy by making sure all your apps not in use are closed. You should have no lag issues when they are closed. If you're running the browser, e-mail, gmail, messages app, plus whatever you have else, its going to be laggy. As far as load time, how long are we talking about? with the apps properly closed, they take like 2-3 seconds to load, and obviously faster (practically instantaneous) if they are open already, or weren't closed prior.
 

Forum statistics

Threads
941,680
Messages
6,910,064
Members
3,158,020
Latest member
sipos