Having to reboot to get a data signal. constantly

SDQB17

Active member
Sep 9, 2012
31
0
0
Visit site
Every. Single.Time. If I am at home, my wifi connection is great. When away from home however is a different story. Every time I pick up my phone to check something, I have no data connection, reboot and I get a great 4g signal...but why do I keep losing it and then not get it back unless I reboot/restart? The phone is 2 weeks old, I guess I am wondering if there is a fix for this, a known issue or should I return the phone? This has been a problem before and after the JB update...Advice?
 

HalizDad

Banned
Jul 17, 2011
1,095
13
0
Visit site
Mine will do that when I'm at work and have a weak signal from time to time. You should be able to turn off mobile data, wait 30 seconds and turn it back on instead of rebooting.
 

brkaras

Well-known member
Jun 21, 2012
396
0
0
Visit site
Every. Single.Time. If I am at home, my wifi connection is great. When away from home however is a different story. Every time I pick up my phone to check something, I have no data connection, reboot and I get a great 4g signal...but why do I keep losing it and then not get it back unless I reboot/restart? The phone is 2 weeks old, I guess I am wondering if there is a fix for this, a known issue or should I return the phone? This has been a problem before and after the JB update...Advice?

Time for a new carrier

Sent from my SAMSUNG-SGH-I747 using Android Central Forums
 

SDQB17

Active member
Sep 9, 2012
31
0
0
Visit site
So you don't think it is the actual radio/antenna on the phone? I have tried turning off mobile data and turning back on, it does not restart it. I should not have to do that all the time to get data access anyway. When I reboot it, and have a 4g or 3g signal...I get a great signal. It's almost like when my phone goes to sleep is when I lose the signal and need to reboot. Because everytime I wake my phone , then swipe the screen to unlock there is no data conn. Unless I am on wifi.
 

anon(19759)

Trusted Member
Apr 30, 2010
1,088
8
0
Visit site
Mine isn't quite as bad, but I do find sometimes that I have to toggle airplane mode to pick up 4G. Seems to get stuck in 3g sometimes. Never completely without a signal like yours though.
 

ansextra

Well-known member
Apr 16, 2011
1,492
63
0
Visit site
My experience is that 4G does not cover an area nearly as thoroughly as 3G does. I've noticed differences going from inside my house to outside my house. That never happened with 3G. I've also had situations where 3G got stuck.
 

SDQB17

Active member
Sep 9, 2012
31
0
0
Visit site
The signal where I live is very strong...(Roseville,Cal., near Sacramento) My phone just seems to not be able to turn on mobile data after I turn off WiFi. If I reboot it turns on fine...I only lose it then when I turn the phone off or it goes into sleep when the screen times out. When I wake up the phone and am away from WiFi, I have no data access until I restart the phone.
 

Randy Orgeron

New member
Aug 20, 2015
4
0
0
Visit site
Was this ever resolved?
I have a Sharp Aquos Crystal (with Boost Mobile), that I purchased in Mar. 2015.
Starting in early August, everytime that I leave my home/office network, I have to
reboot the phone constantly to get any kind of connection. Even in the middle of
an open football field, where the signal is full bars. The phone shows LTE, but
can't connect to anything: Internet, Facebook, Pandora, etc...
Very frustrating.
I even restored the phone to factory default & still the issue persists.
Worked fine for the 1st 5 months.
Can it be the phone ... the carrier ... ?
One of the techs told me that if I reach my data plan limit, this type of thing can happen.
I don't even come close to that.
But then it got me thinking: Could this be some manipulation by Boost Mobile to get
me to upgrade to a higher data plan?
 

ajay kumar50

New member
Jul 13, 2016
1
0
0
Visit site
turn on flight mode. check until signal names come to emergency only. now turn off flight mode. aftr dt turn on mobile data. wait for 20 secs. done. no need to restart.
 

Bryan Luksus

New member
Jun 20, 2015
1
0
0
Visit site
Hey ya'll, I've been experiencing this for the past several months all of a sudden with my HTC One M8 where the pass-off from WIFI to Data doesn't always work - didn't seem to happen until after I updated to my current version of Android 6.0. Any ideas on a fix? Did this go away when anyone updated to 7.0?
 

budgieboy

New member
Mar 6, 2019
1
0
0
Visit site
Every. Single.Time. If I am at home, my wifi connection is great. When away from home however is a different story. Every time I pick up my phone to check something, I have no data connection, reboot and I get a great 4g signal...but why do I keep losing it and then not get it back unless I reboot/restart? The phone is 2 weeks old, I guess I am wondering if there is a fix for this, a known issue or should I return the phone? This has been a problem before and after the JB update...Advice?

I find that if I turn off wifi when at home the 4G comes back on automatically. So turning off wifi seems to do the trick, no reboot necessary :)
 
Last edited by a moderator:

Latest posts

Trending Posts

Forum statistics

Threads
943,742
Messages
6,919,886
Members
3,159,204
Latest member
franzmorais