Help, please!!!

Brian Phillips4

New member
Mar 11, 2014
2
0
0
Visit site
I've been using up till yesterday an Iphone with Straight Talk as my service provider. However, yesterday I switched over to the Galaxy S3. Here is my dilemma, I have followed the apn settings I found for getting it to work with ST- and it works fine, until my phone connects to wifi. The moment my phone connects to wifi- I stop getting any and all texts to the Galaxy- they go to my iPhone (I discovered that this morning when I woke up and had all these texts on my iPhone and none on the Galaxy). I don't even know why the iPhone is still working, because there's no Sims card in it- I took it out of the iPhone and put it into the Galaxy.

So, my question is how do I fix it where I still get my texts on the Galaxy when it's connected to wifi. And, before anyone suggests that I turn off the iPhone- I've already tried that. Still no texts to Galaxy, and they just go to my iPhone when it gets turned back on, and not to my Galaxy when I unhook the wifi.

Frustrated!
 

UJ95x

Retired Ambassador
Aug 26, 2013
9,337
0
0
Visit site
Welcome to Android Central! It sounds like you didn't turn off iMessage on your iPhone before making the switch. Read this article for more info: Issues with texts after moving to Android from iPhone? Here's an easy fix! | Android Central

This is likely the issue. My dad switched from an iPhone 4S to the Moto X recently, and he'd occasionally receive texts even after the service on the iPhone was cancelled.
iMessage should be turned off, and you should call Apple to remove the number from their system.

Sent from my Galaxy S4 running SlimKat 4.4.2
 

Forum statistics

Threads
943,881
Messages
6,920,442
Members
3,159,273
Latest member
Name