Help With Updating My Samsung Galaxy S Fascinate 3G+ To 2.3.3


New member
Aug 25, 2011
Visit site
Hey guys, I really need help with updating my phone. I've tried everything. I downloaded Samsung Kies and connected my phone to my laptop and at first, it said that it connected and the window popped-up saying that there's a firmware update so I tried updating it but then a window popped up saying that its not responding or something and that it had to close. So everything closed for some reason. Now, everytime I try opening Samsung Kies and connecting my phone, but it takes forever and then after like 30 seconds, it says that it cannot connect or something and that I have to disconnect and then reconnect my phone. I try that and it won't work! I've tried this so many times and nothing still seems to work. I've even tried uninstalling Samsung Kies and trying again, but that doesn't work either. This is really pissing me off. I really want to update my phone because it is really slow, it keeps acting up, the battery life sucks and its very laggy. If anybody has the answer to my problem, please share! I even called Samsung Social Hub and they were useless! They told me to send my phone in to Telus or whatever so that they could update my phone. I really don't want to do that because I can't live without my phone lol. :(


Well-known member
Dec 26, 2010
Visit site
I can't put a diffinitive solution out for you. But you have to ignore some of the KIES messages like, USB connection lost and at the left screen CONNECT DEVICE because it drops connection during the download.once it gets to the decompressing files it is close to the point where it toggles the phone to accept the download. Nothing was lost in my phone, market apps, data, settings all came back when done. It takes about 10 minutes to get to the downloading into the phone (a big yellow dowload on the Samsung screen etc) adhear to those messages and leave it alone patiently as the end will be soon enough.

Unless you have a computer problem I suggest and clean reboot of the PC, power off the phone and wait about 20 sec and power back on. I launch KIES first and when its up then plug in the phone, swipe unlocking and select KIES on the phone. I only selected to backup contacts which is quick but wasn't necessary.

Now hope for the best. Unless there is a problem with the cable (USB) you could use a different USB port on the computer as I did on the third try it worked after crossing most of my parts!!!

I had the battery already fully charged with the adapter during this.

Val Killmore

Sep 3, 2011
Visit site
I found that the source of the problem, initially for me, was that the drivers required weren't installed properly via USB.

After several reboots of the PC and phone, I eventually opened Kies, then plugged my phone in and the drivers installed properly (confirmation window with driver list and green check marks). Ever since, I have had no issues with Kies, and Gingerbread.

It was a PITA but it eventually worked. Clean reboots and opening Kies on the PC first, then plugging in the phone seemed to be the key to getting the drivers installed properly.
Then it all went smooth after that, and ever since.

Trending Posts

Forum statistics

Latest member